'guix environment --container' test failure

  • Done
  • quality assurance status badge
Details
4 participants
  • Thompson, David
  • Ludovic Courtès
  • Samuel Lotz
  • zimoun
Owner
unassigned
Submitted by
Samuel Lotz
Severity
normal
S
S
Samuel Lotz wrote on 30 Oct 2015 03:06
failed test
(address . bug-guix@gnu.org)
5632D089.4010909@gmail.com
Failed test for guix-environment-container.sh

I don't know where the version is for guix but I just pulled it
yesterday from savannah.

I'm on Ubuntu 14.04
Guile 2.0.9
libgcrypt11 and 20 are installed
make 3.81-8.2ubuntu3

Thank you,
Sam
======================================
GNU Guix 0.9.0: ./test-suite.log
======================================

# TOTAL: 51
# PASS: 50
# SKIP: 0
# XFAIL: 0
# FAIL: 1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: tests/guix-environment-container
======================================

+ set -e
+ guix environment --version
guix environment (GNU Guix) 0.9.0
Copyright (C) 2015 the Guix authors
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
+ tmpdir=t-guix-environment-13420
+ trap 'rm -r "$tmpdir"' EXIT
+ mkdir t-guix-environment-13420
+ guix environment --container --ad-hoc --bootstrap guile-bootstrap -- guile -c '(exit 42)'
accepted connection from pid 13428, user salotz
+ test 42 = 42
+ mount_test_code='
(use-modules (ice-9 rdelim)
(ice-9 match)
(srfi srfi-1))

(define mappings
(filter-map (lambda (line)
(match (string-split line #\space)
;; Empty line.
(("") #f)
;; Ignore these types of file systems.
((_ _ (or "tmpfs" "proc" "sysfs" "devtmpfs"
"devpts" "cgroup" "mqueue") _ _ _)
#f)
((_ mount _ _ _ _)
mount)))
(string-split (call-with-input-file "/proc/mounts" read-string)
#\newline)))

(for-each (lambda (mount)
(display mount)
(newline))
mappings)'
+ guix environment --container --ad-hoc --bootstrap guile-bootstrap -- guile -c '
(use-modules (ice-9 rdelim)
(ice-9 match)
(srfi srfi-1))

(define mappings
(filter-map (lambda (line)
(match (string-split line #\space)
;; Empty line.
(("") #f)
;; Ignore these types of file systems.
((_ _ (or "tmpfs" "proc" "sysfs" "devtmpfs"
"devpts" "cgroup" "mqueue") _ _ _)
#f)
((_ mount _ _ _ _)
mount)))
(string-split (call-with-input-file "/proc/mounts" read-string)
#\newline)))

(for-each (lambda (mount)
(display mount)
(newline))
mappings)'
accepted connection from pid 13436, user salotz
+ cat t-guix-environment-13420/mounts
/
/home/salotz/guix
/home/salotz/guix/test-tmp/store/mymx77h45s4jbym3g0y02dywkbkkf2fd-bash
/home/salotz/guix/test-tmp/store/1njh72acy1s1glwp9kx5zh13j6jabjr9-guile-bootstrap-2.0
++ wc -l
+ test 4 -eq 3
+ rm -r t-guix-environment-13420
T
T
Thompson, David wrote on 31 Oct 2015 02:44
(name . Samuel Lotz)(address . samuel.lotz@gmail.com)(address . 21792@debbugs.gnu.org)
CAJ=RwfYjW50zN4BrqM_nf3AggBnS9+Z+gh3-Fi1=-jnuiCGYpw@mail.gmail.com
Hi!

On Thu, Oct 29, 2015 at 10:06 PM, Samuel Lotz <samuel.lotz@gmail.com> wrote:
Toggle quote (10 lines)
> Failed test for guix-environment-container.sh
>
> I don't know where the version is for guix but I just pulled it yesterday
> from savannah.
>
> I'm on Ubuntu 14.04
> Guile 2.0.9
> libgcrypt11 and 20 are installed
> make 3.81-8.2ubuntu3

Thanks for the report. I see the issue, but I'm not sure why it's
happening. Could you run the following command and send the output?

guix environment --ad-hoc coreutils --container -- cat /proc/mounts

Thanks!

- Dave
L
L
Ludovic Courtès wrote on 31 Oct 2015 11:29
retitle
(address . request@debbugs.gnu.org)
87d1vv9vq4.fsf@gnu.org
retitle 21792 'guix environment --container' test failure
thanks
L
L
Ludovic Courtès wrote on 12 Nov 2015 12:09
control message for bug #21792
(address . control@debbugs.gnu.org)
87a8qj1nl8.fsf@gnu.org
tags 21792 moreinfo
L
L
Ludovic Courtès wrote on 20 Nov 2015 15:54
Re: bug#21792: failed test
(name . Samuel Lotz)(address . samuel.lotz@gmail.com)
87bnaog1qs.fsf@gnu.org
"Thompson, David" <dthompson2@worcester.edu> skribis:

Toggle quote (16 lines)
> On Thu, Oct 29, 2015 at 10:06 PM, Samuel Lotz <samuel.lotz@gmail.com> wrote:
>> Failed test for guix-environment-container.sh
>>
>> I don't know where the version is for guix but I just pulled it yesterday
>> from savannah.
>>
>> I'm on Ubuntu 14.04
>> Guile 2.0.9
>> libgcrypt11 and 20 are installed
>> make 3.81-8.2ubuntu3
>
> Thanks for the report. I see the issue, but I'm not sure why it's
> happening. Could you run the following command and send the output?
>
> guix environment --ad-hoc coreutils --container -- cat /proc/mounts

Samuel, could you try this with Guix 0.9.0 or ‘master’ and report back?

TIA,
Ludo’.
Z
Z
zimoun wrote on 12 Nov 2019 21:37
Bug#21792 Hunting: status?
CAJ3okZ00V06CtPScpoOtHLZmH_qju1CCnzm-pz4PBQX5Rysh2w@mail.gmail.com
Dear,

This bug was reported more than 3 years ago and it is tagged "moreinfo".
Does it still apply?

If yes, please report any progress.
If no, do you agree to close it?

Thank you in advance for any comments.

All the best,
simon
Z
Z
zimoun wrote on 20 Nov 2019 18:45
(address . 21792-done@debbugs.gnu.org)
CAJ3okZ1ZqvKiYoKqw4EQQRhRWYGEWyTvq70SayndVpPR1z+FFg@mail.gmail.com
Dear,

Thank you for reporting this issue.

Information is lacking to investigate more. If you hit this bug again,
please re-open it.

All the best,
simon
Closed
?