"make check" fails: "guix package: error: socket: Protocol not supported"

  • Done
  • quality assurance status badge
Details
3 participants
  • Chris Marusich
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Chris Marusich
Severity
normal
Merged with
C
C
Chris Marusich wrote on 14 Nov 2015 21:42
(address . bug-guix@gnu.org)
CAEKzfHkAFVxKm1U2ROmgif=+ABRKO2+cRcS=wprqz_-Lim1_XQ@mail.gmail.com
Hi all,

Sorry about that last email. I fat-fingered the send button before I
had finished writing it.

I wanted to let you know that when I ran the following command from
the guix git repository root, the tests during "make check" failed:

guix environment guix -- bash -c './bootstrap && ./configure
--localstatedir=/var && make && make check'

The tests which failed were:

tests/guix-package
tests/guix-package-net

They both failed with the following error message:

"guix package: error: socket: Protocol not supported"

The commit that I was using was 2abcc93. The system I am using is
GuixSD, specifically a 0.9.0 installation of it on a bare metal
laptop. I've attached the test suite log for your reference.

Any idea why these tests failed, and how I can make these tests pass?

Thank you,
Chris Marusich
Attachment: test-suite.log
L
L
Ludovic Courtès wrote on 14 Nov 2015 22:52
control message for bug #21925
(address . control@debbugs.gnu.org)
878u60uu3j.fsf@gnu.org
merge 21925 21924
C
C
Chris Marusich wrote on 15 Nov 2015 11:19
Additional information for bug report: 21925
(address . 21925@debbugs.gnu.org)
CAEKzfHk24d0jxF1SqnY054T4CSDLpfGVov-KW6Ftp-qGtSEMBw@mail.gmail.com
Hi,

I've noticed that I also experience similar failures when I try to
install certain packages. For example, I cannot install ncurses or
autoconf:

marusich@garuda ~$ guix package -i autoconf
guix package: error: socket: Protocol not supported
marusich@garuda ~$ guix package -i ncurses
guix package: error: socket: Protocol not supported

However, I CAN install python:

marusich@garuda ~$ guix package -i python
The following package will be installed:
python 3.4.3 /gnu/store/y5x6c38fzrbfl80jxrgjd6py2k88x12a-python-3.4.3
[... I've omitted the rest of the output ...]

I've noticed that ncurses and autoconf both use the "mirror://" pseudo
protocol; perhaps this is somehow related to the problem?

gnu/packages/ncurses.scm:
...
(package
(name "ncurses")
(version "6.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/ncurses/ncurses-"
version ".tar.gz"))
...
gnu/packages/autotools.scm:
...
(define-public autoconf
(package
(name "autoconf")
(version "2.69")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/autoconf/autoconf-"
version ".tar.xz"))
...

However, the python module uses "https://":

gnu/packages/python.scm
...
(define-public python
(package (inherit python-2)
(version "3.4.3")
(source (origin
(method url-fetch)
version "/Python-" version ".tar.xz"))
...

If there's any way I can provide more information, please let me know.
I'm having trouble debugging this any further because I'm just
starting to learn Guile; no matter what I do I can't seem to make guix
give me additional information beyond "Protocol not supported."

I hope this information helps.

- Chris
L
L
Ludovic Courtès wrote on 16 Nov 2015 17:44
(name . Chris Marusich)(address . cmmarusich@gmail.com)
87wpth3nd1.fsf@gnu.org
Chris Marusich <cmmarusich@gmail.com> skribis:

Toggle quote (9 lines)
> I've noticed that I also experience similar failures when I try to
> install certain packages. For example, I cannot install ncurses or
> autoconf:
>
> marusich@garuda ~$ guix package -i autoconf
> guix package: error: socket: Protocol not supported
> marusich@garuda ~$ guix package -i ncurses
> guix package: error: socket: Protocol not supported

Could you apply this patch:
Toggle diff (16 lines)
diff --git a/guix/ftp-client.scm b/guix/ftp-client.scm
index f02d460..e76f08a 100644
--- a/guix/ftp-client.scm
+++ b/guix/ftp-client.scm
@@ -140,8 +140,9 @@ TIMEOUT, an ETIMEDOUT error is raised."
(let loop ((addresses addresses))
(let* ((ai (car addresses))
- (s (socket (addrinfo:fam ai) SOCK_STREAM ;TCP only
- (addrinfo:protocol ai))))
+ (s (socket (addrinfo:fam ai)
+ ;; TCP/IP only
+ SOCK_STREAM IPPROTO_IP)))
(catch 'system-error
(lambda ()
and then try again, with:

./pre-inst-env guix package -i autoconf

(I can provided more info on how to apply the patch if needed. See also

This may be a regression introduced in 279ec1d.

TIA!

Ludo’.
E
E
Efraim Flashner wrote on 16 Nov 2015 22:08
(name . Chris Marusich)(address . cmmarusich@gmail.com)(address . 21925@debbugs.gnu.org)
20151116230803.5b545467@debian-netbook
On Sun, 15 Nov 2015 02:19:24 -0800
Chris Marusich <cmmarusich@gmail.com> wrote:

Toggle quote (68 lines)
> Hi,
>
> I've noticed that I also experience similar failures when I try to
> install certain packages. For example, I cannot install ncurses or
> autoconf:
>
> marusich@garuda ~$ guix package -i autoconf
> guix package: error: socket: Protocol not supported
> marusich@garuda ~$ guix package -i ncurses
> guix package: error: socket: Protocol not supported
>
> However, I CAN install python:
>
> marusich@garuda ~$ guix package -i python
> The following package will be installed:
> python 3.4.3 /gnu/store/y5x6c38fzrbfl80jxrgjd6py2k88x12a-python-3.4.3
> [... I've omitted the rest of the output ...]
>
> I've noticed that ncurses and autoconf both use the "mirror://" pseudo
> protocol; perhaps this is somehow related to the problem?
>
> gnu/packages/ncurses.scm:
> ...
> (package
> (name "ncurses")
> (version "6.0")
> (source (origin
> (method url-fetch)
> (uri (string-append "mirror://gnu/ncurses/ncurses-"
> version ".tar.gz"))
> ...
> gnu/packages/autotools.scm:
> ...
> (define-public autoconf
> (package
> (name "autoconf")
> (version "2.69")
> (source
> (origin
> (method url-fetch)
> (uri (string-append "mirror://gnu/autoconf/autoconf-"
> version ".tar.xz"))
> ...
>
> However, the python module uses "https://":
>
> gnu/packages/python.scm
> ...
> (define-public python
> (package (inherit python-2)
> (version "3.4.3")
> (source (origin
> (method url-fetch)
> (uri (string-append "https://www.python.org/ftp/python/"
> version "/Python-" version ".tar.xz"))
> ...
>
> If there's any way I can provide more information, please let me know.
> I'm having trouble debugging this any further because I'm just
> starting to learn Guile; no matter what I do I can't seem to make guix
> give me additional information beyond "Protocol not supported."
>
> I hope this information helps.
>
> - Chris
>
>
>
copied from the end of your log:

+ guix package --bootstrap -p t-profile-21455 -e '(@@ (gnu packages commencement) gnu-make-boot0)'
accepted connection from pid 21586, user marusich
looking for the latest release of GNU make-boot0... guix package: error: socket: Protocol not supported

"looking for latest release" is the automagic checker looking for a new
upstream release of GNU make (i think), and the other two, ncurses and
autoconf, I believe also trip the autochecker to see if there's a new
upstream release.

As to the actual error, I'm not sure

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCgAGBQJWSkWzAAoJEPTB05F+rO6TirQP/3IeTdG1vEw1qyGR+A+FRh3m
bmSTVowDB8wuB/IZq/dvtg8wVLqgopyUfYUg/qzJbpoObgGPf42cYr9KmFLqjllO
wtcepbvDj0w0a0eqaEBm2jxTtEy5uNa8DtRyaQUl05hltJPTl9LQv91A0A2FgaOA
5pY/B5B8Sl9UtGasTOl3oHL8DKh1tzQSxoS/UQLSSpptTRY4caqtE5JSmBkKudQ2
bieacZm2QwmWH48SOdxiPJ8EHNgXHKTEVvMZU0owmUJrPEEyjDAOkgWfzCJPAqdO
xWjBRd2vLxv2U4fzah79wDyLfwuW6Xlib9NJXp86bMOaXs/aOWkPckDcY/TwNfU8
OAGIKFKYkYiwOpumsE2wh+w65n6YfboZw2N97UhytlC9wY6S/2r7kstPhnwEMZzk
FKlwJ57b9ebc8EWUSh1NYl0IkJiXDUF5WlsW7sDKQHOXmYdgQ0qUCcz6L4Ue0/iN
jOJN5SAUanvFTcipKgbEzYaJCK1NyoKs75BVkugN9C6p3sXSKeWt95jzD1vaS8R/
avBoxmZJeelSnO7/wLQOJRLPvy/QUGxfTf+mtNXepcu3cuuA8nbDUsIJI/DOIaid
aiI4isQ/8BLEvtcaSLz9bNll0DyaJ4WYnyXVQrhOUe2mzQB+LMZwTtAXPRsHH2rC
ZQoIheSw+jKnpDaMUGAK
=R1g4
-----END PGP SIGNATURE-----


C
C
Chris Marusich wrote on 17 Nov 2015 06:11
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 21925@debbugs.gnu.org)
CAEKzfHnmqVS7edn=7SxU3Z9txo-TcjJnXaxte2W7SuheLWqavA@mail.gmail.com
Hi,

Thank you for the quick response!

Toggle quote (2 lines)
> Could you apply this patch

The patch fixes the problem for me. Now, all the tests run during
"make check" succeed, and when I ran the following command, it worked
as expected:

./pre-inst-env guix package -i autoconf

Chris
L
L
Ludovic Courtès wrote on 17 Nov 2015 09:46
(name . Chris Marusich)(address . cmmarusich@gmail.com)
87y4dx9fot.fsf@gnu.org
Chris Marusich <cmmarusich@gmail.com> skribis:

Toggle quote (8 lines)
>> Could you apply this patch
>
> The patch fixes the problem for me. Now, all the tests run during
> "make check" succeed, and when I ran the following command, it worked
> as expected:
>
> ./pre-inst-env guix package -i autoconf

OK, pushed as b7f4677.

Thank you for testing!

Ludo’.
Closed
?