bae0636 bournish: Add 'wc' command. make check FAIL: 9

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • myglc2
Owner
unassigned
Submitted by
myglc2
Severity
normal
Merged with
M
M
myglc2 wrote on 24 Jun 2016 01:03
(address . bug-guix@gnu.org)
868txvse36.fsf@gmail.com
Running Guix on Debian 8.3 from git bae0636 bournish: Add 'wc' command.

============================================================================
Testsuite summary for GNU Guix 0.10.0
============================================================================
# TOTAL: 582
# PASS: 558
# SKIP: 15
# XFAIL: 0
# FAIL: 9
# XPASS: 0
# ERROR: 0
============================================================================
Attachment: test-suite.log
L
L
Ludovic Courtès wrote on 24 Jun 2016 14:30
Re: bug#23836: bae0636 bournish: Add 'wc' command. make check FAIL: 9
(name . myglc2)(address . myglc2@gmail.com)(address . 23836@debbugs.gnu.org)
87h9ci6a73.fsf@gnu.org
Hello,

myglc2 <myglc2@gmail.com> skribis:

Toggle quote (30 lines)
> Running Guix on Debian 8.3 from git bae0636 bournish: Add 'wc' command.

> test-name: query narinfo without signature
> location: /home/g1/dev/guix/tests/substitute.scm:173
> source:
> + (test-equal
> + "query narinfo without signature"
> + ""
> + (with-narinfo
> + %narinfo
> + (string-trim-both
> + (with-output-to-string
> + (lambda ()
> + (with-input-from-string
> + (string-append
> + "have "
> + (%store-prefix)
> + "/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa-foo")
> + (lambda () (guix-substitute "--query"))))))))
> expected-value:
> actual-value: #f
> actual-error:
> + (system-error
> + "lstat"
> + "~A: ~S"
> + ("No such file or directory"
> + "/home/g1/dev/guix/test-tmp/var/24621/cache-24621/guix/substitute/")
> + (2))
> result: FAIL

This is fishy. Could it be that files in this directory were being
accessed or removed concurrently?

Could you retry these tests with:

make check TESTS=tests/substitute.scm

?

Toggle quote (57 lines)
> test-name: container-excursion
> location: /home/g1/dev/guix/tests/containers.scm:100
> source:
> + (test-assert
> + "container-excursion"
> + (call-with-temporary-directory
> + (lambda (root)
> + (match (list (pipe) (pipe))
> + (((start-in . start-out) (end-in . end-out))
> + (define (container)
> + (close end-out)
> + (close start-in)
> + (write 'ready start-out)
> + (close start-out)
> + (read end-in)
> + (close end-in))
> + (define (namespaces pid)
> + (let ((pid (number->string pid)))
> + (map (lambda (ns)
> + (readlink (string-append "/proc/" pid "/ns/" ns)))
> + '("user" "ipc" "uts" "net" "pid" "mnt"))))
> + (let* ((pid (run-container root '() %namespaces 1 container))
> + (container-namespaces (namespaces pid))
> + (result
> + (begin
> + (close start-out)
> + (read start-in)
> + (close start-in)
> + (container-excursion
> + pid
> + (lambda ()
> + (match (primitive-fork)
> + (0
> + (assert-exit
> + (equal?
> + container-namespaces
> + (namespaces (getpid)))))
> + (fork-pid
> + (match (waitpid fork-pid)
> + ((_ . status)
> + (primitive-exit
> + (status:exit-val
> + status)))))))))))
> + (close end-in)
> + (write 'done end-out)
> + (close end-out)
> + (waitpid pid)
> + (zero? result)))))))
> actual-value: #f
> actual-error:
> + (system-error
> + "clone"
> + "~d: ~A"
> + (2080505873 "Operation not permitted")
> + (1))
> result: FAIL

You can ignore this one: the previous tests were skipped due to lack of
support for user namespaces on this system, and this one should have
been fixed too (I’ll update tests/containers.scm so that it really skips
it.)

Thanks for your report!

Ludo’.
M
M
myglc2 wrote on 24 Jun 2016 15:09
(address . bug-guix@gnu.org)
86por6ravz.fsf@gmail.com
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (37 lines)
> Hello,
>
> myglc2 <myglc2@gmail.com> skribis:
>
>> Running Guix on Debian 8.3 from git bae0636 bournish: Add 'wc' command.
>
>> test-name: query narinfo without signature
>> location: /home/g1/dev/guix/tests/substitute.scm:173
>> source:
>> + (test-equal
>> + "query narinfo without signature"
>> + ""
>> + (with-narinfo
>> + %narinfo
>> + (string-trim-both
>> + (with-output-to-string
>> + (lambda ()
>> + (with-input-from-string
>> + (string-append
>> + "have "
>> + (%store-prefix)
>> + "/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa-foo")
>> + (lambda () (guix-substitute "--query"))))))))
>> expected-value:
>> actual-value: #f
>> actual-error:
>> + (system-error
>> + "lstat"
>> + "~A: ~S"
>> + ("No such file or directory"
>> + "/home/g1/dev/guix/test-tmp/var/24621/cache-24621/guix/substitute/")
>> + (2))
>> result: FAIL
>
> This is fishy. Could it be that files in this directory were being
> accessed or removed concurrently?

Maybe because I ran make with 5 jobs ...

[guix env] g1@e3b:~/dev/guix$ make -j5

Was that a bad idea?

Toggle quote (5 lines)
>
> Could you retry these tests with:
>
> make check TESTS=tests/substitute.scm

please see below :-)

g1@e3b:~/dev/guix$ guix environment guix
;;; note: source file /home/g1/.config/guix/latest/gnu/packages/screen.scm
;;; newer than compiled /home/g1/.config/guix/latest/gnu/packages/screen.go
;;; found fresh local cache at /home/g1/.cache/guile/ccache/2.0-LE-8-2.0/home/g1/dev/guix/gnu/packages/screen.scm.go
substitute: warning: failed to install locale: Invalid argument
[guix env] g1@e3b:~/dev/guix$ make check TESTS=tests/substitute.scm
make check-recursive
make[1]: Entering directory '/home/g1/dev/guix'
Making check in po/guix
make[2]: Entering directory '/home/g1/dev/guix/po/guix'
make[2]: Leaving directory '/home/g1/dev/guix/po/guix'
Making check in po/packages
make[2]: Entering directory '/home/g1/dev/guix/po/packages'
make[2]: Leaving directory '/home/g1/dev/guix/po/packages'
make[2]: Entering directory '/home/g1/dev/guix'
Compiling Scheme modules...
LOAD (gnu packages screen)
;;; note: source file ./gnu/packages/screen.scm
;;; newer than compiled /home/g1/dev/guix/gnu/packages/screen.go
;;; found fresh local cache at /home/g1/.cache/guile/ccache/2.0-LE-8-2.0/home/g1/dev/guix/gnu/packages/screen.scm.go
GUILEC gnu/packages/screen.go
make check-TESTS check-local
make[3]: Entering directory '/home/g1/dev/guix'
make[4]: Entering directory '/home/g1/dev/guix'
FAIL: tests/substitute.scm
============================================================================
Testsuite summary for GNU Guix 0.10.0
============================================================================
# TOTAL: 11
# PASS: 3
# SKIP: 0
# XFAIL: 0
# FAIL: 8
# XPASS: 0
# ERROR: 0
============================================================================
See ./test-suite.log
Please report to bug-guix@gnu.org
============================================================================
Makefile:4097: recipe for target 'test-suite.log' failed
make[4]: *** [test-suite.log] Error 1
make[4]: Leaving directory '/home/g1/dev/guix'
Makefile:4203: recipe for target 'check-TESTS' failed
make[3]: *** [check-TESTS] Error 2
make[3]: Leaving directory '/home/g1/dev/guix'
Makefile:4446: recipe for target 'check-am' failed
make[2]: *** [check-am] Error 2
make[2]: Leaving directory '/home/g1/dev/guix'
Makefile:3983: recipe for target 'check-recursive' failed
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory '/home/g1/dev/guix'
Makefile:4448: recipe for target 'check' failed
make: *** [check] Error 2
[guix env] g1@e3b:~/dev/guix$
Attachment: test-suite.log
Thanks! - George
L
L
Ludovic Courtès wrote on 25 Jun 2016 01:14
(name . myglc2)(address . myglc2@gmail.com)(address . 23836-done@debbugs.gnu.org)
87a8iatc19.fsf@gnu.org
myglc2 <myglc2@gmail.com> skribis:

Toggle quote (2 lines)
> FAIL: tests/substitute.scm

Ooh, my bad. Fixed in 934c5d5b28f74ab2fe187ad727e4b56cfda6def8.

Thanks!

Ludo’.
Closed
L
L
Ludovic Courtès wrote on 25 Jun 2016 01:16
oops
(address . request@debbugs.gnu.org)
871t3mtbxu.fsf@gnu.org
close 23834
merge 23834 23836
thanks
M
M
myglc2 wrote on 28 Jun 2016 18:11
Re: bug#23836: bae0636 bournish: Add 'wc' command. make check FAIL: 9
(address . bug-guix@gnu.org)
86vb0t9tuz.fsf@gmail.com
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (7 lines)
> myglc2 <myglc2@gmail.com> skribis:
>
>> FAIL: tests/substitute.scm
>
> Ooh, my bad. Fixed in 934c5d5b28f74ab2fe187ad727e4b56cfda6def8.
>

Now I see ...

Testsuite summary for GNU Guix 0.10.0
============================================================================
# TOTAL: 582
# PASS: 564
# SKIP: 18
# XFAIL: 0
# FAIL: 0
# XPASS: 0
# ERROR: 0
============================================================================

... in this commit

[guix env] g1@e3b:~/.config/guix/latest$ git branch -av | grep '* master'
* master d6e374a gnu: mafft: Update to 7.299.

Thanks! - George
?