RAID config boot hangs at [...] Clocksource: Switched to clocksource tsc

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • myglc2
Owner
unassigned
Submitted by
myglc2
Severity
normal
M
M
myglc2 wrote on 2 Aug 2016 03:51
(address . bug-guix@gnu.org)
8660rklyzq.fsf@gmail.com
Note: I forgot that gmane is swallowing my posts to bug-guix and posted
this via gmane, so now I am resending by mail. Sorry if this duplicates!

I am attempting to set up RAID. First, following the doc, I ended up
with system39.scm, attached, excerpt below:

(operating-system
(host-name "g1")
(timezone "America/New_York")
(locale "en_US.utf8")
(bootloader (grub-configuration (device "/dev/sda")))
(initrd (lambda (fs . args)
(apply base-initrd fs
#:extra-modules '("raid1")
#:mapped-devices '((mapped-device
(source (list "/dev/sdb1" "/dev/sdc1"))
(target "/dev/md0")
(type raid-device-mapping)))
args)))
(file-systems (cons (file-system
(device "ssd-root")
(title 'label)
(mount-point "/")
(type "ext4"))
%base-file-systems))

In this config I was attempting to have the array assembled, but not
mounted after the boot. It did not look promissing that 'guix system
reconfigure system39.scm' did not assemble the array. Then as one might
expect, the resulting system boots but the array is not assembled.

After a couple helpful exchanges with Andreas on the devel list, I ended
up with system40.scm, attached, excerpt below:

(define md0
(mapped-device
(source (list "/dev/sdb1" "/dev/sdc1"))
(target "/dev/md0")
(type raid-device-mapping)))
(operating-system
(host-name "g1")
(timezone "America/New_York")
(locale "en_US.utf8")
(bootloader (grub-configuration (device "/dev/sda")))
(mapped-devices (list md0))
;; Add a kernel module for RAID-1.
(initrd (lambda (file-systems . rest)
(apply base-initrd file-systems
#:extra-modules '("raid1")
rest)))
(file-systems (cons*
(file-system
(device "ssd-root")
(title 'label)
(mount-point "/")
(type "ext4"))
(file-system
(title 'device)
(device "/dev/md0")
(dependencies (list md0))
(mount-point "/mnt/md0")
(create-mount-point? #t)
(type "ext4"))
%base-file-systems))


Here the intent is to have the array assembled and mounted after the
boot. It looked promissing when 'guix system reconfigure system40.scm'
assembled and mounted the array (see system40.log). But on reboot the
system hangs with the console showing:

[...] clocksource: Switched to clocksource tsc

And /var/log/sheperd.log contains:

2016-08-01 18:15:13 Service root has been started.
2016-08-01 18:15:13 ERROR: In procedure scm-error:
2016-08-01 18:15:13 ERROR: no code for module (gnu build file-systems)
2016-08-01 18:15:13
2016-08-01 18:15:13 Entering a new prompt. Type `,bt' for a backtrace or `,q' to continue.
2016-08-01 18:15:13 GNU Guile 2.0.11
2016-08-01 18:15:13 Copyright (C) 1995-2014 Free Software Foundation, Inc.
2016-08-01 18:15:13
2016-08-01 18:15:13 Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
2016-08-01 18:15:13 This program is free software, and you are welcome to redistribute it
2016-08-01 18:15:13 under certain conditions; type `,show c' for details.
2016-08-01 18:15:13
2016-08-01 18:15:13 Enter `,help' for help.

For this config, /var/log/messages (messages40.log) is also attached.

TIA - George
Attachment: messages40.log
Attachment: system40.log
Attachment: system40.scm
Attachment: system39.scm
L
L
Ludovic Courtès wrote on 2 Aug 2016 13:55
(name . myglc2)(address . myglc2@gmail.com)(address . 24129-done@debbugs.gnu.org)
87mvkvxu4z.fsf@gnu.org
myglc2 <myglc2@gmail.com> skribis:

Toggle quote (48 lines)
> After a couple helpful exchanges with Andreas on the devel list, I ended
> up with system40.scm, attached, excerpt below:
>
> (define md0
> (mapped-device
> (source (list "/dev/sdb1" "/dev/sdc1"))
> (target "/dev/md0")
> (type raid-device-mapping)))
> (operating-system
> (host-name "g1")
> (timezone "America/New_York")
> (locale "en_US.utf8")
> (bootloader (grub-configuration (device "/dev/sda")))
> (mapped-devices (list md0))
> ;; Add a kernel module for RAID-1.
> (initrd (lambda (file-systems . rest)
> (apply base-initrd file-systems
> #:extra-modules '("raid1")
> rest)))
> (file-systems (cons*
> (file-system
> (device "ssd-root")
> (title 'label)
> (mount-point "/")
> (type "ext4"))
> (file-system
> (title 'device)
> (device "/dev/md0")
> (dependencies (list md0))
> (mount-point "/mnt/md0")
> (create-mount-point? #t)
> (type "ext4"))
> %base-file-systems))
>
>
> Here the intent is to have the array assembled and mounted after the
> boot. It looked promissing when 'guix system reconfigure system40.scm'
> assembled and mounted the array (see system40.log). But on reboot the
> system hangs with the console showing:
>
> [...] clocksource: Switched to clocksource tsc
>
> And /var/log/sheperd.log contains:
>
> 2016-08-01 18:15:13 Service root has been started.
> 2016-08-01 18:15:13 ERROR: In procedure scm-error:
> 2016-08-01 18:15:13 ERROR: no code for module (gnu build file-systems)

I believe this is fixed by dfe06f6e7f486eb42a2b71e9d0ae52dfe8e3bb26.

Toggle quote (10 lines)
> 2016-08-01 18:15:13 Entering a new prompt. Type `,bt' for a backtrace or `,q' to continue.
> 2016-08-01 18:15:13 GNU Guile 2.0.11
> 2016-08-01 18:15:13 Copyright (C) 1995-2014 Free Software Foundation, Inc.
> 2016-08-01 18:15:13
> 2016-08-01 18:15:13 Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
> 2016-08-01 18:15:13 This program is free software, and you are welcome to redistribute it
> 2016-08-01 18:15:13 under certain conditions; type `,show c' for details.
> 2016-08-01 18:15:13
> 2016-08-01 18:15:13 Enter `,help' for help.

This is another bug that has yet to be fixed:


Thanks for your report!

Ludo’.
Closed
M
M
myglc2 wrote on 2 Aug 2016 04:48
(address . bug-guix@gnu.org)
86shunlwcl.fsf@gmail.com
myglc2 <myglc2@gmail.com> writes:

Toggle quote (7 lines)
>
> And /var/log/sheperd.log contains:
>
> 2016-08-01 18:15:13 Service root has been started.
> 2016-08-01 18:15:13 ERROR: In procedure scm-error:
> 2016-08-01 18:15:13 ERROR: no code for module (gnu build file-systems)

In a valiant effort at self help I read the line above and thought
... maybe I should add ...

(use-modules (gnu build file-systems))

... to the config (system41.scm)

Unfortunately this didn't fix things but it did produce an interesting
result: 'guix system reconfigure system41.scm' hung but added new
generation. Hey! guix is not supposed to do that. I want my money back!!

Interestingly, when I set --verbosity=5, 'guix system ...' failed and
refrained from adding a new generation.

So, no fix, but maybe a wormhole to plug ;-)

Log attached.
Attachment: system41.scm
Attachment: system41.log
?