RAID config boot hangs at [...] Clocksource: Switched to clocksource tsc

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • myglc2
Owner
unassigned
Submitted by
myglc2
Severity
normal
M
M
myglc2 wrote on 2 Aug 2016 03:43
(address . bug-guix@gnu.org)
86eg6854ju.fsf@gmail.com
I am attempting to set up RAID. First, following the doc, I ended up
with system39.scm, attached, excerpt below:

(operating-system
(host-name "g1")
(timezone "America/New_York")
(locale "en_US.utf8")
(bootloader (grub-configuration (device "/dev/sda")))
(initrd (lambda (fs . args)
(apply base-initrd fs
#:extra-modules '("raid1")
#:mapped-devices '((mapped-device
(source (list "/dev/sdb1" "/dev/sdc1"))
(target "/dev/md0")
(type raid-device-mapping)))
args)))
(file-systems (cons (file-system
(device "ssd-root")
(title 'label)
(mount-point "/")
(type "ext4"))
%base-file-systems))

In this config I was attempting to have the array assembled, but not
mounted after the boot. It did not look promissing that 'guix system
reconfigure system39.scm' did not assemble the array. Then as one might
expect, the resulting system boots but the array is not assembled.

After a couple helpful exchanges with Andreas on the devel list, I ended
up with system40.scm, attached, excerpt below:

(define md0
(mapped-device
(source (list "/dev/sdb1" "/dev/sdc1"))
(target "/dev/md0")
(type raid-device-mapping)))
(operating-system
(host-name "g1")
(timezone "America/New_York")
(locale "en_US.utf8")
(bootloader (grub-configuration (device "/dev/sda")))
(mapped-devices (list md0))
;; Add a kernel module for RAID-1.
(initrd (lambda (file-systems . rest)
(apply base-initrd file-systems
#:extra-modules '("raid1")
rest)))
(file-systems (cons*
(file-system
(device "ssd-root")
(title 'label)
(mount-point "/")
(type "ext4"))
(file-system
(title 'device)
(device "/dev/md0")
(dependencies (list md0))
(mount-point "/mnt/md0")
(create-mount-point? #t)
(type "ext4"))
%base-file-systems))


Here the intent is to have the array assembled and mounted after the
boot. It looked promissing when 'guix system reconfigure system40.scm'
assembled and mounted the array (see system40.log). But on reboot the
system hangs with the console showing:

[...] clocksource: Switched to clocksource tsc

And /var/log/sheperd.log contains:

2016-08-01 18:15:13 Service root has been started.
2016-08-01 18:15:13 ERROR: In procedure scm-error:
2016-08-01 18:15:13 ERROR: no code for module (gnu build file-systems)
2016-08-01 18:15:13
2016-08-01 18:15:13 Entering a new prompt. Type `,bt' for a backtrace or `,q' to continue.
2016-08-01 18:15:13 GNU Guile 2.0.11
2016-08-01 18:15:13 Copyright (C) 1995-2014 Free Software Foundation, Inc.
2016-08-01 18:15:13
2016-08-01 18:15:13 Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
2016-08-01 18:15:13 This program is free software, and you are welcome to redistribute it
2016-08-01 18:15:13 under certain conditions; type `,show c' for details.
2016-08-01 18:15:13
2016-08-01 18:15:13 Enter `,help' for help.

For this config, /var/log/messages (messages40.log) is also attached.

TIA - George
Attachment: messages40.log
Attachment: system40.log
Attachment: system40.scm
Attachment: system39.scm
L
L
Ludovic Courtès wrote on 9 Nov 2016 21:45
(name . myglc2)(address . myglc2@gmail.com)(address . 24130@debbugs.gnu.org)
87a8d8757k.fsf@gnu.org
Hi myglc2,

myglc2 <myglc2@gmail.com> skribis:

Toggle quote (3 lines)
> I am attempting to set up RAID. First, following the doc, I ended up
> with system39.scm, attached, excerpt below:

Sorry for the looong delay. In addition to the doc, there’s no a system
test in (gnu tests install) (search for “raid-root-os”) that installs
GuixSD with a RAID root file system, and this has allowed us to fix a
couple of bugs in this area.

Could you try again, following the doc and/or the test, and see how it
goes?

TIA,
Ludo’.
L
L
Ludovic Courtès wrote on 11 Jan 2017 23:14
(name . myglc2)(address . myglc2@gmail.com)(address . 24130@debbugs.gnu.org)
87tw95utvz.fsf@gnu.org
Hi!

Could you tell me if this bug is still relevant?


Ludo’.

ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (17 lines)
> Hi myglc2,
>
> myglc2 <myglc2@gmail.com> skribis:
>
>> I am attempting to set up RAID. First, following the doc, I ended up
>> with system39.scm, attached, excerpt below:
>
> Sorry for the looong delay. In addition to the doc, there’s no a system
> test in (gnu tests install) (search for “raid-root-os”) that installs
> GuixSD with a RAID root file system, and this has allowed us to fix a
> couple of bugs in this area.
>
> Could you try again, following the doc and/or the test, and see how it
> goes?
>
> TIA,
> Ludo’.
M
M
myglc2 wrote on 13 Jan 2017 05:34
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 24130@debbugs.gnu.org)
86mvevtw6w.fsf@gmail.com
On 01/11/2017 at 23:14 Ludovic Courtès writes:

Toggle quote (2 lines)
> Could you tell me if this bug is still relevant?

Hi Ludo’,

Sorry for the delay, I had to swap hardware around to revisit this. I
am now able to assemble 3 arrays as shown below, so I think you should
close the bug.

config:

(define md0
(mapped-device
(source (list "/dev/sdb1" "/dev/sdc1"))
(target "/dev/md0")
(type raid-device-mapping)))
(define md1
(mapped-device
(source (list "/dev/sdb5" "/dev/sdc5"))
(target "/dev/md1")
(type raid-device-mapping)))
(define md2
(mapped-device
(source (list "/dev/sdb6" "/dev/sdc6"))
(target "/dev/md2")
(type raid-device-mapping)))
(operating-system
(host-name "g1")
(timezone "America/New_York")
(locale "en_US.utf8")
(bootloader (grub-configuration (device "/dev/sda")))
(mapped-devices (list md0 md1 md2))
;; Add a kernel module for RAID-1.
(initrd (lambda (file-systems . rest)
(apply base-initrd file-systems
#:extra-modules '("raid1")
rest)))
(file-systems (cons*
(file-system
(device "ssd-root")
(title 'label)
(mount-point "/")
(type "ext4"))
(file-system
(title 'device)
(device "/dev/md0")
(dependencies (list md0))
(mount-point "/mnt/md0")
(create-mount-point? #t)
(type "ext4")
)
(file-system
(title 'device)
(device "/dev/md2")
(dependencies (list md2))
(mount-point "/mnt/md2")
(create-mount-point? #t)
(type "ext4")
)
%base-file-systems))


guix version:

guix (GNU Guix) 0.12.0
v0.12.0-456-gb0a567640
L
L
Ludovic Courtès wrote on 13 Jan 2017 09:04
(name . myglc2)(address . myglc2@gmail.com)(address . 24130-done@debbugs.gnu.org)
87o9zbl72c.fsf@gnu.org
myglc2 <myglc2@gmail.com> skribis:

Toggle quote (10 lines)
> On 01/11/2017 at 23:14 Ludovic Courtès writes:
>
>> Could you tell me if this bug is still relevant?
>
> Hi Ludo’,
>
> Sorry for the delay, I had to swap hardware around to revisit this. I
> am now able to assemble 3 arrays as shown below, so I think you should
> close the bug.

Excellent, thanks for reporting back!

Ludo’.
Closed
?