[PATCH] guix: build: make-bootstrap: Copy "falloc.h" to the new system.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • manolis837
  • Marius Bakke
Owner
unassigned
Submitted by
manolis837
Severity
normal
M
M
manolis837 wrote on 25 Feb 2017 18:20
(address . guix-patches@gnu.org)
20170225172004.25966-1-manolis837@gmail.com
From: Manolis Ragkousis <manolis837@gmail.com>

In glibc-2.25 a dependency on "linux/falloc.h" was added.
This also reverts commit 8f8f250bdca917b3ce38aa0902f01b19081859a4
which is no longer needed. This commit was not compatible with
the glibc version Hurd is using. See

* guix/build/make-bootstrap.scm (make-stripped-libc): Copy "falloc.h"
to the new system.
* gnu/packages/patches/glibc-bootstrap-system.patch: Remove part
that touches fcntl-linux.h.

Problem reported by Andreas Enge <andreas@enge.fr>.
---
gnu/packages/patches/glibc-bootstrap-system.patch | 24 +----------------------
guix/build/make-bootstrap.scm | 2 +-
2 files changed, 2 insertions(+), 24 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/patches/glibc-bootstrap-system.patch b/gnu/packages/patches/glibc-bootstrap-system.patch
index 6d09efed2..2f8e7da7e 100644
--- a/gnu/packages/patches/glibc-bootstrap-system.patch
+++ b/gnu/packages/patches/glibc-bootstrap-system.patch
@@ -3,10 +3,6 @@ and popen(3) need to be tweaked to use the right shell. For the bootstrap
glibc, we just use whatever `sh' can be found in $PATH. The final glibc
instead uses the hard-coded absolute file name of `bash'.
-The second part that touches fcntl-linux.h reverts a change from glibc-2.25
-which would require the statically compiled glibc used in bootstrapping to
-depend on the linux kernel headers.
-
--- a/sysdeps/posix/system.c
+++ b/sysdeps/posix/system.c
@@ -134,7 +134,7 @@ do_system (const char *line)
@@ -31,22 +27,4 @@ depend on the linux kernel headers.
}
_IO_close (child_end);
---- a/sysdeps/unix/sysv/linux/bits/fcntl-linux.h
-+++ b/sysdeps/unix/sysv/linux/bits/fcntl-linux.h
-@@ -318,7 +318,15 @@ struct f_owner_ex
-
-
- /* Flags for fallocate. */
-+# define FALLOC_FL_KEEP_SIZE 1 /* Don't extend size of file
-+ even if offset + len is
-+ greater than file size. */
-+# define FALLOC_FL_PUNCH_HOLE 2 /* Create a hole in the file. */
-+# define FALLOC_FL_COLLAPSE_RANGE 8 /* Remove a range of a file
-+ without leaving a
-+ hole. */
-+# define FALLOC_FL_ZERO_RANGE 16 /* Convert a range of a
-+ file to zeros. */
--# include <linux/falloc.h>
-
-
- /* File handle structure. */
+
diff --git a/guix/build/make-bootstrap.scm b/guix/build/make-bootstrap.scm
index 21c78cc8f..43b136248 100644
--- a/guix/build/make-bootstrap.scm
+++ b/guix/build/make-bootstrap.scm
@@ -55,7 +55,7 @@ when producing a bootstrap libc."
(string-append incdir "/linux")))
'("limits.h" "errno.h" "socket.h" "kernel.h"
"sysctl.h" "param.h" "ioctl.h" "types.h"
- "posix_types.h" "stddef.h"))
+ "posix_types.h" "stddef.h" "falloc.h"))
(copy-recursively (string-append kernel-headers "/include/asm")
(string-append incdir "/asm"))
--
2.11.1
M
M
Marius Bakke wrote on 26 Feb 2017 16:34
Re: bug#25873: [PATCH] guix: build: make-bootstrap: Copy "falloc.h" to the new system.
87fuj1ezka.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
manolis837@gmail.com writes:

Toggle quote (13 lines)
> From: Manolis Ragkousis <manolis837@gmail.com>
>
> In glibc-2.25 a dependency on "linux/falloc.h" was added.
> This also reverts commit 8f8f250bdca917b3ce38aa0902f01b19081859a4
> which is no longer needed. This commit was not compatible with
> the glibc version Hurd is using. See
> <https://lists.gnu.org/archive/html/guix-devel/2017-02/msg01046.html>
>
> * guix/build/make-bootstrap.scm (make-stripped-libc): Copy "falloc.h"
> to the new system.
> * gnu/packages/patches/glibc-bootstrap-system.patch: Remove part
> that touches fcntl-linux.h.

LGTM.

Toggle quote (61 lines)
>
> Problem reported by Andreas Enge <andreas@enge.fr>.
> ---
> gnu/packages/patches/glibc-bootstrap-system.patch | 24 +----------------------
> guix/build/make-bootstrap.scm | 2 +-
> 2 files changed, 2 insertions(+), 24 deletions(-)
>
> diff --git a/gnu/packages/patches/glibc-bootstrap-system.patch b/gnu/packages/patches/glibc-bootstrap-system.patch
> index 6d09efed2..2f8e7da7e 100644
> --- a/gnu/packages/patches/glibc-bootstrap-system.patch
> +++ b/gnu/packages/patches/glibc-bootstrap-system.patch
> @@ -3,10 +3,6 @@ and popen(3) need to be tweaked to use the right shell. For the bootstrap
> glibc, we just use whatever `sh' can be found in $PATH. The final glibc
> instead uses the hard-coded absolute file name of `bash'.
>
> -The second part that touches fcntl-linux.h reverts a change from glibc-2.25
> -which would require the statically compiled glibc used in bootstrapping to
> -depend on the linux kernel headers.
> -
> --- a/sysdeps/posix/system.c
> +++ b/sysdeps/posix/system.c
> @@ -134,7 +134,7 @@ do_system (const char *line)
> @@ -31,22 +27,4 @@ depend on the linux kernel headers.
> }
> _IO_close (child_end);
>
> ---- a/sysdeps/unix/sysv/linux/bits/fcntl-linux.h
> -+++ b/sysdeps/unix/sysv/linux/bits/fcntl-linux.h
> -@@ -318,7 +318,15 @@ struct f_owner_ex
> -
> -
> - /* Flags for fallocate. */
> -+# define FALLOC_FL_KEEP_SIZE 1 /* Don't extend size of file
> -+ even if offset + len is
> -+ greater than file size. */
> -+# define FALLOC_FL_PUNCH_HOLE 2 /* Create a hole in the file. */
> -+# define FALLOC_FL_COLLAPSE_RANGE 8 /* Remove a range of a file
> -+ without leaving a
> -+ hole. */
> -+# define FALLOC_FL_ZERO_RANGE 16 /* Convert a range of a
> -+ file to zeros. */
> --# include <linux/falloc.h>
> -
> -
> - /* File handle structure. */
> +
> diff --git a/guix/build/make-bootstrap.scm b/guix/build/make-bootstrap.scm
> index 21c78cc8f..43b136248 100644
> --- a/guix/build/make-bootstrap.scm
> +++ b/guix/build/make-bootstrap.scm
> @@ -55,7 +55,7 @@ when producing a bootstrap libc."
> (string-append incdir "/linux")))
> '("limits.h" "errno.h" "socket.h" "kernel.h"
> "sysctl.h" "param.h" "ioctl.h" "types.h"
> - "posix_types.h" "stddef.h"))
> + "posix_types.h" "stddef.h" "falloc.h"))
>
> (copy-recursively (string-append kernel-headers "/include/asm")
> (string-append incdir "/asm"))
> --
> 2.11.1
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAliy9XUACgkQoqBt8qM6
VPps9AgAz2oihGORKtlyrC9LvnMVOccCRT4WeQxLdM5QBfEdCdYcSQg+q7SeujgG
dIQQlLRckqVBryOPWcQv9Gy0UMbYLOvbW5tgIFlpmGsjj/DogF9+8CHR8ulivXDa
+0PzRicazEiriSXoFb/0JYvlg7SsuRbfORhlJj2VrpE5364FEQxEP7LZN2v+oPEo
m73726DO4G1+r/E1RPQAww/5Fd+yU3XWe+83oeYzERtZkk7jPFRZXpDt2xN//Y2O
ZGdYb6Vjyo4FMn4fcbhQ7uezREklQXMmBBoSosDNj/Ov3Sg/A3r+yzFm2M3h3HrN
s33JmPpJ+sCE4inLjziQwzSS1qRTVw==
=TIZQ
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 14 Mar 2017 10:10
control message for bug #25873
(address . control@debbugs.gnu.org)
87inncp6jw.fsf@gnu.org
tags 25873 fixed
close 25873
?