guix-patches debbugs appears to mangle patches

  • Done
  • quality assurance status badge
Details
5 participants
  • ng0
  • Eric Blake
  • Leo Famulari
  • Ludovic Courtès
  • Glenn Morris
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 4 Mar 2017 23:54
(address . bug-guix@gnu.org)
20170304225456.GB19780@jasmine
Git has a simple workflow for using email, with `git send-email` and
`git am`.

The guix-patches debbugs thing causes a regression in this workflow by
rewriting the commit messages to include the debbugs ticket number.

So, a commit that begins with this:

gnu: gitolite: Fix shebangs in hooks.

... becomes this:

bug#25966: [PATCH 2/2] gnu: gitolite: Fix shebangs in hooks.

Am I missing something, or is debbugs really rewriting the patches?
N
(name . Leo Famulari)(address . leo@famulari.name)(address . 25969@debbugs.gnu.org)
20170305123413.r6agl3chv5344wg2@abyayala
On 17-03-04 17:54:56, Leo Famulari wrote:
Toggle quote (19 lines)
> Git has a simple workflow for using email, with `git send-email` and
> `git am`.
>
> The guix-patches debbugs thing causes a regression in this workflow by
> rewriting the commit messages to include the debbugs ticket number.
>
> So, a commit that begins with this:
>
> gnu: gitolite: Fix shebangs in hooks.
>
> ... becomes this:
>
> bug#25966: [PATCH 2/2] gnu: gitolite: Fix shebangs in hooks.
>
> Am I missing something, or is debbugs really rewriting the patches?
>
>
>

Possibly. Though I see some people started to just attach the git
format-patch patches.
Maybe we should look at / ask other projects how they deal with this for
debbugs?
N
(name . Leo Famulari)(address . leo@famulari.name)(address . 25969@debbugs.gnu.org)
20170305123729.sypt6ha77jeqg62z@abyayala
On 17-03-04 17:54:56, Leo Famulari wrote:
Toggle quote (19 lines)
> Git has a simple workflow for using email, with `git send-email` and
> `git am`.
>
> The guix-patches debbugs thing causes a regression in this workflow by
> rewriting the commit messages to include the debbugs ticket number.
>
> So, a commit that begins with this:
>
> gnu: gitolite: Fix shebangs in hooks.
>
> ... becomes this:
>
> bug#25966: [PATCH 2/2] gnu: gitolite: Fix shebangs in hooks.
>
> Am I missing something, or is debbugs really rewriting the patches?
>
>
>

885227386855e446e653d958c38b6bbcfc2a24ca and the patch afterwards was
sent with git send-email (after I was assigned an issue-id) and if Kei
didn't fix it, they were not altered in subject etc.
L
L
Ludovic Courtès wrote on 6 Mar 2017 11:16
(name . Leo Famulari)(address . leo@famulari.name)
87a88yww0m.fsf@gnu.org
Hello!

Leo Famulari <leo@famulari.name> skribis:

Toggle quote (13 lines)
> The guix-patches debbugs thing causes a regression in this workflow by
> rewriting the commit messages to include the debbugs ticket number.
>
> So, a commit that begins with this:
>
> gnu: gitolite: Fix shebangs in hooks.
>
> ... becomes this:
>
> bug#25966: [PATCH 2/2] gnu: gitolite: Fix shebangs in hooks.
>
> Am I missing something, or is debbugs really rewriting the patches?

Good question. Maybe Glenn and others at help-debbugs have an idea?

Thanks,
Ludo’.
G
G
Glenn Morris wrote on 6 Mar 2017 18:46
(name . Ludovic Courtès)(address . ludo@gnu.org)
nashmqz4aw.fsf@fencepost.gnu.org
Ludovic Courtès wrote:

Toggle quote (19 lines)
> Hello!
>
> Leo Famulari <leo@famulari.name> skribis:
>
>> The guix-patches debbugs thing causes a regression in this workflow by
>> rewriting the commit messages to include the debbugs ticket number.
>>
>> So, a commit that begins with this:
>>
>> gnu: gitolite: Fix shebangs in hooks.
>>
>> ... becomes this:
>>
>> bug#25966: [PATCH 2/2] gnu: gitolite: Fix shebangs in hooks.
>>
>> Am I missing something, or is debbugs really rewriting the patches?
>
> Good question. Maybe Glenn and others at help-debbugs have an idea?

I think it's over the top to describe this as "mangling" or "rewriting"
patches. The system relies on adding a bug number to the subject, so
that replies to the maintainer address can be associated with the right
bug. I don't see any prospect of this changing. If you are using a tool
that is sensitive to the subject line in emails, I can only suggest
using eg a trivial sed command to take out the bug number before passing
the mail to your tool.
E
E
Eric Blake wrote on 6 Mar 2017 18:54
398d7c29-a7c4-f600-49f1-e7db9562b509@redhat.com
On 03/06/2017 11:46 AM, Glenn Morris wrote:
Toggle quote (29 lines)
> Ludovic Courtès wrote:
>
>> Hello!
>>
>> Leo Famulari <leo@famulari.name> skribis:
>>
>>> The guix-patches debbugs thing causes a regression in this workflow by
>>> rewriting the commit messages to include the debbugs ticket number.
>>>
>>> So, a commit that begins with this:
>>>
>>> gnu: gitolite: Fix shebangs in hooks.
>>>
>>> ... becomes this:
>>>
>>> bug#25966: [PATCH 2/2] gnu: gitolite: Fix shebangs in hooks.
>>>
>>> Am I missing something, or is debbugs really rewriting the patches?
>>
>> Good question. Maybe Glenn and others at help-debbugs have an idea?
>
> I think it's over the top to describe this as "mangling" or "rewriting"
> patches. The system relies on adding a bug number to the subject, so
> that replies to the maintainer address can be associated with the right
> bug. I don't see any prospect of this changing. If you are using a tool
> that is sensitive to the subject line in emails, I can only suggest
> using eg a trivial sed command to take out the bug number before passing
> the mail to your tool.

'git am' already knows how to strip anything inside one or more [text]
prefix of the subject. I don't know how hard it would be to convince the
GNU debbugs instance to output '[bug#25969] ' instead of its current
'bug#25969: ' (and of course to also recognize both spellings on input,
when checking for existing mails in reply to existing bugs), but such a
tweak would play nicer with a git patch workflow.

--
Eric Blake eblake redhat com +1-919-301-3266
Libvirt virtualization library http://libvirt.org
Attachment: signature.asc
L
L
Ludovic Courtès wrote on 5 May 2017 20:29
control message for bug #25969
(address . control@debbugs.gnu.org)
87pofn2m4f.fsf@gnu.org
tags 25969 notabug
close 25969
?