[PATCH] gnu: gnuplot: Enable tikz backend.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 25 Mar 2017 18:37
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170325173717.31505-1-dannym@scratchpost.org
* gnu/packages/maths.scm (gnuplot)[inputs]: Add lua.
---
gnu/packages/maths.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ed13556cb..a5cdacb63 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -70,6 +70,7 @@
#:use-module (gnu packages less)
#:use-module (gnu packages lisp)
#:use-module (gnu packages logging)
+ #:use-module (gnu packages lua)
#:use-module (gnu packages gnome)
#:use-module (gnu packages guile)
#:use-module (gnu packages xorg)
@@ -495,7 +496,8 @@ singular value problems.")
(inputs `(("readline" ,readline)
("cairo" ,cairo)
("pango" ,pango)
- ("gd" ,gd)))
+ ("gd" ,gd)
+ ("lua" ,lua)))
(native-inputs `(("pkg-config" ,pkg-config)
("texlive" ,texlive-minimal)))
(home-page "http://www.gnuplot.info")
K
K
Kei Kebreau wrote on 26 Mar 2017 00:22
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 26255@debbugs.gnu.org)
8760ix2b75.fsf@openmailbox.org
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (28 lines)
> * gnu/packages/maths.scm (gnuplot)[inputs]: Add lua.
> ---
> gnu/packages/maths.scm | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index ed13556cb..a5cdacb63 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -70,6 +70,7 @@
> #:use-module (gnu packages less)
> #:use-module (gnu packages lisp)
> #:use-module (gnu packages logging)
> + #:use-module (gnu packages lua)
> #:use-module (gnu packages gnome)
> #:use-module (gnu packages guile)
> #:use-module (gnu packages xorg)
> @@ -495,7 +496,8 @@ singular value problems.")
> (inputs `(("readline" ,readline)
> ("cairo" ,cairo)
> ("pango" ,pango)
> - ("gd" ,gd)))
> + ("gd" ,gd)
> + ("lua" ,lua)))
> (native-inputs `(("pkg-config" ,pkg-config)
> ("texlive" ,texlive-minimal)))
> (home-page "http://www.gnuplot.info")

Looks good!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljW+84ACgkQ5qXuPBlG
eg2G2hAAjKq1alKEV9NsOddai0G/catPDGybWf6HCERW1Kzr9hu0tJ/+Brk5QvTB
GjEq4zHOR0XMpUtrcJ1PRU5lUUZQ/Eq6pXBENK9+aT+Rb63DR10CKEkunV42npI5
zeGI0dksr4LylIcOq/2vk+6anJWdzix9RkrcxIO9wiBa1EI+a9QONzk+1SSak8b5
u3U7UUzxSG+6zSiIzi6OSnqyKt2FEVVF1HuBYwOXE0abX3QfhQEq/nNvSYd92HJo
IcQ1oiw7+uzxK7ZnInSM8qJUBjc2n2zOUTvjR3oXeNCH9so5nhQM1iPZjj4bJqKN
XFS8VFRWgObXe6yzBNtU3gXfO0tDcNeqL174xzHP1U+mMUdgIaIm+yYavZAJQjVw
s9I88JLwPU7HekSdHJd5S+WkHp/JdzPiP6fGmBPLppF+QmBIA7xg45J14YfXLbS/
Vao/uZRogUGp6mM/gwx75mHgC5KxnM25h3fR5zkJ2TRPI0C/JsrogLyEPK0AGiHm
KdlCes9jifNi4DzexbOwmKk41Rs+rNM2HwpFJSeW2A2DMf0+1nbOWGBSRq5EQMbf
0y2xdIzUsu9/tJ6fI5f6tActV4morp5bcHgE/BuI3g7Gw5mrgBR0CNpZxRRGyEiI
zsy+C1l+iLgRgJHtEOJx/bZrwY/CrV8aS0MMRlOe+z1tcVC9tjs=
=hjcw
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 26 Mar 2017 16:13
(name . Kei Kebreau)(address . kei@openmailbox.org)
878tnsp1m1.fsf@gnu.org
Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (32 lines)
> Danny Milosavljevic <dannym@scratchpost.org> writes:
>
>> * gnu/packages/maths.scm (gnuplot)[inputs]: Add lua.
>> ---
>> gnu/packages/maths.scm | 4 +++-
>> 1 file changed, 3 insertions(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
>> index ed13556cb..a5cdacb63 100644
>> --- a/gnu/packages/maths.scm
>> +++ b/gnu/packages/maths.scm
>> @@ -70,6 +70,7 @@
>> #:use-module (gnu packages less)
>> #:use-module (gnu packages lisp)
>> #:use-module (gnu packages logging)
>> + #:use-module (gnu packages lua)
>> #:use-module (gnu packages gnome)
>> #:use-module (gnu packages guile)
>> #:use-module (gnu packages xorg)
>> @@ -495,7 +496,8 @@ singular value problems.")
>> (inputs `(("readline" ,readline)
>> ("cairo" ,cairo)
>> ("pango" ,pango)
>> - ("gd" ,gd)))
>> + ("gd" ,gd)
>> + ("lua" ,lua)))
>> (native-inputs `(("pkg-config" ,pkg-config)
>> ("texlive" ,texlive-minimal)))
>> (home-page "http://www.gnuplot.info")
>
> Looks good!

Same here, though could you check how this affect the closure size, as
reported by ‘guix size gnuplot’?

Thanks,
Ludo’.
D
D
Danny Milosavljevic wrote on 26 Mar 2017 17:36
(name . Ludovic Courtès)(address . ludo@gnu.org)
20170326173619.6dd7a5bb@scratchpost.org
Closure size before: 207.8 MiB
Closure size afterwards: 209.2 MiB
L
L
Ludovic Courtès wrote on 27 Mar 2017 10:22
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
874lyfp1rx.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (3 lines)
> Closure size before: 207.8 MiB
> Closure size afterwards: 209.2 MiB

Awesome, go for it!

Ludo’.
D
D
Danny Milosavljevic wrote on 27 Mar 2017 16:00
(address . 26255-done@debbugs.gnu.org)
20170327160013.18f73ddd@scratchpost.org
The gnuplot tikz backend has been pushed as 6e64766a861f4fa881320921738edef8b7da6bf1. Closing bug report.
Closed
?