Alpine News and Mail client

  • Done
  • quality assurance status badge
Details
2 participants
  • ng0
  • Kei Kebreau
Owner
unassigned
Submitted by
ng0
Severity
normal
N
(address . guix-patches@gnu.org)
20170331104944.ablaikrujybeqqmf@abyayala
The appended patch adds Alpine. It was discontinued by its previous
developer team and is now being developed at
both released by the same developer. The one which every distro uses is
the one with extra, functionality enhancing and bugs fixing patches applied.
This is the one I picked to not break expectations of people.

It compiles, builds, and can be started. I don't know this client and
only worked on it to complete the dinosaurs of mail clients collection
as some people still seem to use Alpine on other distros.
I haven't tested sending mail or receiving mail for obvious reasons.
and I do not trust applications I rarely use.
From 932623f11a7f11173051c4f87683fe52052642ba Mon Sep 17 00:00:00 2001
From: ng0 <contact.ng0@cryptolab.net>
Date: Wed, 15 Feb 2017 03:20:38 +0000
Subject: [PATCH] gnu: Add alpine.

* gnu/packages/mail.scm (alpine): New variable.
---
gnu/packages/mail.scm | 56 +++++++++++++++++++++++++++++++++++++++++++++++++--
1 file changed, 54 insertions(+), 2 deletions(-)

Toggle diff (108 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index e36f884ea..d62437aa5 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
-;;; Copyright © 2016, 2017 <contact.ng0@cryptolab.net>
+;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
@@ -39,6 +39,7 @@
(define-module (gnu packages mail)
#:use-module (gnu packages)
+ #:use-module (gnu packages aspell)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages backup)
@@ -62,6 +63,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages kerberos)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
@@ -69,6 +71,7 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages m4)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages openldap)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
@@ -84,6 +87,7 @@
#:use-module (gnu packages ruby)
#:use-module (gnu packages samba)
#:use-module (gnu packages screen)
+ #:use-module (gnu packages tcl)
#:use-module (gnu packages tls)
#:use-module (gnu packages networking)
#:use-module (gnu packages web)
@@ -94,7 +98,7 @@
#:select (gpl2 gpl2+ gpl3 gpl3+ lgpl2.1 lgpl2.1+ lgpl3+
non-copyleft (expat . license:expat) bsd-3
public-domain bsd-4 isc (openssl . license:openssl)
- bsd-2 x11-style agpl3))
+ bsd-2 x11-style agpl3 asl2.0))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -2141,3 +2145,51 @@ Options can be specified in environment variables, configuration files, and
the command line allowing maximum configurability and ease of use for
operators and scripters.")
(license gpl2+)))
+
+(define-public alpine
+ (package
+ (name "alpine")
+ (version "2.21")
+ (source
+ (origin
+ (method url-fetch)
+ ;; There are two versions: the plain continuation of Alpine without extra
+ ;; patches and the version which adds extra fixes. Every distro uses
+ ;; the patched version, and so do we to not break expectations.
+ ;; http://patches.freeiz.com/alpine/readme/README.patches
+ (uri (string-append "http://patches.freeiz.com/alpine/patches/alpine-"
+ version "/alpine-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1k9hcfjywfk3mpsl71hjza3nk6icgf1b6xxzgx10kdzg5yci5x5m"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "CC=gcc")
+ #:configure-flags (list (string-append "--with-ssl-include-dir="
+ (assoc-ref %build-inputs "openssl")
+ "/include/openssl")
+ (string-append "--with-ssl-dir="
+ (assoc-ref %build-inputs "openssl"))
+ (string-append "--with-ssl-certs-dir="
+ "/etc/ssl/certs/")
+ (string-append "--with-ssl-lib-dir="
+ (assoc-ref %build-inputs "openssl")
+ "/lib")
+ (string-append "--with-interactive-spellcheck="
+ (assoc-ref %build-inputs "aspell")
+ "/bin/aspell"))))
+ (inputs
+ `(("ncurses" ,ncurses)
+ ("openssl" ,openssl)
+ ("gnutls" ,gnutls)
+ ("openldap" ,openldap)
+ ("cyrus-sasl" ,cyrus-sasl)
+ ("mit-krb5" ,mit-krb5)
+ ("aspell" ,aspell)
+ ("tcl" ,tcl)
+ ("linux-pam" ,linux-pam)))
+ (home-page "http://patches.freeiz.com/alpine/")
+ (synopsis "Alternatively Licensed Program for Internet News and Email")
+ (description
+ "Alpine is a text-based mail and news client.")
+ (license asl2.0)))
--
2.12.2
K
K
Kei Kebreau wrote on 2 Apr 2017 18:48
(address . guix-patches@gnu.org)
871sta69hi.fsf@openmailbox.org
ng0 <contact.ng0@cryptolab.net> writes:

Toggle quote (99 lines)
> The appended patch adds Alpine. It was discontinued by its previous
> developer team and is now being developed at
> "http://patches.freeiz.com/alpine/index.html". There are two versions,
> both released by the same developer. The one which every distro uses is
> the one with extra, functionality enhancing and bugs fixing patches applied.
> This is the one I picked to not break expectations of people.
>
> It compiles, builds, and can be started. I don't know this client and
> only worked on it to complete the dinosaurs of mail clients collection
> as some people still seem to use Alpine on other distros.
> I haven't tested sending mail or receiving mail for obvious reasons.
> and I do not trust applications I rarely use.
>
>>From 932623f11a7f11173051c4f87683fe52052642ba Mon Sep 17 00:00:00 2001
> From: ng0 <contact.ng0@cryptolab.net>
> Date: Wed, 15 Feb 2017 03:20:38 +0000
> Subject: [PATCH] gnu: Add alpine.
>
> * gnu/packages/mail.scm (alpine): New variable.
> ---
> gnu/packages/mail.scm | 56 +++++++++++++++++++++++++++++++++++++++++++++++++--
> 1 file changed, 54 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
> index e36f884ea..d62437aa5 100644
> --- a/gnu/packages/mail.scm
> +++ b/gnu/packages/mail.scm
> @@ -15,7 +15,7 @@
> ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
> ;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
> ;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
> -;;; Copyright © 2016, 2017 <contact.ng0@cryptolab.net>
> +;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
> ;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
> ;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
> ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
> @@ -39,6 +39,7 @@
>
> (define-module (gnu packages mail)
> #:use-module (gnu packages)
> + #:use-module (gnu packages aspell)
> #:use-module (gnu packages autotools)
> #:use-module (gnu packages base)
> #:use-module (gnu packages backup)
> @@ -62,6 +63,7 @@
> #:use-module (gnu packages gtk)
> #:use-module (gnu packages guile)
> #:use-module (gnu packages flex)
> + #:use-module (gnu packages kerberos)
> #:use-module (gnu packages libcanberra)
> #:use-module (gnu packages libevent)
> #:use-module (gnu packages libidn)
> @@ -69,6 +71,7 @@
> #:use-module (gnu packages lua)
> #:use-module (gnu packages m4)
> #:use-module (gnu packages ncurses)
> + #:use-module (gnu packages openldap)
> #:use-module (gnu packages pcre)
> #:use-module (gnu packages perl)
> #:use-module (gnu packages python)
> @@ -84,6 +87,7 @@
> #:use-module (gnu packages ruby)
> #:use-module (gnu packages samba)
> #:use-module (gnu packages screen)
> + #:use-module (gnu packages tcl)
> #:use-module (gnu packages tls)
> #:use-module (gnu packages networking)
> #:use-module (gnu packages web)
> @@ -94,7 +98,7 @@
> #:select (gpl2 gpl2+ gpl3 gpl3+ lgpl2.1 lgpl2.1+ lgpl3+
> non-copyleft (expat . license:expat) bsd-3
> public-domain bsd-4 isc (openssl . license:openssl)
> - bsd-2 x11-style agpl3))
> + bsd-2 x11-style agpl3 asl2.0))
> #:use-module (guix packages)
> #:use-module (guix download)
> #:use-module (guix git-download)
> @@ -2141,3 +2145,51 @@ Options can be specified in environment variables, configuration files, and
> the command line allowing maximum configurability and ease of use for
> operators and scripters.")
> (license gpl2+)))
> +
> +(define-public alpine
> + (package
> + (name "alpine")
> + (version "2.21")
> + (source
> + (origin
> + (method url-fetch)
> + ;; There are two versions: the plain continuation of Alpine without extra
> + ;; patches and the version which adds extra fixes. Every distro uses
> + ;; the patched version, and so do we to not break expectations.
> + ;; http://patches.freeiz.com/alpine/readme/README.patches
> + (uri (string-append "http://patches.freeiz.com/alpine/patches/alpine-"
> + version "/alpine-" version ".tar.xz"))
> + (sha256
> + (base32
> + "1k9hcfjywfk3mpsl71hjza3nk6icgf1b6xxzgx10kdzg5yci5x5m"))))

Could you add a snippet that corrects the time-dependent code? Grepping
(is that a word?) for "datestamp" in alpine's source directory should
show you the offending code.

Toggle quote (31 lines)
> + (build-system gnu-build-system)
> + (arguments
> + `(#:make-flags (list "CC=gcc")
> + #:configure-flags (list (string-append "--with-ssl-include-dir="
> + (assoc-ref %build-inputs "openssl")
> + "/include/openssl")
> + (string-append "--with-ssl-dir="
> + (assoc-ref %build-inputs "openssl"))
> + (string-append "--with-ssl-certs-dir="
> + "/etc/ssl/certs/")
> + (string-append "--with-ssl-lib-dir="
> + (assoc-ref %build-inputs "openssl")
> + "/lib")
> + (string-append "--with-interactive-spellcheck="
> + (assoc-ref %build-inputs "aspell")
> + "/bin/aspell"))))
> + (inputs
> + `(("ncurses" ,ncurses)
> + ("openssl" ,openssl)
> + ("gnutls" ,gnutls)
> + ("openldap" ,openldap)
> + ("cyrus-sasl" ,cyrus-sasl)
> + ("mit-krb5" ,mit-krb5)
> + ("aspell" ,aspell)
> + ("tcl" ,tcl)
> + ("linux-pam" ,linux-pam)))
> + (home-page "http://patches.freeiz.com/alpine/")
> + (synopsis "Alternatively Licensed Program for Internet News and Email")
> + (description
> + "Alpine is a text-based mail and news client.")

Maybe this can be a bit more descriptive, but then again, the mutt mail
client has a fairly modest description as well.

Toggle quote (2 lines)
> + (license asl2.0)))

Other than that, the patch looks good. Sadly I'm not a user of alpine
so I can't test its functionality. Do any alpine users want to step up
to the plate and try this out?
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljhK3kACgkQ5qXuPBlG
eg3+IA//altAdXFddSN3RqiyYq3D+bE5sGFPi/mzLboxIKTWRHFxsvJnrq8OKYmF
8OuczRcjbkZA/2kmlOmPJVrNYOZ5m9Tcfy3sX7etspKbQ4WkFwekRHsVS6zJ2Crb
x6Gptxd3o8zEJXG/33nPLWMZZJXceY7yYwekAUuIpzQyvD7VmjK2ScnpQyVKLA0c
HUs0CBbsCMX2sHhNAiHg/UZ17tWxwkV0l7HbONZFDK1vEDRmMnjscDdzRRj/NNPW
h0PtUM2CYRE8P7Eju0jV4l1sEObWro2gUAJDx/yyLdMaLlM+sH1ogrU4KB2vXor+
qpH0vIjKSWx68oSjteIHdFcDdFbyAKFPA6vTBOC8Lj/dCzdd1hDzMsknIuDqK83x
UZCxGdEcR7WhvZB/PcMUZgYJC92EtSa/9ZLaVWY8TqqDknVwvniXzHSPZbE+EZFt
I/T+PfUZZJB0hBzPC2wbIjPI7Bx8QThh/JrcX78liFxktp1UWAhMObCVnG40juGC
Os/vko4tPg5pt5oxjpBzdCbBysTgj9fYpCngS5zv0jZFvtLtPgRvuqXQFEN7goNq
FCpnwyEgwpuOFb4HVQ9a5BBKRJgZ64t6ihlgruPtmF5JUIdHTTGMGGLwMFViekyw
0DGcQ54sgLmFGUCYaEBL1KgWNMabguV6kRxElrHj68+8eDGUEfo=
=/1hU
-----END PGP SIGNATURE-----

N
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26320@debbugs.gnu.org)
20170402174756.q45xbhskwclyddtb@abyayala
Attachment: file
K
K
Kei Kebreau wrote on 2 Apr 2017 21:17
(address . 26320@debbugs.gnu.org)
87tw664o11.fsf@openmailbox.org
ng0 <contact.ng0@cryptolab.net> writes:

Toggle quote (13 lines)
> Kei Kebreau transcribed 7.4K bytes:
>> ng0 <contact.ng0@cryptolab.net> writes:
>>
>>
>> Maybe this can be a bit more descriptive, but then again, the mutt mail
>> client has a fairly modest description as well.
>
> I don't know. It's a text bsaed email and news client. It features its
> own text editor (so it says) called pico. That's all I know. I don't
> know wether the editor can be used on its own or just in application.
>
>

It can! Users can run "pico", GNU nano's predecessor, as a standalone
program with this package installed.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljhTloACgkQ5qXuPBlG
eg2c+w//f6CibRCpjjpFEYagg2WE8+/HnOZUSN7GKwLH28LHqnmuBpBiGXyNuoZS
mPXSRFOK3yYU5YHsXH0zvUMLtuO8uFGzojl8c5v4zhKvB6oQ6w5WURMynMoJsgpM
MIDjwe3CM0z+JnAB4gD9cDb1cWkb8YZY7gCbW7vS4JF2BMbH9bnanmv4wqz030PR
uSYguVUTWj7Flea0GWqzksGFJcer2ndy4xwSbtpEKlNijItyIF4lPXp0sN6GTYsE
2Mkr+eBD4ZCpejDaUEUhlU7vsG92WZ5e1dU5QrPX36kGQG9OwU+p0GyLA7W3RvHB
htua6weeXyKnfMqtehFg2h7sCC8SYs4qavPduWaS0c32cCAaMEYc/e8yGSqxsXXl
dX9TR07jIzhFEXZw3J2BRUHt8CHO8KwBLMYISFXGcSP5wBJLdNiRJ4sbJsOBzjEb
i5UdvHp3gIB/Y7aZlPo7GUbJul9U5fuhoJL8dZhwEraDuFegazxrGKG4j3I9W+ny
nwcDwuFDDloylCnwpdZiHNk4D5Q1xgRjquOHOnntCNCCPYfEDQYVm3Me1KpwmJeS
4tAuWlBbpGNK/lATA+wZtilHGLUaoYFKWMCEK+eLEMgPXKi/MNkzoFtxJ2ZYn4kL
Ggl3TL7uCUgUufpiFjKiY/ugcqn901eFlxWcbvfvDjcYka2DMlU=
=aEht
-----END PGP SIGNATURE-----

N
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 26320@debbugs.gnu.org)
20170404143447.tf5kjam26qe5mpvt@abyayala
Kei Kebreau transcribed 1.5K bytes:
Toggle quote (18 lines)
> ng0 <contact.ng0@cryptolab.net> writes:
>
> > Kei Kebreau transcribed 7.4K bytes:
> >> ng0 <contact.ng0@cryptolab.net> writes:
> >>
> >>
> >> Maybe this can be a bit more descriptive, but then again, the mutt mail
> >> client has a fairly modest description as well.
> >
> > I don't know. It's a text bsaed email and news client. It features its
> > own text editor (so it says) called pico. That's all I know. I don't
> > know wether the editor can be used on its own or just in application.
> >
> >
>
> It can! Users can run "pico", GNU nano's predecessor, as a standalone
> program with this package installed.

quote README:

In general "make install" should place alpine, pico and pilot, and
their corresponding man pages, in the proper directory for your
system. As the remaining binaries are intended for specific uses or
are a component of a larger package, their installation is typically
done by hand.
endquote README

Include are not:

quote
alpined
The Web Alpine serveret that is the primary component of
Web Alpine
imapd The IMAP daemon. If you want to run alpine in client/server
mode, this is the daemon to run on the server. Installing this
requires system privileges and modifications to /etc/services.
See doc/tech-notes for more details.
mtest The test IMAP client, an absolutely minimal mail client, useful
for debugging.
mailutil
Utility for performing various operations on mailboxes,
be they local or remote.
endquote

But in addition to the above listed included applications, "rpload" and
"rpdump" are included.

This is taken from the section "RESULTING EXECUTABLE".

Whoever wants to include more than the standard set of make install
needs to be a alpine user, I can't judge what's necessary, important,
too much, or whatever.

I have addressed the datestamp issue, but I needed to fix this in
#:phases, as a snippet did not accept what I ran, files weren't being
found.
K
K
Kei Kebreau wrote on 8 Apr 2017 19:47
(address . 26320-done@debbugs.gnu.org)
87tw5y3i5y.fsf@openmailbox.org
ng0 <contact.ng0@cryptolab.net> writes:

Toggle quote (194 lines)
> Kei Kebreau transcribed 1.5K bytes:
>> ng0 <contact.ng0@cryptolab.net> writes:
>>
>> > Kei Kebreau transcribed 7.4K bytes:
>> >> ng0 <contact.ng0@cryptolab.net> writes:
>> >>
>> >>
>> >> Maybe this can be a bit more descriptive, but then again, the mutt mail
>> >> client has a fairly modest description as well.
>> >
>> > I don't know. It's a text bsaed email and news client. It features its
>> > own text editor (so it says) called pico. That's all I know. I don't
>> > know wether the editor can be used on its own or just in application.
>> >
>> >
>>
>> It can! Users can run "pico", GNU nano's predecessor, as a standalone
>> program with this package installed.
>
> quote README:
>
> In general "make install" should place alpine, pico and pilot, and
> their corresponding man pages, in the proper directory for your
> system. As the remaining binaries are intended for specific uses or
> are a component of a larger package, their installation is typically
> done by hand.
> endquote README
>
> Include are not:
>
> quote
> alpined
> The Web Alpine serveret that is the primary component of
> Web Alpine
>
> imapd The IMAP daemon. If you want to run alpine in client/server
> mode, this is the daemon to run on the server. Installing this
> requires system privileges and modifications to /etc/services.
> See doc/tech-notes for more details.
>
> mtest The test IMAP client, an absolutely minimal mail client, useful
> for debugging.
> mailutil
> Utility for performing various operations on mailboxes,
> be they local or remote.
> endquote
>
> But in addition to the above listed included applications, "rpload" and
> "rpdump" are included.
>
> This is taken from the section "RESULTING EXECUTABLE".
>
> Whoever wants to include more than the standard set of make install
> needs to be a alpine user, I can't judge what's necessary, important,
> too much, or whatever.
>
> I have addressed the datestamp issue, but I needed to fix this in
> #:phases, as a snippet did not accept what I ran, files weren't being
> found.
>
>>From c5298208448e0a46b6162801bbb17ae1d9e72a5c Mon Sep 17 00:00:00 2001
> From: ng0 <contact.ng0@cryptolab.net>
> Date: Wed, 15 Feb 2017 03:20:38 +0000
> Subject: [PATCH] gnu: Add alpine.
>
> * gnu/packages/mail.scm (alpine): New variable.
> ---
> gnu/packages/mail.scm | 73 +++++++++++++++++++++++++++++++++++++++++++++++++--
> 1 file changed, 71 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
> index 65fa9df54..463ed2850 100644
> --- a/gnu/packages/mail.scm
> +++ b/gnu/packages/mail.scm
> @@ -15,7 +15,7 @@
> ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
> ;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
> ;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
> -;;; Copyright © 2016, 2017 <contact.ng0@cryptolab.net>
> +;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
> ;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
> ;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
> ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
> @@ -40,6 +40,7 @@
>
> (define-module (gnu packages mail)
> #:use-module (gnu packages)
> + #:use-module (gnu packages aspell)
> #:use-module (gnu packages autotools)
> #:use-module (gnu packages base)
> #:use-module (gnu packages backup)
> @@ -63,6 +64,7 @@
> #:use-module (gnu packages gtk)
> #:use-module (gnu packages guile)
> #:use-module (gnu packages flex)
> + #:use-module (gnu packages kerberos)
> #:use-module (gnu packages libcanberra)
> #:use-module (gnu packages libevent)
> #:use-module (gnu packages libidn)
> @@ -70,6 +72,7 @@
> #:use-module (gnu packages lua)
> #:use-module (gnu packages m4)
> #:use-module (gnu packages ncurses)
> + #:use-module (gnu packages openldap)
> #:use-module (gnu packages pcre)
> #:use-module (gnu packages perl)
> #:use-module (gnu packages python)
> @@ -85,6 +88,7 @@
> #:use-module (gnu packages ruby)
> #:use-module (gnu packages samba)
> #:use-module (gnu packages screen)
> + #:use-module (gnu packages tcl)
> #:use-module (gnu packages tls)
> #:use-module (gnu packages networking)
> #:use-module (gnu packages web)
> @@ -95,7 +99,7 @@
> #:select (gpl2 gpl2+ gpl3 gpl3+ lgpl2.1 lgpl2.1+ lgpl3+
> non-copyleft (expat . license:expat) bsd-3
> public-domain bsd-4 isc (openssl . license:openssl)
> - bsd-2 x11-style agpl3))
> + bsd-2 x11-style agpl3 asl2.0))
> #:use-module (guix packages)
> #:use-module (guix download)
> #:use-module (guix git-download)
> @@ -2148,3 +2152,68 @@ Options can be specified in environment variables, configuration files, and
> the command line allowing maximum configurability and ease of use for
> operators and scripters.")
> (license gpl2+)))
> +
> +(define-public alpine
> + (package
> + (name "alpine")
> + (version "2.21")
> + (source
> + (origin
> + (method url-fetch)
> + ;; There are two versions: the plain continuation of Alpine without extra
> + ;; patches and the version which adds extra fixes. Every distro uses
> + ;; the patched version, and so do we to not break expectations.
> + ;; http://patches.freeiz.com/alpine/readme/README.patches
> + (uri (string-append "http://patches.freeiz.com/alpine/patches/alpine-"
> + version "/alpine-" version ".tar.xz"))
> + (sha256
> + (base32
> + "1k9hcfjywfk3mpsl71hjza3nk6icgf1b6xxzgx10kdzg5yci5x5m"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:make-flags (list "CC=gcc")
> + #:configure-flags (list (string-append "--with-ssl-include-dir="
> + (assoc-ref %build-inputs "openssl")
> + "/include/openssl")
> + (string-append "--with-ssl-dir="
> + (assoc-ref %build-inputs "openssl"))
> + (string-append "--with-ssl-certs-dir="
> + "/etc/ssl/certs/")
> + (string-append "--with-ssl-lib-dir="
> + (assoc-ref %build-inputs "openssl")
> + "/lib")
> + (string-append "--with-interactive-spellcheck="
> + (assoc-ref %build-inputs "aspell")
> + "/bin/aspell"))
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'make-reproducible
> + (lambda _
> + ;; This removes time-dependent code to make alpine reproducible.
> + (substitute* "pico/blddate.c"
> + (("%02d-%s-%d") "1970-01-01"))
> + (substitute* (list "alpine/Makefile.in"
> + "web/src/alpined.d/Makefile.in")
> + (("`date`") "1970-01-01"))
> + #t)))))
> + (inputs
> + `(("ncurses" ,ncurses)
> + ("openssl" ,openssl)
> + ("gnutls" ,gnutls)
> + ("openldap" ,openldap)
> + ("cyrus-sasl" ,cyrus-sasl)
> + ("mit-krb5" ,mit-krb5)
> + ("aspell" ,aspell)
> + ("tcl" ,tcl)
> + ("linux-pam" ,linux-pam)))
> + (home-page "http://patches.freeiz.com/alpine/")
> + (synopsis "Alternatively Licensed Program for Internet News and Email")
> + (description
> + "Alpine is a text-based mail and news client. Alpine includes several
> +tools and applications:
> +@enumerate
> +@item alpine, the Alpine mailer
> +@item pico, the standalone text editor, GNU nano's predecessor
> +@item pilot, the standalone file system navigator
> +@end enumerate\n")
> + (license asl2.0)))

Package pushed to master.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljpIkkACgkQ5qXuPBlG
eg3xvw//eQvirNopYCvwUY+QrMosgOIbGYRjHRvxdTOtOuJ0fVXbYLOO2gmXuVHZ
/20kohxORWe7lCXUqzKPPtJy5h732/lg2oi8tgVdwltyJYBUKFT3mPPtnjwr+hA6
pe3Ta9hPhBEghFGPzqLdQqp54HP9UCHcj69+tAghyunDNKgiX0nydb1j6qUNKKuv
W5pZ+J1BneclyAdR2iJygu3iWDsLMPZaezhIerpZiRKZp9TjOhZX3sg2/yWtrMn9
r2crlOy4uCYZxHNvwwK+kTCRnleVhtR6iGMG6brJZQCDn6QY1jVGp1ZXyc3ocCTt
snAaOs0C0OE4Azx2cTxv8K0FSJKSRjsfbMhqB91BOtTEOr2t49UtOv7g1SHUpuDz
2oG/UlZFqvD4anXjPwnQpKXH9SBDYP0vbW4wTdvah4FyBJT4aQ/hwxHuxADNL7Z3
Y3Y5QxlpSj3KQX99MXbAPfwKsPYig9EgC4H+HXP+lSjmb5Dfx3Bdz1EE+OuYTK0E
h2ZIAlSQevVzmzW5aSsWzWFTvLBjoSZ4erqlop1iON89/M2Pm3a72/yVJhSPes80
0nDPuiNFDkNEoAxJv6llwtYiSLDYqsVrMErjxNHE7N9kEO4juFBgZns9go+pTwbZ
eiiEeWmtNDY8qQtie4TVQQqlxqKTH0sCZPTAnLU7Kr96MEJnWVg=
=Q9vV
-----END PGP SIGNATURE-----

Closed
?