[PATCH 0/1] gnu: Add emacs-default-encrypt.

  • Done
  • quality assurance status badge
Details
2 participants
  • Chris Marusich
  • Ludovic Courtès
Owner
unassigned
Submitted by
Chris Marusich
Severity
normal
C
C
Chris Marusich wrote on 11 Apr 2017 10:44
(address . guix-patches@gnu.org)(name . Chris Marusich)(address . cmmarusich@gmail.com)
20170411084448.9457-1-cmmarusich@gmail.com
Hi,

Here's a patch to add DefaultEncrypt. Thanks to Alex for their help!
Sometimes it takes a second pair of eyes to solve a problem [1].


Chris Marusich (1):
gnu: Add emacs-default-encrypt.

gnu/packages/emacs.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

--
2.12.0
C
C
Chris Marusich wrote on 11 Apr 2017 10:49
[PATCH 1/1] gnu: Add emacs-default-encrypt.
(address . 26442@debbugs.gnu.org)(name . Chris Marusich)(address . cmmarusich@gmail.com)
20170411084950.9719-1-cmmarusich@gmail.com
* gnu/packages/emacs.scm (emacs-default-encrypt): New variable.
---
gnu/packages/emacs.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3db31f207..53ad50e86 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014, 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
+;;; Copyright © 2016, 2017 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 humanitiesNerd <catonano@gmail.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
@@ -4057,3 +4057,31 @@ jQuery and Bootstrap resources included via osscdn.")
(description
"This Emacs package highlights the s-exp at the current position.")
(license license:gpl3+)))
+
+(define-public emacs-default-encrypt
+ (package
+ (name "emacs-default-encrypt")
+ (version "4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ ;; A versioned, signed copy of this package is avialable on the
+ ;; home page, but 'guix download' fails to download it.
+ "https://github.com/emacsmirror/emacswiki.org/raw/master/jl-encrypt.el"))
+ (file-name (string-append "jl-encrypt-" version ".el"))
+ (sha256
+ (base32
+ "16i3rlfp3jxlqvndn8idylhmczync3gwmy8a019v29vyr48rnnr0"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.informationelle-selbstbestimmung-im-internet.de/Emacs.html")
+ (synopsis "Automatically encrypt or sign Gnus messages in Emacs")
+ (description
+ "DefaultEncrypt is designed to be used with Gnus in Emacs. It
+automatically encrypts messages that you send (e.g., email) when public keys
+for all recipients are available, and it protects you from accidentally
+sending un-encrypted messages. It can also be configured to automatically
+sign messages that you send. For details and instructions on how to use
+DefaultEncrypt, please refer to the home page or read the comments in the
+source file, @file{jl-encrypt.el}.")
+ (license license:gpl3+)))
--
2.12.0
L
L
Ludovic Courtès wrote on 11 Apr 2017 17:51
(name . Chris Marusich)(address . cmmarusich@gmail.com)(address . 26442-done@debbugs.gnu.org)
87shlfq6wx.fsf@gnu.org
Hello Chris,

Chris Marusich <cmmarusich@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-default-encrypt): New variable.

Applied, thanks!

Toggle quote (6 lines)
> + (method url-fetch)
> + (uri (string-append
> + ;; A versioned, signed copy of this package is avialable on the
> + ;; home page, but 'guix download' fails to download it.
> + "https://github.com/emacsmirror/emacswiki.org/raw/master/jl-encrypt.el"))

I think it’s OK to take it from github.com, but for the record, I don’t
seem to experience the problem you’re referring to:

Toggle snippet (9 lines)
$ guix download https://www.informationelle-selbstbestimmung-im-internet.de/emacs/jl-encrypt4.1/jl-encrypt.el

Starting download of /tmp/guix-file.ukU3OR
From https://www.informationelle-selbstbestimmung-im-internet.de/emacs/jl-encrypt4.1/jl-encrypt.el...
…rypt.el 24KiB 615KiB/s 00:00 [####################] 100.0%
/gnu/store/ysgd00j7pm38wi0h40557rhsq5zprnj9-jl-encrypt.el
0viwnsza60cgf0ayh45pgbij156yacxwdfvmfldy0161vkr9dizl

(That’s with Guile 2.2.0.)

Ludo’.
Closed
C
C
Chris Marusich wrote on 11 Apr 2017 18:41
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 26442-done@debbugs.gnu.org)
87tw5u6gnp.fsf@gmail.com
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (12 lines)
> I don’t seem to experience the problem you’re referring to:
>
> $ guix download https://www.informationelle-selbstbestimmung-im-internet.de/emacs/jl-encrypt4.1/jl-encrypt.el
>
> Starting download of /tmp/guix-file.ukU3OR
> From https://www.informationelle-selbstbestimmung-im-internet.de/emacs/jl-encrypt4.1/jl-encrypt.el...
> …rypt.el 24KiB 615KiB/s 00:00 [####################] 100.0%
> /gnu/store/ysgd00j7pm38wi0h40557rhsq5zprnj9-jl-encrypt.el
> 0viwnsza60cgf0ayh45pgbij156yacxwdfvmfldy0161vkr9dizl
>
> (That’s with Guile 2.2.0.)

That's because the author fixed it just a few hours ago! :-) I'll
submit another patch to update the URL to use their home page.

--
Chris
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEy/WXVcvn5+/vGD+x3UCaFdgiRp0FAljtByoACgkQ3UCaFdgi
Rp2Qgg/9EapOq8voATHfTP11CbVwPHnMSXeKXtpvswhVosmhxY4jKASpdCNTvv04
S2ezl7rmzhraitKHQjma/p25cdhaAOL4XaNiluHQbl8OpR9N8Ygs6WEqELR63m4X
MkC1bgwRy+Aba4v0bRvKHPEEGnI+d7aqcZ3BN2gj3LxYzRYURyrKy5+i+KhL2mwz
kSa8nZYL26ZQ2lIHGMmpUd5wgK8ye691HUO/9uWeZdYTcUvEWQmABLLP7egH9r2X
pH3jo/YtyEcu9JuCrVrUsK5yEQhzfXrtmMQCmIRGBMZkfs37wS9wkvQFZ0SIvpwh
3zi6vasT1+bjroqNKj0NlvrzwqKpDFIXTaYb6wk8v50Z6R6BL9kaogxVCSU+7TAU
16fbUDczcsa14+QehA21ZdLfxPWuWSzW2NgqBukQGwBys8CXUJcxGyf//x3O3u/+
ZRWARtKRwp+Tuv3fCSEMBojW20MqFFLXVAUz3M9Mb+p97icZbcLn392E4CMDsAFV
dE5OVKPUtCB/EdTi+jon/GD6AMyZ0wEXmZB/ajJFj1EElporfX+KO8L0NZ2hTwvL
ok8UaNH5xl7U2DFR67K8d06uWM9qOKnZZ/C/XffU5kgbTfkcSG0ISzaYcGXAtCB4
kZxHVcSfdI+3587F3j9tPPdZLXhySVUDdqSTIR3/NpuE6ROVNDs=
=5J6X
-----END PGP SIGNATURE-----

Closed
?