Add some (non-free?) font licenses.

  • Done
  • quality assurance status badge
Details
2 participants
  • Clément Lassieur
  • Marius Bakke
Owner
unassigned
Submitted by
Clément Lassieur
Severity
normal
C
C
Clément Lassieur wrote on 21 Apr 2017 16:46
(address . guix-patches@gnu.org)
87a879zum4.fsf@lassieur.org
The first patch adds Bitstream Vera license, which IMHO is non-free.
Feel free to discuss it though, I'm not sure of the comment I wrote.

The font could be added even though it is non-free because it could be
considered a "Non-fonctional data". See

The second patch adds Arev license, which is almost like Bitsteam Vera,
and is needed by 0ad-data (which I'm working on).

The third patch fixes font-bitstream-vera, which IMHO erroneously had
X11-style license.
C
C
Clément Lassieur wrote on 21 Apr 2017 16:48
[PATCH 1/3] licenses: Add Bitstream Vera.
(address . 26588@debbugs.gnu.org)
20170421144804.10169-1-clement@lassieur.org
* guix/licenses.scm (bitstream-vera): New variable.
---
guix/licenses.scm | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)

Toggle diff (40 lines)
diff --git a/guix/licenses.scm b/guix/licenses.scm
index 7b2ac2d31..09a17b8c6 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016, 2017 ng0 <ng0@libertad.pw>
+;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -71,7 +72,7 @@
tcl/tk
unlicense
vim
- x11 x11-style
+ x11 x11-style bitstream-vera
zpl2.1
zlib
fsf-free
@@ -471,6 +472,16 @@ which may be a file:// URI pointing the package's tree."
"Check the URI for details. "
comment)))
+(define bitstream-vera
+ (license "Bitstream Vera"
+ "https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"
+ "\"The Font Software may be sold as part of a larger software package
+but no copy of one or more of the Font Software typefaces may be sold by
+itself.\"
+
+The license is non-free because of the above clause, but a Guix package is a
+\"larger software package\"."))
+
(define zpl2.1
(license "Zope Public License 2.1"
"http://directory.fsf.org/wiki?title=License:ZopePLv2.1"
--
2.12.2
C
C
Clément Lassieur wrote on 21 Apr 2017 16:48
[PATCH 2/3] licenses: Add Arev.
(address . 26588@debbugs.gnu.org)
20170421144804.10169-2-clement@lassieur.org
* guix/licenses.scm (arev): New variable.
---
guix/licenses.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/guix/licenses.scm b/guix/licenses.scm
index 09a17b8c6..3bf275712 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -72,7 +72,7 @@
tcl/tk
unlicense
vim
- x11 x11-style bitstream-vera
+ x11 x11-style bitstream-vera arev
zpl2.1
zlib
fsf-free
@@ -482,6 +482,11 @@ itself.\"
The license is non-free because of the above clause, but a Guix package is a
\"larger software package\"."))
+(define arev
+ (license "Arev"
+ "http://tavmjong.free.fr/FONTS/ArevCopyright.txt"
+ (license-comment bitstream-vera)))
+
(define zpl2.1
(license "Zope Public License 2.1"
"http://directory.fsf.org/wiki?title=License:ZopePLv2.1"
--
2.12.2
C
C
Clément Lassieur wrote on 21 Apr 2017 16:48
[PATCH 3/3] gnu: font-bitstream-vera: Change license to Bitstream Vera.
(address . 26588@debbugs.gnu.org)
20170421144804.10169-3-clement@lassieur.org
This license is not X11-style because of its clause that makes it non-free.

* gnu/packages/fonts.scm (font-bitstream-vera)[license]: Change to Bitstream
Vera.
---
gnu/packages/fonts.scm | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 6579a66e4..18ddcc6e3 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -238,9 +238,7 @@ provide serif, sans and monospaced variants.")
(synopsis "Bitstream Vera sans-serif typeface")
(description "Vera is a sans-serif typeface from Bitstream, Inc. This
package provides the TrueType (TTF) files.")
- (license
- (license:x11-style
- "http://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))
+ (license (license:bitstream-vera))))
(define-public font-cantarell
(package
--
2.12.2
C
C
Clément Lassieur wrote on 21 Apr 2017 17:30
(address . 26588@debbugs.gnu.org)
878tmtzsl4.fsf@lassieur.org
Clément Lassieur <clement@lassieur.org> writes:

Toggle quote (20 lines)
> This license is not X11-style because of its clause that makes it non-free.
>
> * gnu/packages/fonts.scm (font-bitstream-vera)[license]: Change to Bitstream
> Vera.
> ---
> gnu/packages/fonts.scm | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index 6579a66e4..18ddcc6e3 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -238,9 +238,7 @@ provide serif, sans and monospaced variants.")
> (synopsis "Bitstream Vera sans-serif typeface")
> (description "Vera is a sans-serif typeface from Bitstream, Inc. This
> package provides the TrueType (TTF) files.")
> - (license
> - (license:x11-style
> - "http://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))
> + (license (license:bitstream-vera))))
^
Extra parenthesis, that I'll remove when I push (if I do).
Toggle quote (3 lines)
>
> (define-public font-cantarell
> (package
C
C
Clément Lassieur wrote on 23 Apr 2017 03:45
control message for bug #26618
(address . control@debbugs.gnu.org)
87lgqrvqv6.fsf@lassieur.org
block 26618 by 26588
C
C
Clément Lassieur wrote on 25 Apr 2017 11:19
control message for bug #26588
(address . control@debbugs.gnu.org)
871ssgkfod.fsf@lassieur.org
tags 26588 patch
M
M
Marius Bakke wrote on 26 Apr 2017 11:13
Re: bug#26588: [PATCH 1/3] licenses: Add Bitstream Vera.
87zif3cz0s.fsf@fastmail.com
Hello! Thanks for bringing this up.

Clément Lassieur <clement@lassieur.org> writes:

Toggle quote (2 lines)
> * guix/licenses.scm (bitstream-vera): New variable.

[...]
Toggle quote (10 lines)
> +(define bitstream-vera
> + (license "Bitstream Vera"
> + "https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"
> + "\"The Font Software may be sold as part of a larger software package
> +but no copy of one or more of the Font Software typefaces may be sold by
> +itself.\"
> +
> +The license is non-free because of the above clause, but a Guix package is a
> +\"larger software package\"."))

Instead of "officially recognizing" these licenses, which are unlikely
to be re-used and ostensibly non-free, perhaps we could have a
"fsdg-compatible" license procedure similar to "fsf-free". What do you
think?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkAZLMACgkQoqBt8qM6
VPrjfggAm+WscEPnlK+tEKKdf3q6XH7q+9CO3UhvySuom5bNuELSvTCVnuKKx2Vm
mI4ZY8F+fNyqqHJZxid1ScrzHwgUkTMxDGhpWLwPe5T9CM0gq49PYebQOyFCjxm5
iCZm/xR10sE9aJyHK4VtBQ6hvyS3qFwBforaWr2PZwq7XHkZPrA6warBoEJ0sMU2
Gx1lwjNXe33W299vMsSbuTeS/9WNeAMAEsnwfhAMJZVpvKCfsyce9xIqcPd8FW6N
pCKhlfpsQLhm2kafGA91vkzZMMD3rn2Nxzfity5sLwoq5NUyZGfhPpv3xvkSKYu1
4grRlPUsFfk6jeFQGLN/RiC5xZxbhA==
=tuxK
-----END PGP SIGNATURE-----

C
C
Clément Lassieur wrote on 29 Apr 2017 11:57
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26588@debbugs.gnu.org)
87y3ujleoj.fsf@lassieur.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (23 lines)
> Hello! Thanks for bringing this up.
>
> Clément Lassieur <clement@lassieur.org> writes:
>
>> * guix/licenses.scm (bitstream-vera): New variable.
>
> [...]
>
>> +(define bitstream-vera
>> + (license "Bitstream Vera"
>> + "https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"
>> + "\"The Font Software may be sold as part of a larger software package
>> +but no copy of one or more of the Font Software typefaces may be sold by
>> +itself.\"
>> +
>> +The license is non-free because of the above clause, but a Guix package is a
>> +\"larger software package\"."))
>
> Instead of "officially recognizing" these licenses, which are unlikely
> to be re-used and ostensibly non-free, perhaps we could have a
> "fsdg-compatible" license procedure similar to "fsf-free". What do you
> think?

Well, bitstream-vera is used twice (if we include 0ad). But anyway
that's okay. I should specify in the fsdg-compatible 'comment' argument
that it is non-free, right? Or maybe all fsdg-compatible would be
non-free?
M
M
Marius Bakke wrote on 29 Apr 2017 16:00
(name . Clément Lassieur)(address . clement@lassieur.org)(address . 26588@debbugs.gnu.org)
87bmrfb9f9.fsf@fastmail.com
Clément Lassieur <clement@lassieur.org> writes:

Toggle quote (30 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Hello! Thanks for bringing this up.
>>
>> Clément Lassieur <clement@lassieur.org> writes:
>>
>>> * guix/licenses.scm (bitstream-vera): New variable.
>>
>> [...]
>>
>>> +(define bitstream-vera
>>> + (license "Bitstream Vera"
>>> + "https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"
>>> + "\"The Font Software may be sold as part of a larger software package
>>> +but no copy of one or more of the Font Software typefaces may be sold by
>>> +itself.\"
>>> +
>>> +The license is non-free because of the above clause, but a Guix package is a
>>> +\"larger software package\"."))
>>
>> Instead of "officially recognizing" these licenses, which are unlikely
>> to be re-used and ostensibly non-free, perhaps we could have a
>> "fsdg-compatible" license procedure similar to "fsf-free". What do you
>> think?
>
> Well, bitstream-vera is used twice (if we include 0ad). But anyway
> that's okay. I should specify in the fsdg-compatible 'comment' argument
> that it is non-free, right? Or maybe all fsdg-compatible would be
> non-free?

0ad could include (package-license font-bitstream-vera) instead. I also
came across this font in "Hedgewars", so it's fairly prevalent.

The default comment of the "fsdg-compatible" (or fsdg-free as Debian
describes it[0]) license procedure should say something about not
necessarily being free, but passing FSDG criteria; but it's good to have
more specific comments in the actual packages.

Anyway, just an opinion, but I think such a procedure would be nice to
have :)

-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkEnIoACgkQoqBt8qM6
VPq6tgf+K3dCgNl4l8D2joQ3tuz4MVeXdvRb3oC6tKRw2AfOgIVi/LZ66ypN60Ib
Rjdh0g+uyIIovwWIZmDLse6mFocD2iaA5U8ROmYz47m161zCFFelELm7ABUpiEAX
crO4XLX16mnuNgHrpFSN6SK6S0zd9ZHhz1uu8zzr5BL7iOlJfB95NXWWjjAv8BkE
v/CKhSIJstWWyZD2btbX3SiKhOyjyy++LQBFrr4fNNi5IWMAlJ96ZyMP2AGZUnYd
AcMpi1sDLy1S2yOo2h1xlY6qde4JlG0SvDIS65WQnU58RDsjUSKU4APbWNkBkRqO
o5FWDdgJVa2qVrLegJyC+YPbdDmzvg==
=8atm
-----END PGP SIGNATURE-----

C
C
Clément Lassieur wrote on 1 May 2017 13:00
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26588@debbugs.gnu.org)
87a86wdeow.fsf@lassieur.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (45 lines)
> Clément Lassieur <clement@lassieur.org> writes:
>
>> Marius Bakke <mbakke@fastmail.com> writes:
>>
>>> Hello! Thanks for bringing this up.
>>>
>>> Clément Lassieur <clement@lassieur.org> writes:
>>>
>>>> * guix/licenses.scm (bitstream-vera): New variable.
>>>
>>> [...]
>>>
>>>> +(define bitstream-vera
>>>> + (license "Bitstream Vera"
>>>> + "https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"
>>>> + "\"The Font Software may be sold as part of a larger software package
>>>> +but no copy of one or more of the Font Software typefaces may be sold by
>>>> +itself.\"
>>>> +
>>>> +The license is non-free because of the above clause, but a Guix package is a
>>>> +\"larger software package\"."))
>>>
>>> Instead of "officially recognizing" these licenses, which are unlikely
>>> to be re-used and ostensibly non-free, perhaps we could have a
>>> "fsdg-compatible" license procedure similar to "fsf-free". What do you
>>> think?
>>
>> Well, bitstream-vera is used twice (if we include 0ad). But anyway
>> that's okay. I should specify in the fsdg-compatible 'comment' argument
>> that it is non-free, right? Or maybe all fsdg-compatible would be
>> non-free?
>
> 0ad could include (package-license font-bitstream-vera) instead. I also
> came across this font in "Hedgewars", so it's fairly prevalent.
>
> The default comment of the "fsdg-compatible" (or fsdg-free as Debian
> describes it[0]) license procedure should say something about not
> necessarily being free, but passing FSDG criteria; but it's good to have
> more specific comments in the actual packages.
>
> Anyway, just an opinion, but I think such a procedure would be nice to
> have :)
>
> [0] https://packages.debian.org/sid/ttf-bitstream-vera

Ok! Here are two patches: one adds fsdg-compatible, and the other
updates the font package. I'll also send the 0ad update to the 0ad
debbugs thread.
C
C
Clément Lassieur wrote on 1 May 2017 13:01
[PATCH 1/2] licenses: Add new meta-license fsdg-compatible.
(address . 26588@debbugs.gnu.org)
20170501110126.31945-1-clement@lassieur.org
* guix/licenses.scm (fsdg-compatible): New record with constructor.
---
guix/licenses.scm | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)

Toggle diff (38 lines)
diff --git a/guix/licenses.scm b/guix/licenses.scm
index 7b2ac2d31..830d4e1ec 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016, 2017 ng0 <ng0@libertad.pw>
+;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,7 +76,8 @@
zpl2.1
zlib
fsf-free
- wtfpl2))
+ wtfpl2
+ fsdg-compatible))
(define-record-type <license>
(license name uri comment)
@@ -488,4 +490,13 @@ of licenses, approved as free by the FSF. More details can be found at URI."
uri
comment))
+(define* (fsdg-compatible uri #:optional (comment ""))
+ "Return a license that does not fit any of the ones above or a collection
+of licenses, not necessarily free, but in accordance with FSDG as Non-functional
+Data. More details can be found at URI. See also
+https://www.gnu.org/distros/free-system-distribution-guidelines.en.html#non-functional-data"
+ (license "FSDG-compatible"
+ uri
+ comment))
+
;;; licenses.scm ends here
--
2.12.2
C
C
Clément Lassieur wrote on 1 May 2017 13:01
[PATCH 2/2] gnu: font-bitstream-vera: Change license to fsdg-compatible.
(address . 26588@debbugs.gnu.org)
20170501110126.31945-2-clement@lassieur.org
This license is not X11-style because of its clause that makes it non-free.

* gnu/packages/fonts.scm (font-bitstream-vera)[license]: Change to
fsdg-compatible Bitstream Vera.
---
gnu/packages/fonts.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 2452a1c81..1873c7659 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.com>
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -239,8 +240,11 @@ provide serif, sans and monospaced variants.")
(description "Vera is a sans-serif typeface from Bitstream, Inc. This
package provides the TrueType (TTF) files.")
(license
- (license:x11-style
- "http://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))
+ (license:fsdg-compatible
+ "https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"
+ "The Font Software may be sold as part of a larger software package but
+no copy of one or more of the Font Software typefaces may be sold by
+itself."))))
(define-public font-cantarell
(package
--
2.12.2
M
M
Marius Bakke wrote on 1 May 2017 16:53
Re: bug#26588: [PATCH 1/3] licenses: Add Bitstream Vera.
(name . Clément Lassieur)(address . clement@lassieur.org)(address . 26588@debbugs.gnu.org)
87a86whbmn.fsf@fastmail.com
Clément Lassieur <clement@lassieur.org> writes:

Toggle quote (51 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Clément Lassieur <clement@lassieur.org> writes:
>>
>>> Marius Bakke <mbakke@fastmail.com> writes:
>>>
>>>> Hello! Thanks for bringing this up.
>>>>
>>>> Clément Lassieur <clement@lassieur.org> writes:
>>>>
>>>>> * guix/licenses.scm (bitstream-vera): New variable.
>>>>
>>>> [...]
>>>>
>>>>> +(define bitstream-vera
>>>>> + (license "Bitstream Vera"
>>>>> + "https://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"
>>>>> + "\"The Font Software may be sold as part of a larger software package
>>>>> +but no copy of one or more of the Font Software typefaces may be sold by
>>>>> +itself.\"
>>>>> +
>>>>> +The license is non-free because of the above clause, but a Guix package is a
>>>>> +\"larger software package\"."))
>>>>
>>>> Instead of "officially recognizing" these licenses, which are unlikely
>>>> to be re-used and ostensibly non-free, perhaps we could have a
>>>> "fsdg-compatible" license procedure similar to "fsf-free". What do you
>>>> think?
>>>
>>> Well, bitstream-vera is used twice (if we include 0ad). But anyway
>>> that's okay. I should specify in the fsdg-compatible 'comment' argument
>>> that it is non-free, right? Or maybe all fsdg-compatible would be
>>> non-free?
>>
>> 0ad could include (package-license font-bitstream-vera) instead. I also
>> came across this font in "Hedgewars", so it's fairly prevalent.
>>
>> The default comment of the "fsdg-compatible" (or fsdg-free as Debian
>> describes it[0]) license procedure should say something about not
>> necessarily being free, but passing FSDG criteria; but it's good to have
>> more specific comments in the actual packages.
>>
>> Anyway, just an opinion, but I think such a procedure would be nice to
>> have :)
>>
>> [0] https://packages.debian.org/sid/ttf-bitstream-vera
>
> Ok! Here are two patches: one adds fsdg-compatible, and the other
> updates the font package. I'll also send the 0ad update to the 0ad
> debbugs thread.

Thanks! These patches LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkHS+AACgkQoqBt8qM6
VPqo+AgAk1HFGZJJIVivsVFIoPHhvaR2q7nPQUx/M6h/1xHkzuFgQULEBf8FZ5Mv
+vrfvh+yING1NTwcobbmPjCwBMjOiDkAXSpKe3Bv2EYfALI+9+JIvTASvp0BRkUX
f1DwbzTDPVtGDoCrxT33rItVl1V6DmXUAKBQF+YqHO+x1AxvLrjv8iJay4xuhK97
Tt7CzMFffmy2iymiYfTQ1xxmEwM5sWLjkWPsrszhQLHBsFHXTL4yrL7+0FM8geyV
Agh/qG3W4Uy/nUvDFfCzfbP/Jpxqhl3r04kgUecL8TdymEt9cxdcuHS0pMu5RmBL
YuGXbL+2B1nagag4LFaOIOltczcFiQ==
=gzs7
-----END PGP SIGNATURE-----

C
C
Clément Lassieur wrote on 1 May 2017 21:37
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 26588-done@debbugs.gnu.org)
87efw8l66g.fsf@lassieur.org
Toggle quote (6 lines)
>> Ok! Here are two patches: one adds fsdg-compatible, and the other
>> updates the font package. I'll also send the 0ad update to the 0ad
>> debbugs thread.
>
> Thanks! These patches LGTM.

I pushed them. Thank you for the review :-)
Closed
?