guix includes wrong directory in build environment

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • ng0
  • ng0
Owner
unassigned
Submitted by
ng0
Severity
normal
N
(address . bug-guix@gnu.org)
20170610180642.fxkss3io2oorqmsi@abyayala
Attachment: file
From 16a9b9f5976cbe8d301595768c4caeb1a947d9cf Mon Sep 17 00:00:00 2001
From: ng0 <ng0@we.make.ritual.n0.is>
Date: Mon, 19 Sep 2016 16:23:53 +0000
Subject: [PATCH] gnu: Add gnunet-fuse.

* gnu/packages/gnunet.scm (gnunet-fuse): New variable.
---
gnu/packages/gnunet.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 44d612989..c7468378a 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -391,3 +391,32 @@ services.")
`(("pkg-config" ,pkg-config)
("libglade" ,libglade)))
(synopsis "Graphical front-end tools for GNUnet")))
+
+(define-public gnunet-fuse
+ (package
+ (name "gnunet-fuse")
+ (version "0.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gnunet/gnunet-fuse-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ggc2gkyd6qvd4a9z84xbynq5jajbldbx6qkh79k9zjiycz2ffbb"))))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-gnunet="
+ (assoc-ref %build-inputs "gnunet")))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gnunet" ,gnunet)
+ ("fuse" ,fuse)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Mount directories which are published on GNUnet")
+ (description
+ "GNUnet-fuse allows you to mount directories published on GNUnet
+as read-only file-systems on operating systems that support the
+FUSE API).")
+ (license license:gpl3+)
+ (home-page "https://gnunet.org/")))
--
2.13.1
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEqIyK3RKYKNfqwC5S4i+bv+40hYgFAlk8NTIACgkQ4i+bv+40
hYip6A/8Dwq8D/jBfxDtBfRT2HIS0vinaI0gJO78vLydE+Tn6KQmoruHIZPCeZAY
46M+Kq+XuMYYd2S+avLOWhDgq56VwP7hhoVkmmx4IqnthOOSk/3z+n2Mqo0g1oIs
IfL51YHjyH6MFYaz5YzpIuWDnpydbilrgtqJRQYuaH295TGxSFUblA4m1W+N2TvN
+WVGSPWx6jgsK+IErWRXhxlYvb7cqL8mOfnZsCDGsNstILRFWSnV6ZIoUBQ6R7z7
0WH5CLTjwTCEg/7Uw+C1C9djiRJBq/JwA/SokAckroowREnCzqfZq7VA1Ei+4WZT
X1WWhumeilKrosR4LE1zi1AHfcdEZBVkijoJ9+De5btK3SywL2d5Nt0s/YJkM3rw
4DYAR/jOP/OHAA2zBPFjqnTFap42Fp76zQ6LL+TD7LYGAhSYJ+RxTSDHEaAUycOn
Wy2tg6O043pPaKEfbfD9YYsRPoxzpsnl2M1yBvkge+Zs09FbQRvuSTW6C7otXzoD
avOcBzP3bI46aleJUanxDSjyE/bXYSjtv+Llk8rSf3egG/snOWQQQdX4HVRQ20BW
F/lAE1iu66Th9MINjq207N8NAW/87xqnPVFue6FbjLYD/DpFPlI4qYHf274mR4FX
RqANqLqtQyMNAaNuLs/naz66BQjtGibhvPhWVAHbBNRqrlDe4P4=
=b6wV
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 16 Jun 2017 10:48
(name . ng0)(address . ng0@pragmatique.xyz)(address . 27314@debbugs.gnu.org)
87vanwgvxv.fsf@gnu.org
Hi ng0,

ng0 <ng0@pragmatique.xyz> skribis:

Toggle quote (12 lines)
> gnunet-fuse 'picks' the first gnunet it finds in the /gnu/store/:
>
> checking for fuse.h... yes
> checking for GNUnet core... /gnu/store/01ja9wj2v48y5www5bhpmkx94wc4b553-gnunetgf-0.10.114b59076f
> checking for GNUnet util library in /gnu/store/01ja9wj2v48y5www5bhpmkx94wc4b553-gnunetgf-0.10.114b59076f... checking for gnunet/gnunet_util_lib.h... no
> configure: error: gnunet-fuse requires GNUnet
> phase `configure' failed after 2.0 seconds
> note: keeping build directory `/tmp/guix-build-gnunet-fuse-0.10.114b59076f.drv-0'
> builder for `/gnu/store/qc0va2siswmc72bdk8xi4hm7dwz09xpy-gnunet-fuse-0.10.114b59076f.drv' failed with exit code 1
> @ build-failed /gnu/store/qc0va2siswmc72bdk8xi4hm7dwz09xpy-gnunet-fuse-0.10.114b59076f.drv - 1 builder for `/gnu/store/qc0va2siswmc72bdk8xi4hm7dwz09xpy-gnunet-fuse-0.10.114b59076f.drv' failed with exit code 1
> guix build: error: build failed: build of `/gnu/store/qc0va2siswmc72bdk8xi4hm7dwz09xpy-gnunet-fuse-0.10.114b59076f.drv' failed

Could you run “guix build gnunet-fuse -K” and then check
/tmp/guix-build-gnunet-fuse-0.10.114b59076f.drv-0/environment-variables
as well as the ‘config.log’ file in there?

The build environment includes only the ‘gnunet’ package that the recipe
provides, not another ‘gnunet’.

HTH,
Ludo’.
N
(address . 27314@debbugs.gnu.org)
20170616101215.2pgbahdljuzrn6dn@abyayala
Ludovic Courtès transcribed 1.4K bytes:
Toggle quote (26 lines)
> Hi ng0,
>
> ng0 <ng0@pragmatique.xyz> skribis:
>
> > gnunet-fuse 'picks' the first gnunet it finds in the /gnu/store/:
> >
> > checking for fuse.h... yes
> > checking for GNUnet core... /gnu/store/01ja9wj2v48y5www5bhpmkx94wc4b553-gnunetgf-0.10.114b59076f
> > checking for GNUnet util library in /gnu/store/01ja9wj2v48y5www5bhpmkx94wc4b553-gnunetgf-0.10.114b59076f... checking for gnunet/gnunet_util_lib.h... no
> > configure: error: gnunet-fuse requires GNUnet
> > phase `configure' failed after 2.0 seconds
> > note: keeping build directory `/tmp/guix-build-gnunet-fuse-0.10.114b59076f.drv-0'
> > builder for `/gnu/store/qc0va2siswmc72bdk8xi4hm7dwz09xpy-gnunet-fuse-0.10.114b59076f.drv' failed with exit code 1
> > @ build-failed /gnu/store/qc0va2siswmc72bdk8xi4hm7dwz09xpy-gnunet-fuse-0.10.114b59076f.drv - 1 builder for `/gnu/store/qc0va2siswmc72bdk8xi4hm7dwz09xpy-gnunet-fuse-0.10.114b59076f.drv' failed with exit code 1
> > guix build: error: build failed: build of `/gnu/store/qc0va2siswmc72bdk8xi4hm7dwz09xpy-gnunet-fuse-0.10.114b59076f.drv' failed
>
> Could you run “guix build gnunet-fuse -K” and then check
> /tmp/guix-build-gnunet-fuse-0.10.114b59076f.drv-0/environment-variables
> as well as the ‘config.log’ file in there?
>
> The build environment includes only the ‘gnunet’ package that the recipe
> provides, not another ‘gnunet’.
>
> HTH,
> Ludo’.

Files appended.
--
ng0
OpenPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
https://krosos.org/~/ng0/https://www.infotropique.org
Attachment: config.log
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEqIyK3RKYKNfqwC5S4i+bv+40hYgFAllDrv4ACgkQ4i+bv+40
hYgGIQ//f8OlhgG0hzYQx2mPM7tHKUBgfguYHF6gPBfrqrmXIVs1TEVF9phHBw0u
t5tnq/aIceZOu1ySZDE/DmWqLFa+pfhbGM21RIosImBRswMekxG4rE+s6SfEH0RO
jXMW6DMUA3uBXap4IlJ81M498m5dWfDWSs76Y6NKpPbfphPF/Ei1k7K02VNVcjyv
d/XwtIxHHmN6hPjmG85g08uTl03bcEAUbJMtaX3URu8KzRC6pPfIiRfUCh3ZaTuj
uhkQrXMgS6EkLXUTCbETsJwZEZmV79hylVi7JJkuFOgCeagRNVjI9sPGuEvZJ+El
T0cATmE5AM5BGQZHlZpw3TFE0lWLjwr6YZMM4W/yaR1dexmGm8NqjMszWdSjCXNS
9G+wlRWKhpp6DDnIjGLTdfXqtA13Psgg1oR9G8N9HqZeac+zreTV50+OQSTmzFVi
5c7oeW7Lkd1dsvdbkLBlVxl04KgkQKN4JGzPxwagwcXzNvwBXPJSnUzUiaLN28gS
HhEe7L0oMG3HQNL4DH/P1YlppYBov9wzHO5gg3m7FrfU9FabcPd5BIapzve0TWO5
ygUSt8FiMn6V6CmBbNwgnzIStnStGdk3Hnf7mn+Ui5k5Zh32a4vwEy+KQcDKxa5u
jbxEcvPgTPdPOHzm4M7BvH2u0/4pfZmFJkN5GwsHamvMc+6mg3o=
=ElSU
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 26 Jun 2017 21:54
(address . 27314@debbugs.gnu.org)
87vani7cek.fsf@gnu.org
Hi ng0,

config.log reads this:

Toggle quote (6 lines)
> configure:9394: gcc -c -I/gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include -fno-strict-aliasing -Wall -g -O2 -I/gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include conftest.c >&5
> In file included from /gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include/gnunet/gnunet_util_lib.h:56:0,
> from conftest.c:44:
> /gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include/gnunet/gnunet_crypto_lib.h:80:20: fatal error: gcrypt.h: No such file or directory
> compilation terminated.

I think this means that ‘gnunetgf’ should propagate libgcrypt.

I’m closing this bug because I think it’s a packaging issue and not the
bug suggested in the Subject line.

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 26 Jun 2017 21:54
control message for bug #27314
(address . control@debbugs.gnu.org)
87tw327ced.fsf@gnu.org
tags 27314 notabug
close 27314
N
Re: bug#27314: guix includes wrong directory in build environment
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 27314@debbugs.gnu.org)
20170626212535.tp4ikmff3yqmojtt@abyayala
Ludovic Courtès transcribed 0.9K bytes:
Toggle quote (18 lines)
> Hi ng0,
>
> config.log reads this:
>
> > configure:9394: gcc -c -I/gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include -fno-strict-aliasing -Wall -g -O2 -I/gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include conftest.c >&5
> > In file included from /gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include/gnunet/gnunet_util_lib.h:56:0,
> > from conftest.c:44:
> > /gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include/gnunet/gnunet_crypto_lib.h:80:20: fatal error: gcrypt.h: No such file or directory
> > compilation terminated.
>
> I think this means that ‘gnunetgf’ should propagate libgcrypt.
>
> I’m closing this bug because I think it’s a packaging issue and not the
> bug suggested in the Subject line.
>
> Thanks,
> Ludo’.

The thing here is that I am _not_ using gnunetgf for the package in question,
I am using gnunet, from guix master. So from my perspective it is a bug and it
is repeating every time.

gnunetgf[2] inherits from gnunetg[1]


and gnunetg inherits from gnunet but overrides most of the package definition.

But my gnunet-fuse does *only* use ("gnunet" ,gnunet) directly from (gnu packages gnunet)
in guix master, not the module I defined. I don't think propagating libgcrypt in an
unrelated package will fix this issue.
--
ng0
OpenPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
personal: https://ng-0.github.iohttps://krosos.org/
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEqIyK3RKYKNfqwC5S4i+bv+40hYgFAllRe84ACgkQ4i+bv+40
hYhlJhAAmp4ZfP4W9veV0qp3NvROQnIrM0CakyJVeNkniwy3SehVNTnojvHmFJSi
WR7A5ayhn88v2ki1AGmFCNp/bdB0bULLnUIbdsSgN8YWoBDUrdQik1dddr+Xu2/G
oOCevul64H+4xckGx3QzEXf52O8QA+KtTJB+jiYX9fxDM2emHracHMNfJiazG8MS
a8Vug0wI9gfI07jVkpAa3X1qeQva80uUeNk5Ka7T7FCuLlvZO49FTPjhsdGQLFq2
bFAa1O4r/xLmXfR4pHgcfgGiGWNMSSjtySI54cudtwe8Aqj5TyMVxEf5AxQgc02k
7CDrPQEG+IvdhxYMlr3d12mKxYGo7CIrOX76AT2EfYuY64L5NcUP9b35bf7i08sQ
Yw8KvjDWcEPJVY5aAShI7O0fAByVmabaLdvpReuG/9jjAb+Q0PhTJDXFXi6NMQkg
peFcLY+YPTw0C/wGTxlpgE9PNN+D1khLYFgvQ5rs/e7On6CFL2pXfVkHIlnToC2r
ly3o+l9Fq6NMoNxjjrLzskXKeilv5SCaxT8WcH9usXQQYy2flhPmbZtUNZYIDTx6
aFUWarEM0UyOuwGuSJcLucQbdTsbPuxzPI+FoO0khcyldF5NnI3Uz4BjN0biJo8+
tEmFPHHObcP9btLoKJEwAGX6w5Jzn40uHR78vra3Ow0peNWQmKk=
=Bfyc
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 27 Jun 2017 15:42
(address . 27314@debbugs.gnu.org)
87bmp95yzb.fsf@gnu.org
Hi ng0,

ng0 <ng0@infotropique.org> skribis:

Toggle quote (30 lines)
> Ludovic Courtès transcribed 0.9K bytes:
>> Hi ng0,
>>
>> config.log reads this:
>>
>> > configure:9394: gcc -c -I/gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include -fno-strict-aliasing -Wall -g -O2 -I/gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include conftest.c >&5
>> > In file included from /gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include/gnunet/gnunet_util_lib.h:56:0,
>> > from conftest.c:44:
>> > /gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include/gnunet/gnunet_crypto_lib.h:80:20: fatal error: gcrypt.h: No such file or directory
>> > compilation terminated.
>>
>> I think this means that ‘gnunetgf’ should propagate libgcrypt.
>>
>> I’m closing this bug because I think it’s a packaging issue and not the
>> bug suggested in the Subject line.
>>
>> Thanks,
>> Ludo’.
>
> The thing here is that I am _not_ using gnunetgf for the package in question,
> I am using gnunet, from guix master. So from my perspective it is a bug and it
> is repeating every time.
>
> gnunetgf[2] inherits from gnunetg[1]
>
> 1: https://github.com/ng-0/guix_packages/blob/master/ng0/packages/gnunet.scm#L59
> 2: https://github.com/ng-0/guix_packages/blob/master/ng0/packages/gnunet.scm#L167
>
> and gnunetg inherits from gnunet but overrides most of the package definition.

Hey, this is not Guix code here. :-)

I can only give guidance to debug this. For instance, could you check
with “guix graph” whether the package graph really looks the way you
want?

Thanks,
Ludo’.
N
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 27314@debbugs.gnu.org)
20170627142303.hbpegpjzotukkiwn@abyayala
Ludovic Courtès transcribed 1.7K bytes:
Toggle quote (36 lines)
> Hi ng0,
>
> ng0 <ng0@infotropique.org> skribis:
>
> > Ludovic Courtès transcribed 0.9K bytes:
> >> Hi ng0,
> >>
> >> config.log reads this:
> >>
> >> > configure:9394: gcc -c -I/gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include -fno-strict-aliasing -Wall -g -O2 -I/gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include conftest.c >&5
> >> > In file included from /gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include/gnunet/gnunet_util_lib.h:56:0,
> >> > from conftest.c:44:
> >> > /gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include/gnunet/gnunet_crypto_lib.h:80:20: fatal error: gcrypt.h: No such file or directory
> >> > compilation terminated.
> >>
> >> I think this means that ‘gnunetgf’ should propagate libgcrypt.
> >>
> >> I’m closing this bug because I think it’s a packaging issue and not the
> >> bug suggested in the Subject line.
> >>
> >> Thanks,
> >> Ludo’.
> >
> > The thing here is that I am _not_ using gnunetgf for the package in question,
> > I am using gnunet, from guix master. So from my perspective it is a bug and it
> > is repeating every time.
> >
> > gnunetgf[2] inherits from gnunetg[1]
> >
> > 1: https://github.com/ng-0/guix_packages/blob/master/ng0/packages/gnunet.scm#L59
> > 2: https://github.com/ng-0/guix_packages/blob/master/ng0/packages/gnunet.scm#L167
> >
> > and gnunetg inherits from gnunet but overrides most of the package definition.
>
> Hey, this is not Guix code here. :-)

Okay, but it is not guix code which is getting into the way of guix code:
gnunet-fuse is being prepared in the guix repository, not one of my
GUIX_PACKAGE_PATH repositories.

Toggle quote (4 lines)
> I can only give guidance to debug this. For instance, could you check
> with “guix graph” whether the package graph really looks the way you
> want?

No. As you can see in the DAG it makes use of gnunetgt while I specify
really ("gnunet" ,gnunet) in the gnunet-fuse in gnu/packages/gnunet.scm
. This is what is messing with my head. Why?

gnunetgt is the first directory which includes gnunet in its name and is
currently in the /gnu/store that is the only relation I see.


Toggle quote (7 lines)
> Thanks,
> Ludo’.
>
>
>
>

--
ng0
OpenPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
personal: https://ng-0.github.iohttps://krosos.org/
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEqIyK3RKYKNfqwC5S4i+bv+40hYgFAllSakcACgkQ4i+bv+40
hYgTdA//YkUXBuQFMvzE6FbvEXboyu2sU5udTbVeitCOYhFlCs2np2H2e4Vx64CR
cIBp44jEaRktjp9VKKXDeKJ2X7JI2e/iCKrfrNQUDc3TwN0j7AvepHdpm7k04hul
d72pUzU8/P/PYjEvoCv/c4QTgNg7OwXSnQp2AnBUzr+OmH+cwTXOWv1AV/F4IucQ
EH2KzhRf/hTsXTwKeA+L6r6hA1IDibt4YGLJwVBLp+T1X3thrzNN2vP6Lp/qVlcf
k7UpMieAm7FHfLXgqwrGa58UvSUV26Olrbnq5NEQZe1CASB6pff0kXdu+6oW/M+n
gPxYBRsfYUkolfJfpVJO8/FjiX/on3b6XbZqtbwQz0G7uIgW9pcqMlSVIIkl6ckt
og+kIPXNAmak0EFl7t1bapTnKRnflzrqfuMBQss+wMbYbPORSa/E5f0bjCRWkvQ+
QhhduBeeHt6+932N8Nq+7j/2wdvxr+NgF2VG0pNS//0moQY+481WJfyxAKKWAH9x
5ZuBDE6JllDN3qe3iDIpU+caoU9k70j0HjGFbMJDBepXPGjI6J3tGE1jzDQ700zu
+yn+5W8JLUm/cz1OUOiUnKlUrT+Rm3ziE2rcIXftszvfNM2btu+vKqEbUuPtG+hu
OwxowykqPMqcxl8uZTuBdAGX8A7fWnTHs+R4cUal8TXkxTp9g3o=
=pOV/
-----END PGP SIGNATURE-----


N
20170627142701.6j4aa4tfz4efguct@abyayala
Oops! Okay I found the mistake!

I forgot that I have this in my ng0/packages/gnunet.scm:

;; fuse, pointing to the tests disabled version of gnunet-git
(define-public gnunet-fuse
(let* ((commit "c25f3acb22f386f2836cd7c7ae21fcef272c0352")
(revision "2"))
(package
(inherit gnunetg)
(name "gnunet-fuse")
(version (package-version gnunetgf))
[…]

I had it in there for so long that I forgot it exists.
Sorry :)

ng0 transcribed 3.6K bytes:
Toggle quote (69 lines)
> Ludovic Courtès transcribed 1.7K bytes:
> > Hi ng0,
> >
> > ng0 <ng0@infotropique.org> skribis:
> >
> > > Ludovic Courtès transcribed 0.9K bytes:
> > >> Hi ng0,
> > >>
> > >> config.log reads this:
> > >>
> > >> > configure:9394: gcc -c -I/gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include -fno-strict-aliasing -Wall -g -O2 -I/gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include conftest.c >&5
> > >> > In file included from /gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include/gnunet/gnunet_util_lib.h:56:0,
> > >> > from conftest.c:44:
> > >> > /gnu/store/5cbyk5gmw2gj017d02vyibz3v6rdldz7-gnunetgf-0.10.114b59076f/include/gnunet/gnunet_crypto_lib.h:80:20: fatal error: gcrypt.h: No such file or directory
> > >> > compilation terminated.
> > >>
> > >> I think this means that ‘gnunetgf’ should propagate libgcrypt.
> > >>
> > >> I’m closing this bug because I think it’s a packaging issue and not the
> > >> bug suggested in the Subject line.
> > >>
> > >> Thanks,
> > >> Ludo’.
> > >
> > > The thing here is that I am _not_ using gnunetgf for the package in question,
> > > I am using gnunet, from guix master. So from my perspective it is a bug and it
> > > is repeating every time.
> > >
> > > gnunetgf[2] inherits from gnunetg[1]
> > >
> > > 1: https://github.com/ng-0/guix_packages/blob/master/ng0/packages/gnunet.scm#L59
> > > 2: https://github.com/ng-0/guix_packages/blob/master/ng0/packages/gnunet.scm#L167
> > >
> > > and gnunetg inherits from gnunet but overrides most of the package definition.
> >
> > Hey, this is not Guix code here. :-)
>
> Okay, but it is not guix code which is getting into the way of guix code:
> gnunet-fuse is being prepared in the guix repository, not one of my
> GUIX_PACKAGE_PATH repositories.
>
> > I can only give guidance to debug this. For instance, could you check
> > with “guix graph” whether the package graph really looks the way you
> > want?
>
> No. As you can see in the DAG it makes use of gnunetgt while I specify
> really ("gnunet" ,gnunet) in the gnunet-fuse in gnu/packages/gnunet.scm
> . This is what is messing with my head. Why?
>
> gnunetgt is the first directory which includes gnunet in its name and is
> currently in the /gnu/store that is the only relation I see.
>
> https://krosos.org/gnunet-fuse.pdf
>
> > Thanks,
> > Ludo’.
> >
> >
> >
> >
>
> --
> ng0
> OpenPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
> infotropique: https://www.infotropique.org
> personal: https://ng-0.github.io https://krosos.org/



--
ng0
OpenPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
personal: https://ng-0.github.iohttps://krosos.org/
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEqIyK3RKYKNfqwC5S4i+bv+40hYgFAllSazQACgkQ4i+bv+40
hYghgw//YsMA07gIbctraLEwpTStLgXD0h/s9i+fb9wRkrAh7dPT/nms5PCOVJdn
4C4Rbjq20nuNURpB2aYNahVYig0pNNtZVLsTIGP5iaTXb5pk0/o/e79c5z2qVNIT
s9C5fS27z981zcpqB/aFqG7+e8fsmd9QfhvErxH/Z2pSv67LN1RM4ECeaasHyxq2
ztJP4NCTyKb/LenS5i2zwgKk7G89ri614hsln31FZaXr9rBZe7qA9akhpji24zna
wps9aIYGQc2zR005/uDxeQ15xjEMLwdoD2uVaHf5ORiNcHP90uouA9lK6ubI8Tk7
Lm6v/K91ooXV/QPZmnwkjrGAIVd3STR4rStQrqDAe0GrGDNKgZgDytBhoU6qeFjh
BBHR5iXMJDbPr/xNXmCqx7h4KriDFgOeWXKHzSZoGCB5yhIuSd6NXa1k7fAmi3ab
Htx17ymYusFq2qcChDBCEtUrk/E9Ua/z6hYuRsncrzK2R6mCb248J2J7azlgwELQ
ivPN0wG1jRvMvqEExSP1uPce5UBk0Uisz6EyYZPmevxBQcMj1fnJb/fwu3Jcyur2
dPJ9lGD54Da0szHg6RX4QM8ba1myvTeJBOH+H1zcMFekdT0fHABC7kvBrGDYka/K
NWRnXIKBYellzc77HbL16PFQkfE/VSjjARNuvg1UTXsNM05voxQ=
=dABe
-----END PGP SIGNATURE-----


Closed
L
L
Ludovic Courtès wrote on 27 Jun 2017 21:33
(address . 27314-done@debbugs.gnu.org)
87podp445n.fsf@gnu.org
ng0 <ng0@infotropique.org> skribis:

Toggle quote (17 lines)
> Oops! Okay I found the mistake!
>
> I forgot that I have this in my ng0/packages/gnunet.scm:
>
> ;; fuse, pointing to the tests disabled version of gnunet-git
> (define-public gnunet-fuse
> (let* ((commit "c25f3acb22f386f2836cd7c7ae21fcef272c0352")
> (revision "2"))
> (package
> (inherit gnunetg)
> (name "gnunet-fuse")
> (version (package-version gnunetgf))
> […]
>
> I had it in there for so long that I forgot it exists.
> Sorry :)

No problem, glad you found it!

Ludo’.
Closed
?