[PATCH] gnu: rustc: Enable tests.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 17 Jun 2017 20:37
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170617183701.28819-1-dannym@scratchpost.org
* gnu/packages/rust.scm (rustc)[source]: Remove bundled llvm.
[native-inputs]: Add bison, flex, procps.
[inputs]: Update llvm to llvm-3.9.1.
[arguments]: Patch and enable tests.
---
gnu/packages/rust.scm | 35 +++++++++++++++++++++++++++--------
1 file changed, 27 insertions(+), 8 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 1217ec71f..1c03bde2a 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -21,13 +21,16 @@
(define-module (gnu packages rust)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bison)
#:use-module (gnu packages bootstrap)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages elf)
+ #:use-module (gnu packages flex)
#:use-module (gnu packages gcc)
#:use-module (gnu packages jemalloc)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -205,22 +208,27 @@ rustc-bootstrap and cargo-bootstrap packages.")
"rustc-" version "-src.tar.gz"))
(sha256
(base32
- "1d78jq7mc34n265by68amr9r4nzbiqrilfbwh7gx56ydn4gb6rpr"))))
+ "1d78jq7mc34n265by68amr9r4nzbiqrilfbwh7gx56ydn4gb6rpr"))
+ (modules '((guix build utils)))
+ (snippet
+ `(begin
+ (delete-file-recursively "src/llvm")
+ #t))))
(build-system gnu-build-system)
(native-inputs
- `(("cmake" ,cmake)
+ `(("bison" ,bison) ; For the tests
+ ("cmake" ,cmake)
+ ("flex" ,flex) ; For the tests
("git" ,git)
+ ("procps" ,procps) ; For the tests
("python-2" ,python-2)
("rust-bootstrap" ,rust-bootstrap)
("which" ,which)))
(inputs
`(("jemalloc" ,jemalloc)
- ("llvm" ,llvm)))
+ ("llvm" ,llvm-3.9.1)))
(arguments
- ;; FIXME: Test failure with llvm 3.8; Update llvm.
- ;; https://github.com/rust-lang/rust/issues/36835
- `(#:tests? #f
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-configure
(lambda _
@@ -254,7 +262,18 @@ rustc-bootstrap and cargo-bootstrap packages.")
(substitute* "src/tools/tidy/src/main.rs"
(("^.*cargo.*::check.*$") ""))
(substitute* "src/libstd/process.rs"
- (("\"/bin/sh\"") (string-append "\"" bash "/bin/sh\"")))
+ ;; The newline is intentional.
+ ;; There's a line length "tidy" check in Rust which would
+ ;; fail otherwise.
+ (("\"/bin/sh\"") (string-append "
+\"" bash "/bin/sh\"")))
+ (substitute* "src/libstd/sys/unix/process/process_common.rs"
+ (("fn test_process_mask") "#[cfg_attr(target_os = \"linux\", ignore)]
+fn test_process_mask"))
+ (substitute* "src/vendor/libc/src/lib.rs"
+ (("TODO") "TXDO"))
+ ;; Our ld-wrapper cannot process non-UTF8 bytes in LIBRARY_PATH.
+ (delete-file-recursively "src/test/run-make/linker-output-non-utf8")
#t)))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
M
M
Marius Bakke wrote on 18 Jun 2017 18:17
87shixfexf.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (5 lines)
> * gnu/packages/rust.scm (rustc)[source]: Remove bundled llvm.
> [native-inputs]: Add bison, flex, procps.
> [inputs]: Update llvm to llvm-3.9.1.
> [arguments]: Patch and enable tests.

Great!

[...]

Toggle quote (11 lines)
> @@ -254,7 +262,18 @@ rustc-bootstrap and cargo-bootstrap packages.")
> (substitute* "src/tools/tidy/src/main.rs"
> (("^.*cargo.*::check.*$") ""))
> (substitute* "src/libstd/process.rs"
> - (("\"/bin/sh\"") (string-append "\"" bash "/bin/sh\"")))
> + ;; The newline is intentional.
> + ;; There's a line length "tidy" check in Rust which would
> + ;; fail otherwise.
> + (("\"/bin/sh\"") (string-append "
> +\"" bash "/bin/sh\"")))

Can you use '\n' instead?

Toggle quote (4 lines)
> + (substitute* "src/libstd/sys/unix/process/process_common.rs"
> + (("fn test_process_mask") "#[cfg_attr(target_os = \"linux\", ignore)]
> +fn test_process_mask"))

I'm guessing this is disabled due to some build container oddity?

Toggle quote (3 lines)
> + (substitute* "src/vendor/libc/src/lib.rs"
> + (("TODO") "TXDO"))

A comment about this would be nice.

Toggle quote (3 lines)
> + ;; Our ld-wrapper cannot process non-UTF8 bytes in LIBRARY_PATH.
> + (delete-file-recursively "src/test/run-make/linker-output-non-utf8")

This is temporary, right? Maybe add the guix-devel URL?

LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAllGp6wACgkQoqBt8qM6
VPrtkwgAvwXdIqevoyWB0sYqz1+S4ktqcRqgQVuDvlPlQ9BRT6xT1THGfbfVWEKU
7z3EhGxdqnC4y1Yqxj2h3DcDtRE4XezS3bmkDOjzaAMI/2bgSUuOjqAmOYvfcps7
hleeXiOyP+/9+ZPZqFgNhS2f4vl+JyPZEbp7EKl7LaNPs+ix+Jy4nieSNfjrHNxH
NY6SoOqCAaXx/q2RXgEiaKw/4gmdYUSRdBkl5NA9f1o6QJsZWMMHeGnvmFXhS0Vd
659E2o7+cb2v7zwFfUqXol99TBZvWamOkNbLtPjaspKboy3YbED3pTTj+W9FeI7g
yopD2ialqeyaw2T6JaQu0L0F3V0bHA==
=mdPU
-----END PGP SIGNATURE-----

D
D
Danny Milosavljevic wrote on 18 Jun 2017 19:28
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 27412@debbugs.gnu.org)
20170618192834.5181cebe@scratchpost.org
Hi Marius,

On Sun, 18 Jun 2017 18:17:48 +0200
Marius Bakke <mbakke@fastmail.com> wrote:

Toggle quote (5 lines)
> > + (("\"/bin/sh\"") (string-append "
> > +\"" bash "/bin/sh\"")))
>
> Can you use '\n' instead?

No idea. I don't really use '\n' in Guile at all. I'll try it...

Toggle quote (6 lines)
> > + (substitute* "src/libstd/sys/unix/process/process_common.rs"
> > + (("fn test_process_mask") "#[cfg_attr(target_os = \"linux\", ignore)]
> > +fn test_process_mask"))
>
> I'm guessing this is disabled due to some build container oddity?

Yeah. Strangely enough if I manually run the tests in "guix environment -C -N", it works. WTF?


Toggle quote (3 lines)
> > + (substitute* "src/vendor/libc/src/lib.rs"
> > + (("TODO") "TXDO"))

I think this was a false flag and it works without that substitution. I'll try...

Toggle quote (5 lines)
> > + ;; Our ld-wrapper cannot process non-UTF8 bytes in LIBRARY_PATH.
> > + (delete-file-recursively "src/test/run-make/linker-output-non-utf8")

>This is temporary, right?

Not really. I think Guile will continue to convert char* to Unicode UCS-4 (or similar) strings - so I don't see how that's ever going to change. What this Rust test does is it explicitly uses a NON-Unicode character (as in 0xFF) to make sure that that works, too.

I'm not sure what the use case is for that...


Toggle quote (2 lines)
>Maybe add the guix-devel URL?

I'll add links to these archive entries as comments, and try without the "TODO" substitution and if all is well then I'll push to master (building takes ≈ 4 h per round, so no hurry).

Thanks for the review!
D
D
Danny Milosavljevic wrote on 15 Jul 2017 12:44
(no subject)
(address . control@debbugs.gnu.org)
20170715124458.369d8c36@scratchpost.org
close 27459
close 27412
?