[PATCH] gnu: Add mescc-tools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jan Nieuwenhuizen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jan Nieuwenhuizen
Severity
normal
J
J
Jan Nieuwenhuizen wrote on 25 Jun 2017 17:16
(address . guix-patches@gnu.org)
20170625151605.5440-1-janneke@gnu.org
* gnu/packages/mes.scm (mescc-tools): New variable.
---
gnu/packages/mes.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index e711148c7..2cef77406 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -100,3 +100,31 @@ consists of a mutual self-hosting [close to Guile-] Scheme interpreter
prototype in C and a Nyacc-based C compiler in [Guile] Scheme.")
(home-page "https://gitlab.com/janneke/mes")
(license gpl3+))))
+
+(define-public mescc-tools
+ (package
+ (name "mescc-tools")
+ (version "0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/oriansj/MESCC_Tools/archive/Release_"
+ version
+ ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lzi9sqv41269isn7in70q2hhh087n4v97zr5i2qzz69j2lkr3xb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:test-target "test"
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (synopsis "Tools for the full source bootstrapping process")
+ (description
+ "Mescc-tools is a collection of tools for use in a full source
+bootstrapping process. Currently consists of the M0 macro assembler and the
+hex2 linker.")
+ (home-page "https://github.com/oriansj/MESCC_Tools")
+ (license gpl3+)))
--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com | Avatar® http://AvatarAcademy.com
L
L
Ludovic Courtès wrote on 29 Jun 2017 15:02
(name . Jan Nieuwenhuizen)(address . janneke@gnu.org)(address . 27484@debbugs.gnu.org)
87tw2zne0j.fsf@gnu.org
Jan Nieuwenhuizen <janneke@gnu.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/mes.scm (mescc-tools): New variable.

Works for me!

Since it’s x86-only, please add:

(supported-systems '("i686-linux" "x86_64-linux"))

Thanks,
Ludo’.
J
J
Jan Nieuwenhuizen wrote on 29 Jun 2017 18:11
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 27484-done@debbugs.gnu.org)
87podmu63l.fsf@gnu.org
Ludovic Courtès writes:

Toggle quote (10 lines)
> Jan Nieuwenhuizen <janneke@gnu.org> skribis:
>
>> * gnu/packages/mes.scm (mescc-tools): New variable.
>
> Works for me!
>
> Since it’s x86-only, please add:
>
> (supported-systems '("i686-linux" "x86_64-linux"))

Thanks! Pushed to master as: 9ae3fcb9e873172b2accc2ed874eb05828db458d
janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
Closed
?