[PATCH 1/2] gnu: sqlite: Update to 3.20.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Catonano
  • Jelle Licht
Owner
unassigned
Submitted by
Jelle Licht
Severity
normal
J
J
Jelle Licht wrote on 12 Sep 2017 00:17
(address . guix-patches@gnu.org)(name . Jelle Licht)(address . jlicht@fsfe.org)
20170911221745.13947-2-jlicht@fsfe.org
* gnu/packages/databases.scm (sqlite): Update to 3.20.1.
---
gnu/packages/databases.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ba365523d..37890a91f 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -754,7 +754,7 @@ for example from a shell script.")
(define-public sqlite
(package
(name "sqlite")
- (version "3.19.3")
+ (version "3.20.1")
(source (origin
(method url-fetch)
(uri (let ((numeric-version
@@ -770,7 +770,7 @@ for example from a shell script.")
numeric-version ".tar.gz")))
(sha256
(base32
- "00b3l2qglpl1inx21fckiwxnfq5xf6441flc79rqg7zdvh1rq4h6"))))
+ "0hh7jnxfwvs2qlvmjwrgkvxb8sk4x8hj04m54fq9h1xw55dmjrpc"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
(arguments
--
2.14.1
C
C
Catonano wrote on 12 Sep 2017 13:00
(name . Jelle Licht)(address . jlicht@fsfe.org)(address . 28425@debbugs.gnu.org)
CAJ98PDz+gTUhWJs-887w5WPeJpSS+LTa206d51xmyK04YV-zKw@mail.gmail.com
2017-09-12 0:17 GMT+02:00 Jelle Licht <jlicht@fsfe.org>:

Toggle quote (35 lines)
> * gnu/packages/databases.scm (sqlite): Update to 3.20.1.
> ---
> gnu/packages/databases.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> index ba365523d..37890a91f 100644
> --- a/gnu/packages/databases.scm
> +++ b/gnu/packages/databases.scm
> @@ -754,7 +754,7 @@ for example from a shell script.")
> (define-public sqlite
> (package
> (name "sqlite")
> - (version "3.19.3")
> + (version "3.20.1")
> (source (origin
> (method url-fetch)
> (uri (let ((numeric-version
> @@ -770,7 +770,7 @@ for example from a shell script.")
> numeric-version ".tar.gz")))
> (sha256
> (base32
> - "00b3l2qglpl1inx21fckiwxnfq5xf6441flc79rqg7zdvh1rq4h6"))))
> + "0hh7jnxfwvs2qlvmjwrgkvxb8sk4x8hj04m54fq9h1xw55dmjrpc"))))
> (build-system gnu-build-system)
> (inputs `(("readline" ,readline)))
> (arguments
> --
> 2.14.1
>
>
>
>
>

It just built successfully.

Are there any more checsks/tests I should perform in order to properly
review this ?
Attachment: file
J
J
Jelle Licht wrote on 12 Sep 2017 15:24
(name . Catonano)(address . catonano@gmail.com)
874ls89hjh.fsf@fsfe.org
Catonano <catonano@gmail.com> writes:

Toggle quote (42 lines)
> 2017-09-12 0:17 GMT+02:00 Jelle Licht <jlicht@fsfe.org>:
>
>> * gnu/packages/databases.scm (sqlite): Update to 3.20.1.
>> ---
>> gnu/packages/databases.scm | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
>> index ba365523d..37890a91f 100644
>> --- a/gnu/packages/databases.scm
>> +++ b/gnu/packages/databases.scm
>> @@ -754,7 +754,7 @@ for example from a shell script.")
>> (define-public sqlite
>> (package
>> (name "sqlite")
>> - (version "3.19.3")
>> + (version "3.20.1")
>> (source (origin
>> (method url-fetch)
>> (uri (let ((numeric-version
>> @@ -770,7 +770,7 @@ for example from a shell script.")
>> numeric-version ".tar.gz")))
>> (sha256
>> (base32
>> - "00b3l2qglpl1inx21fckiwxnfq5xf6441flc79rqg7zdvh1rq4h6"))))
>> + "0hh7jnxfwvs2qlvmjwrgkvxb8sk4x8hj04m54fq9h1xw55dmjrpc"))))
>> (build-system gnu-build-system)
>> (inputs `(("readline" ,readline)))
>> (arguments
>> --
>> 2.14.1
>>
>>
>>
>>
>>
>
> It just built successfully.
>
> Are there any more checsks/tests I should perform in order to properly
> review this ?

If you have the time, you could try building and using something which
depends on sqlite. I have verified python-apsw (my other patch) to work
properly already, but there are lots of dependents of sqlite which might
inadvertently break because of my patch.
C
C
Catonano wrote on 12 Sep 2017 23:00
(name . Jelle Licht)(address . jlicht@fsfe.org)(address . 28425@debbugs.gnu.org)
CAJ98PDxEEwOQgvPagAPMTBC4o8dya2JevaAUz1h++4uo_vhVOA@mail.gmail.com
2017-09-12 15:24 GMT+02:00 Jelle Licht <jlicht@fsfe.org>:

Toggle quote (53 lines)
>
> Catonano <catonano@gmail.com> writes:
>
> > 2017-09-12 0:17 GMT+02:00 Jelle Licht <jlicht@fsfe.org>:
> >
> >> * gnu/packages/databases.scm (sqlite): Update to 3.20.1.
> >> ---
> >> gnu/packages/databases.scm | 4 ++--
> >> 1 file changed, 2 insertions(+), 2 deletions(-)
> >>
> >> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> >> index ba365523d..37890a91f 100644
> >> --- a/gnu/packages/databases.scm
> >> +++ b/gnu/packages/databases.scm
> >> @@ -754,7 +754,7 @@ for example from a shell script.")
> >> (define-public sqlite
> >> (package
> >> (name "sqlite")
> >> - (version "3.19.3")
> >> + (version "3.20.1")
> >> (source (origin
> >> (method url-fetch)
> >> (uri (let ((numeric-version
> >> @@ -770,7 +770,7 @@ for example from a shell script.")
> >> numeric-version ".tar.gz")))
> >> (sha256
> >> (base32
> >> - "00b3l2qglpl1inx21fckiwxnfq5xf6
> 441flc79rqg7zdvh1rq4h6"))))
> >> + "0hh7jnxfwvs2qlvmjwrgkvxb8sk4x8
> hj04m54fq9h1xw55dmjrpc"))))
> >> (build-system gnu-build-system)
> >> (inputs `(("readline" ,readline)))
> >> (arguments
> >> --
> >> 2.14.1
> >>
> >>
> >>
> >>
> >>
> >
> > It just built successfully.
> >
> > Are there any more checsks/tests I should perform in order to properly
> > review this ?
>
> If you have the time, you could try building and using something which
> depends on sqlite. I have verified python-apsw (my other patch) to work
> properly already, but there are lots of dependents of sqlite which might
> inadvertently break because of my patch.
>

Jelle, I tried but core-updates is too much !

It was bootstrapping Guile 2.2.2 when I stopped it. And that can be a long
process, if I remember correctly

When I first reported to have built it successfully, I had branched from
master and git am'ed your patch there. So many things were available already

This second time I tried with the real core-updates branch

I'm afraid you'll need to set up your own Cuirass instance :-/
Attachment: file
J
J
Jelle Licht wrote on 13 Sep 2017 10:55
control message for bug #28425
(address . control@debbugs.gnu.org)
87shfrx9ig.fsf@fsfe.org
close 28425
?