[PATCH 0/1] gnu: Add GnuCash documentation.

  • Done
  • quality assurance status badge
Details
3 participants
  • Chris Marusich
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Chris Marusich
Severity
normal
C
C
Chris Marusich wrote on 19 Sep 2017 11:10
(address . guix-patches@gnu.org)
20170919091058.31027-1-cmmarusich@gmail.com
Hi,

This patch adds some missing documentation for GnuCash. This is
related to the following email thread:


I decided to put the approximately 100 megabytes of documentation into
the "doc" output, rather than putting it into the regular "out"
output. I also decided not to use a separate package, partly because
I wanted to play around with multiple outputs, and partly because I
think it will make it easier for people to find the documentation.

Chris Marusich (1):
gnu: Add GnuCash documentation.

gnu/packages/gnucash.scm | 54 ++++++++++++++++++++++++++++++++++++++++++++++--
1 file changed, 52 insertions(+), 2 deletions(-)

--
2.14.1
C
C
Chris Marusich wrote on 19 Sep 2017 11:10
[PATCH 1/1] gnu: Add GnuCash documentation.
(address . guix-patches@gnu.org)
20170919091058.31027-2-cmmarusich@gmail.com
* gnu/packages/gnucash.scm (gnucash-docs): Add it.
(gnucash): Use the glib-or-gtk-build-system, create a "doc" output, and
install the output of "gnucash-docs" into there.
---
gnu/packages/gnucash.scm | 54 ++++++++++++++++++++++++++++++++++++++++++++++--
1 file changed, 52 insertions(+), 2 deletions(-)

Toggle diff (105 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index ac2dce576..45f804fa3 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Chris Marusich <cmmarusich@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,8 +24,11 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages docbook)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages glib)
@@ -52,7 +56,7 @@
(base32
"0g2risryfgplxh6cxpsl7fn255vipgsx38b4l081h665nqwmz5nv"))
(patches (search-patches "gnucash-price-quotes-perl.patch"))))
- (build-system gnu-build-system)
+ (build-system glib-or-gtk-build-system)
(inputs
`(("guile" ,guile-2.0)
("icu4c" ,icu4c)
@@ -69,15 +73,25 @@
(native-inputs
`(("glib" ,glib "bin") ; glib-compile-schemas, etc.
("intltool" ,intltool)
+ ("gnucash-docs" ,gnucash-docs)
("pkg-config" ,pkg-config)))
+ (outputs '("out" "doc"))
(arguments
`(#:tests? #f ;FIXME: failing at /qof/gnc-date/qof print date dmy buff
#:configure-flags '("--disable-dbi"
"--enable-aqbanking")
#:phases
(modify-phases %standard-phases
+ ;; There are about 100 megabytes of documentation.
+ (add-after
+ 'install 'install-docs
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((docs (assoc-ref inputs "gnucash-docs"))
+ (doc-output (assoc-ref outputs "doc")))
+ (symlink (string-append docs "/share/gnome")
+ (string-append doc-output "/share/gnome")))))
(add-after
- 'install 'wrap-programs
+ 'install-docs 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
(for-each (lambda (prog)
(wrap-program (string-append (assoc-ref outputs "out")
@@ -114,6 +128,42 @@ import and transaction matching. It also automates several tasks, such as
financial calculations or scheduled transactions.")
(license license:gpl3+)))
+;; This package is not public, since we use it to build the "doc" output of
+;; the gnucash package (see above). It would be confusing if it were public.
+(define gnucash-docs
+ (package
+ (name "gnucash-docs")
+ (version (package-version gnucash))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/gnucash/gnucash-docs/"
+ version "/gnucash-docs-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0dfb4m4084apav9kjsc4mfbj99xsyxm59qhpm1nxvhybn5h6qr3r"))))
+ (build-system gnu-build-system)
+ ;; These are native-inputs because they are only required for building the
+ ;; documentation.
+ (native-inputs
+ `(("libxml2" ,libxml2)
+ ;; The "check" target needs the docbook xml packages for validating the
+ ;; DocBook XML during the tests.
+ ("docbook-xml-4.4" ,docbook-xml-4.4)
+ ("docbook-xml-4.2" ,docbook-xml-4.2)
+ ("docbook-xml-4.1.2" ,docbook-xml-4.1.2)
+ ("libxslt" ,libxslt)
+ ("docbook-xsl" ,docbook-xsl)
+ ("scrollkeeper" ,scrollkeeper)))
+ (home-page "http://www.gnucash.org/")
+ (synopsis "Documentation for GnuCash")
+ (description
+ "User guide and other documentation for GnuCash in various languages.
+This package exists because the GnuCash project maintains its documentation in
+an entirely separate package from the actual GnuCash program. It is intended
+to be read using the GNOME Yelp program.")
+ (license (list license:fdl1.1+ license:gpl3+))))
+
(define-public gwenhywfar
(package
(name "gwenhywfar")
--
2.14.1
L
L
Ludovic Courtès wrote on 19 Sep 2017 14:02
(name . Chris Marusich)(address . cmmarusich@gmail.com)
87shfi522g.fsf@gnu.org
Chris Marusich <cmmarusich@gmail.com> skribis:

Toggle quote (4 lines)
> * gnu/packages/gnucash.scm (gnucash-docs): Add it.
> (gnucash): Use the glib-or-gtk-build-system, create a "doc" output, and
> install the output of "gnucash-docs" into there.

LGTM, thanks for working on it!

Ludo'.
L
L
Ludovic Courtès wrote on 7 Oct 2017 22:48
(name . Chris Marusich)(address . cmmarusich@gmail.com)
87fuauit13.fsf@gnu.org
ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (8 lines)
> Chris Marusich <cmmarusich@gmail.com> skribis:
>
>> * gnu/packages/gnucash.scm (gnucash-docs): Add it.
>> (gnucash): Use the glib-or-gtk-build-system, create a "doc" output, and
>> install the output of "gnucash-docs" into there.
>
> LGTM, thanks for working on it!

Ping! :-)

Ludo'.
C
C
Chris Marusich wrote on 9 Oct 2017 01:43
(name . Ludovic Courtès)(address . ludo@gnu.org)
87bmlhi4td.fsf@gmail.com
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (14 lines)
> ludo@gnu.org (Ludovic Courtès) skribis:
>
>> Chris Marusich <cmmarusich@gmail.com> skribis:
>>
>>> * gnu/packages/gnucash.scm (gnucash-docs): Add it.
>>> (gnucash): Use the glib-or-gtk-build-system, create a "doc" output, and
>>> install the output of "gnucash-docs" into there.
>>
>> LGTM, thanks for working on it!
>
> Ping! :-)
>
> Ludo'.

I'm waiting for someone with commit access to commit this. I don't have
commit access. Would it be faster now and in the future if I just got
commit access? I don't intend to commit anything without first
reviewing it with the list - but I don't mind either way, so please let
me know.

--
Chris
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEy/WXVcvn5+/vGD+x3UCaFdgiRp0FAlnauB8ACgkQ3UCaFdgi
Rp0sRA//YROL0ztmyOlrAjVaV7nYzYUhmcHim8xNYw7Unu6xHuH8QU3e0/udNOXo
BYxCdXtorbvH8OqODN9Iu8yaYOt1QuN777P0CdH2KNiKvvnODUfOfbHVemSDj4Lz
HQQHBJsNsmNga63B1aVPqjj3jwWS0WA1LBnCjRyn3pJXaq867edDpIywQDJCH0Gl
KfAr9ilcTfr6wKJNZk7TaWRZs5GFuLcg/5knbWZ/sAwzCSI5TjzCF5Q2lwoWdfIa
PfmZVD4Qn9h/9lzAuKzhRgOaWh9UVXbc7P15X5gsdKJLOfbaEbHLGYmlZMqRvTh3
zwfy4EyhnYFnogpn3TftvzeM47bu8VRdizguk2ghDXGaiLlol+sNyM5rAnve4mkB
HS2RWty/AfD4LdjyctIO/IXDQYZLrphKNCwTMkPXcxoMj90is+AQKVjW1QOs3q6Y
trGlcLOEz34rXWcBV9ffIiWAo4EF9lFuoOaKKjDjGBM3+6KH0A05FqUWJvbh4P2w
WNqA6a3ty4Dr7tIUg8Imc9ng2NssJQ0J+JFQj7zlzvPwZHWL+b9gUD9lRl6/37/m
RDny6ygZpqJh67vCktn8Ypx8ttnsJi6iiwZb6t4B2LI+x9N2HCPl9XfPm9nDHwrR
aAYV82qL2SPL61T+G05OembK9usx8kv2JAJk2SX1tVVjBol3NNE=
=1PN+
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 9 Oct 2017 09:30
(name . Chris Marusich)(address . cmmarusich@gmail.com)
871smcbwwv.fsf@gnu.org
Hi Chris,

Chris Marusich <cmmarusich@gmail.com> skribis:

Toggle quote (22 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> ludo@gnu.org (Ludovic Courtès) skribis:
>>
>>> Chris Marusich <cmmarusich@gmail.com> skribis:
>>>
>>>> * gnu/packages/gnucash.scm (gnucash-docs): Add it.
>>>> (gnucash): Use the glib-or-gtk-build-system, create a "doc" output, and
>>>> install the output of "gnucash-docs" into there.
>>>
>>> LGTM, thanks for working on it!
>>
>> Ping! :-)
>>
>> Ludo'.
>
> I'm waiting for someone with commit access to commit this. I don't have
> commit access. Would it be faster now and in the future if I just got
> commit access? I don't intend to commit anything without first
> reviewing it with the list - but I don't mind either way, so please let
> me know.

Oops, I was pretty sure you already had commit access, apologies!

So, let’s fix that. Can you create an account on savannah.gnu.org, and
email it here? Please add the OpenPGP key that you’ll use to sign
commits to your account info, and reply with a message signed with that
key.

TIA!

Ludo’.
C
C
Chris Marusich wrote on 12 Oct 2017 05:07
(name . Ludovic Courtès)(address . ludo@gnu.org)
87k201awtg.fsf@gmail.com
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (4 lines)
> Can you create an account on savannah.gnu.org, and email it here?
> Please add the OpenPGP key that you’ll use to sign commits to your
> account info, and reply with a message signed with that key.

I've created an account and uploaded the key. The info is here:

Key fingerprint: CBF5 9755 CBE7 E7EF EF18 3FB1 DD40 9A15 D822 469D

I'll try committing the change once you let me know I've been given
access. Thank you!

--
Chris
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEy/WXVcvn5+/vGD+x3UCaFdgiRp0FAlne3FsACgkQ3UCaFdgi
Rp2klw//Wf5AJ7K21tjBgvJ0uGVxpqW5UJhNExBa4omTij7x1ZkSl7smyU5szJos
EWHQFf3633W0R0w5415SMixPYsuYiDjYbCLV4+MIXsOuSn3fBr/Fi0fUQLPPJWtg
H+PKY0U/QCjH151mKEB3gwHXvKaunQiB98KtF4KX5sq3cPEqeoFaxFbMmDMGK8Qa
KTv9bD94KYRNvb8exj5EAd9rl5eup/OPseqCEXOGLFlqEfTuZ9nGhYqH0r1V89CK
YsAz73Hb/guv1s5WlX8h8KhuDzpqfiYU5DD4ss+jY4iEabggQVNqXvpu4eiHkyGY
HJoj6IbUYwabW7jXZGtSVG43PTGpRN7tWq23Tu+pM0GPgS9lRlTJFvv2VYp9d3m8
lGxPfHGZrbcparxMy503qfuIbq4FZF5kO6EHGlAltIWWLYa0EqJIa1YEuYDMdi6i
jwO9xvDJ/JilksdU7SgYiKspFQJiPp1p9T6ikkYiLqgISNck/WanDIDRhqNtTL2Q
wJfsJ1Nb/ytPM0NtNWsHa7burK+e/XHmnXevZ0zJiKVPRPbfyxhCcNdKSyu5WdK3
QnkAOALepVV82jytEGK8PjVFkJbk2qK4LQLu3XyCloBkc6TL4u8xV8aa35M0vWC0
dF/XjZkegvluZK9vno79SE9BAla4PG95flf5VPRHFsyP2BiXG3M=
=8QRC
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 12 Oct 2017 10:00
(name . Chris Marusich)(address . cmmarusich@gmail.com)
87po9sre1s.fsf@gnu.org
Hi Chris,

Chris Marusich <cmmarusich@gmail.com> skribis:

Toggle quote (14 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Can you create an account on savannah.gnu.org, and email it here?
>> Please add the OpenPGP key that you’ll use to sign commits to your
>> account info, and reply with a message signed with that key.
>
> I've created an account and uploaded the key. The info is here:
>
> Profile: https://savannah.gnu.org/users/marusich
> Key fingerprint: CBF5 9755 CBE7 E7EF EF18 3FB1 DD40 9A15 D822 469D
>
> I'll try committing the change once you let me know I've been given
> access. Thank you!

I’ve added you so you should be able to commit now.

Please (re)read ‘HACKING’ for rules and tips regarding commit access.

Welcome again! :-)

Ludo’.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEPORkVYqE/cadtAz7CQsRmT2a67UFAlnfIR8ACgkQCQsRmT2a
67V1Pw/9Exek4lSQuZB2eD5m6d5EvhrV+eS2lqtzzroLxTPW7/oWy1eRj5OH+Yz9
2nrhPNE807Q5J/tHyZW4uy735jcvs56nUbyK8T7SiHmCCumOpR8OiHTjE5cLt6Yd
XX9cqVJ1lSVdMJEHYtVvEeyCA9I+7cvqqERbdw6+LJdnuyPcvTIhKbvdnKqbgekH
t1gYhRhQWRTGLjfrVaQGOmKzxQJJ2an7smrX0+9cr06F9w6pnBMUHBKSJ6f9eWJ0
wTnfrVSjWpkfjGWZ8daOPHx+KZT4ei2gyt/+03rgcqc7N7W5C26phX2GiJaidxAU
bO0Pi5JmMJX4jsSVhgECF+2F0bkwflWlOSaWVcZaDnT0ikrgDsQEotiUSY6XeKFM
mgl3Jo3LHB/YB/DHn1ueyck3EMesFT9941Kfq1+mCoJbu+nwea8BzqLzUKOpJ9Lx
cV7fEiGIvvm9blaW6biJZirak6jj8+vD4ULKkZ3OA1l15HVETKW0tmhGZKRF8WMO
/xBTNgtg5OO6Lqdemtliw057j1Rugu3ICprFkeXMHtRhtJh97kKqFHAMnTUjx4rD
w4Y+4+GEv9UwfeCIW1hQHOt1vVKEtoncOSo48df36zEfWxTwWbHlhbQuPJfuLje5
IJXLQHR7/QfJSgM6/GQ3o5ZjVAgef1bs3aFSFU5j8SExplEJXe4=
=trWR
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 13 Oct 2017 21:47
(name . Chris Marusich)(address . cmmarusich@gmail.com)(address . 28509-done@debbugs.gnu.org)
20171013204718.05b53f3a@cbaines.net
On Wed, 11 Oct 2017 20:07:07 -0700
Chris Marusich <cmmarusich@gmail.com> wrote:

Toggle quote (14 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
> > Can you create an account on savannah.gnu.org, and email it here?
> > Please add the OpenPGP key that you’ll use to sign commits to your
> > account info, and reply with a message signed with that key.
>
> I've created an account and uploaded the key. The info is here:
>
> Profile: https://savannah.gnu.org/users/marusich
> Key fingerprint: CBF5 9755 CBE7 E7EF EF18 3FB1 DD40 9A15 D822 469D
>
> I'll try committing the change once you let me know I've been given
> access. Thank you!

Looks to me like you've been successful :D So I'm going to close this
bug (by emailing 28509-done@debbugs.gnu.org).
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlnhGEZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfVNg/7BjtHr8Qq8S2vXwckDiMl8J40phg0Qp3zs7HhSG1FuISTVTnqNss/cDkS
AOaYyXkl2sqmrZ4gA2/mglU1F6gFau4IhhEMRqW0nlmbLM0davLWyIUAM2DYya6E
H2T4g+4A5FOrR3IqBDU5D1bLkE+NNwFF9pLmjtrH4k+LfLYAUQ9EYXiIFAWvbZJ/
4C2uJS4xKNt3QyecNIk6CLMd3l01kV4CxOFc1BoD8HVdIB124lgJENxfJB1QaV1+
t4Y3P2P0lpf7GSyM0fgbFQRSV6hEm6PS8+LXmYLPI0y9fbyhz+vAqnMINAe7lV2J
4LnAl3SVrdl9quO9nPsdFFgWHmpG7A3Yf3IyoWQxdozw0yUAxrojEpw3fY10TUaP
8M3iwLs1q19lFqe+bmQyrSn+BaCTUnNWPRxbFo1p6o5q7nUxmg1qxN5CsNcVnOZs
C6Nfzu2qauuH+tIvlSwOswkf9aDRhOpJeyXybr84FBAfZHMAijDnaOJ3zZHddInB
0qGvsXt7TQ+Fq6hejCg9Cy7WEjxuryGfNqLnBNSc6Rc2TFRzIdm+OcwRn1Qd2e19
GN/2lGUQvLFLrsaqAc2ehNsoSK/MdosZ0sLGXIA5qPt7WsQ8gvKOldxeVYLx6tz/
q+M5pJlgXvS0wFVhzuTd2JzcvQdfyl2YSdeVqSYdCHjIaJ8pipw=
=sb8W
-----END PGP SIGNATURE-----


Closed
?