guix system vm Failed to install GRUB (EFI)

  • Done
  • quality assurance status badge
Details
3 participants
  • Oleg Pykhalov
  • Ludovic Courtès
  • Marius Bakke
Owner
unassigned
Submitted by
Oleg Pykhalov
Severity
normal
O
O
Oleg Pykhalov wrote on 9 Oct 2017 21:50
(address . bug-guix@gnu.org)
87info3xtj.fsf@gmail.com
Hello Guix,

EFI bootloader configuration causes problems to test with 'system vm'
before 'reconfigure'.

To reproduce it replace default bootloader expression with following
snippet in gnu/system/examples/vm-image.tmpl

(bootloader (bootloader-configuration
(bootloader grub-efi-bootloader)
(target "/boot/efi")))

Toggle snippet (19 lines)
[ 0.909226] EXT4-fs (vda1): mounted filesystem with ordered data mode. Opts: (null)
installing bootloader...
/gnu/store/b1kdjsmwkphwh06gcm2ym0d0zh5wf4gc-grub-efi-2.02/sbin/grub-install: error: /gnu/store/b1kdjsmwkphwh06gcm2ym0d0zh5wf4gc-grub-efi-2.02/lib/grub/i386-pc/modinfo.sh doesn't exist. Please specify --target or --directory.
ERROR: In procedure scm-error:
ERROR: failed to install GRUB (EFI)

Entering a new prompt. Type `,bt' for a backtrace or `,q' to continue.
GNU Guile 2.2.2
Copyright (C) 1995-2017 Free Software Foundation, Inc.

Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
This program is free software, and you are welcome to redistribute it
under certain conditions; type `,show c' for details.

Enter `,help' for help.
scheme@(guile-user)> [ 1.344109] tsc: Refined TSC clocksource calibration: 3392.250 MHz
[ 1.344677] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x30e5b54dbe0, max_idle_ns: 440795272496 ns
C-c C-c
M
M
Marius Bakke wrote on 10 Oct 2017 21:08
87efqa95x4.fsf@fastmail.com
Oleg Pykhalov <go.wigust@gmail.com> writes:

Toggle quote (3 lines)
> EFI bootloader configuration causes problems to test with 'system vm'
> before 'reconfigure'.

This is because `guix system vm` is not currently UEFI enabled, so GRUB
tries to install for a normal PC BIOS.

The fix would be to make the various QEMU invocations in (gnu system vm)
take a #:firmware parameter that passes something along the lines of
'-bios #$(file-append ovmf "/share/ovmf/firmware/ovmf_x64.bin")' to the
QEMU command-line, and update other scripts to take advantage.

It's on my ever-growing TODO list and would be nice to have indeed.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlndGsgACgkQoqBt8qM6
VPoLYAf/TwYGG3q6BS7NpSRyp5NVbHNPeHSbwP8QSLxYYuFK4ZkdIsdJnEuPtKPP
SmUX9jehYe5s0a0HB0yQFsX7gZPTP8SBoSOR7kbQfvFQtlbapzHRFIwvIl8392g4
Dq2MA/VLnNXzjQ6/HP2koP6NTcQJrIo53f4nO0+dJyN0QjPE3x7Q7mv6E5b4HSgh
sK4SqBCHNqfmAB2/Tn2eGSwjpV/QZMPOryiXQjk2X4F/cYWnCMFrkzXIBTtLHLOA
8jNbYBSV4z/W1IzIbB29woBkBAhWkKUQYWArBLXu2Yudo7qiFRZWP9u0HMynOXky
dC/epqiRw0UoMb8AlU+TIox9QvFWbw==
=Ca+V
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 12 Oct 2017 10:46
(name . Marius Bakke)(address . mbakke@fastmail.com)
877ew0rbxc.fsf@gnu.org
Marius Bakke <mbakke@fastmail.com> skribis:

Toggle quote (13 lines)
> Oleg Pykhalov <go.wigust@gmail.com> writes:
>
>> EFI bootloader configuration causes problems to test with 'system vm'
>> before 'reconfigure'.
>
> This is because `guix system vm` is not currently UEFI enabled, so GRUB
> tries to install for a normal PC BIOS.
>
> The fix would be to make the various QEMU invocations in (gnu system vm)
> take a #:firmware parameter that passes something along the lines of
> '-bios #$(file-append ovmf "/share/ovmf/firmware/ovmf_x64.bin")' to the
> QEMU command-line, and update other scripts to take advantage.

Perhaps by adding it to <virtual-machine> records we’d make it less
annoying to pass around? Or are there other places that would still
need extra care?

Another option, in the meantime is this:
Toggle diff (19 lines)
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index 273a895be..f763b430b 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -565,6 +565,14 @@ environment with the store shared with the host. MAPPINGS is a list of
user-file-systems)))
(operating-system (inherit os)
+
+ ;; XXX: Until we run QEMU with UEFI support (with the OVMF firmware),
+ ;; force the traditional i386/BIOS method.
+ ;; See <https://bugs.gnu.org/28768>.
+ (bootloader (bootloader-configuration
+ (bootloader grub-bootloader)
+ (target "/dev/vda")))
+
(initrd (lambda (file-systems . rest)
(apply base-initrd file-systems
#:volatile-root? #t
That’s what I do manually anyway.

WDYT? If that’s fine with you, I can commit it.

Thanks,
Ludo’.
M
M
Marius Bakke wrote on 19 Oct 2017 20:21
(name . Ludovic Courtès)(address . ludo@gnu.org)
87infb577p.fsf@fastmail.com
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (19 lines)
> Marius Bakke <mbakke@fastmail.com> skribis:
>
>> Oleg Pykhalov <go.wigust@gmail.com> writes:
>>
>>> EFI bootloader configuration causes problems to test with 'system vm'
>>> before 'reconfigure'.
>>
>> This is because `guix system vm` is not currently UEFI enabled, so GRUB
>> tries to install for a normal PC BIOS.
>>
>> The fix would be to make the various QEMU invocations in (gnu system vm)
>> take a #:firmware parameter that passes something along the lines of
>> '-bios #$(file-append ovmf "/share/ovmf/firmware/ovmf_x64.bin")' to the
>> QEMU command-line, and update other scripts to take advantage.
>
> Perhaps by adding it to <virtual-machine> records we’d make it less
> annoying to pass around? Or are there other places that would still
> need extra care?

Sorry for late response, still going through a backlog! I think
<virtual-machine> should be sufficient, did not do a lot of research.

Toggle quote (26 lines)
> Another option, in the meantime is this:
>
> diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
> index 273a895be..f763b430b 100644
> --- a/gnu/system/vm.scm
> +++ b/gnu/system/vm.scm
> @@ -565,6 +565,14 @@ environment with the store shared with the host. MAPPINGS is a list of
> user-file-systems)))
>
> (operating-system (inherit os)
> +
> + ;; XXX: Until we run QEMU with UEFI support (with the OVMF firmware),
> + ;; force the traditional i386/BIOS method.
> + ;; See <https://bugs.gnu.org/28768>.
> + (bootloader (bootloader-configuration
> + (bootloader grub-bootloader)
> + (target "/dev/vda")))
> +
> (initrd (lambda (file-systems . rest)
> (apply base-initrd file-systems
> #:volatile-root? #t
>
> That’s what I do manually anyway.
>
> WDYT? If that’s fine with you, I can commit it.

LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlno7TsACgkQoqBt8qM6
VPr9ogf/YfnSnQDGPp05BWXtBeXzSOhYeROgYabI1yqjbrPY9FJIhFHGXL+e4eof
AUXe+Wfg2XsI1QXkcG1KJ8H5VviF1Ubuftw2DSIY7l40Kaerj+U9I/6M0ZA6SUa/
JEI4nP7VUWeIu3HPf5g2xPgZmgG5KcFcBs9Kj1Nuwe+Yz7QRcW7xTTrzSwsGW6lm
I3KwZ1cT/lBr1EEYWnq3CyCnPzY+TKlkrTYwcK3zWuyllLP6Dgtw5m/UzZXCiicU
prj3424ZaPGA5le2JqQU6T79eezoy6K6PtZBCMRQzq8+d5oMMlARt0g/REBm3s41
74cmORod1EOeCr7k/UlHEcwjEqypPw==
=/ktA
-----END PGP SIGNATURE-----

O
O
Oleg Pykhalov wrote on 19 Oct 2017 22:32
(name . Ludovic Courtès)(address . ludo@gnu.org)
87y3o6yj2f.fsf@gmail.com
Hello Ludovic,

Apologies for the late reply.

ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (49 lines)
> Marius Bakke <mbakke@fastmail.com> skribis:
>
>> Oleg Pykhalov <go.wigust@gmail.com> writes:
>>
>>> EFI bootloader configuration causes problems to test with 'system vm'
>>> before 'reconfigure'.
>>
>> This is because `guix system vm` is not currently UEFI enabled, so GRUB
>> tries to install for a normal PC BIOS.
>>
>> The fix would be to make the various QEMU invocations in (gnu system vm)
>> take a #:firmware parameter that passes something along the lines of
>> '-bios #$(file-append ovmf "/share/ovmf/firmware/ovmf_x64.bin")' to the
>> QEMU command-line, and update other scripts to take advantage.
>
> Perhaps by adding it to <virtual-machine> records we’d make it less
> annoying to pass around? Or are there other places that would still
> need extra care?
>
> Another option, in the meantime is this:
>
> diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
> index 273a895be..f763b430b 100644
> --- a/gnu/system/vm.scm
> +++ b/gnu/system/vm.scm
> @@ -565,6 +565,14 @@ environment with the store shared with the host. MAPPINGS is a list of
> user-file-systems)))
>
> (operating-system (inherit os)
> +
> + ;; XXX: Until we run QEMU with UEFI support (with the OVMF firmware),
> + ;; force the traditional i386/BIOS method.
> + ;; See <https://bugs.gnu.org/28768>.
> + (bootloader (bootloader-configuration
> + (bootloader grub-bootloader)
> + (target "/dev/vda")))
> +
> (initrd (lambda (file-systems . rest)
> (apply base-initrd file-systems
> #:volatile-root? #t
>
>
> That’s what I do manually anyway.
>
> WDYT? If that’s fine with you, I can commit it.
>
> Thanks,
> Ludo’.

Tiny improvement:

Toggle snippet (24 lines)
natsu@magnolia ~/src/guix$ pre-guix system vm ~/dotfiles/guix/system-magnolia.scm
Backtrace:
10 (primitive-load "/home/natsu/src/guix/scripts/guix")
In guix/ui.scm:
1384:12 9 (run-guix-command _ . _)
In ice-9/boot-9.scm:
837:9 8 (catch _ _ #<procedure 7f3d47deeac0 at guix/ui.scm:460:2 (key c)> _)
837:9 7 (catch _ _ #<procedure 7f3d47deead8 at guix/ui.scm:548:6 (key proc…> …)
In guix/scripts/system.scm:
1099:8 6 (_)
974:6 5 (process-action _ _ _)
In guix/store.scm:
1444:24 4 (run-with-store _ _ #:guile-for-build _ #:system _ #:target _)
In guix/scripts/system.scm:
987:13 3 (_ _)
706:18 2 (perform-action vm #<<operating-system> kernel: #<package linux-li…> …)
In gnu/system/vm.scm:
671:31 1 (system-qemu-image/shared-store-script #<<operating-system> kernel…> …)
559:4 0 (virtualized-operating-system #<<operating-system> kernel: #<packa…> …)

gnu/system/vm.scm:559:4: In procedure virtualized-operating-system:
gnu/system/vm.scm:559:4: In procedure module-lookup: Unbound variable: grub-bootloader

Toggle diff (25 lines)
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index f763b430b..7feb242d5 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -49,7 +49,8 @@
#:use-module (gnu packages admin)
#:use-module (gnu bootloader)
- #:use-module ((gnu bootloader grub) #:select (grub-mkrescue-bootloader))
+ #:use-module ((gnu bootloader grub) #:select (grub-mkrescue-bootloader
+ grub-bootloader))
#:use-module (gnu system shadow)
#:use-module (gnu system pam)
#:use-module (gnu system linux-initrd)


But I got another issue, not related to Grub.

Loops in QEMU:

waiting for partition 'magnolia-data' to appear
failed to start service 'file-systems'
L
L
Ludovic Courtès wrote on 19 Oct 2017 23:25
(name . Marius Bakke)(address . mbakke@fastmail.com)
87a80mj0eq.fsf@gnu.org
Hello!

Marius Bakke <mbakke@fastmail.com> skribis:

Toggle quote (2 lines)
> Ludovic Courtès <ludo@gnu.org> writes:

[...]

Toggle quote (28 lines)
>> Another option, in the meantime is this:
>>
>> diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
>> index 273a895be..f763b430b 100644
>> --- a/gnu/system/vm.scm
>> +++ b/gnu/system/vm.scm
>> @@ -565,6 +565,14 @@ environment with the store shared with the host. MAPPINGS is a list of
>> user-file-systems)))
>>
>> (operating-system (inherit os)
>> +
>> + ;; XXX: Until we run QEMU with UEFI support (with the OVMF firmware),
>> + ;; force the traditional i386/BIOS method.
>> + ;; See <https://bugs.gnu.org/28768>.
>> + (bootloader (bootloader-configuration
>> + (bootloader grub-bootloader)
>> + (target "/dev/vda")))
>> +
>> (initrd (lambda (file-systems . rest)
>> (apply base-initrd file-systems
>> #:volatile-root? #t
>>
>> That’s what I do manually anyway.
>>
>> WDYT? If that’s fine with you, I can commit it.
>
> LGTM!

Pushed as 9b396c0cabb086746cbe4ec20d4ae0d79962d758 (along with the
missing #:use-module clause that Oleg reported.)

I’m closing this bug. We can create a new issue when we add support for
UEFI in VMs.

Oleg Pykhalov <go.wigust@gmail.com> skribis:

Toggle quote (10 lines)
> But I got another issue, not related to Grub.
>
> Loops in QEMU:
>
> …
> waiting for partition 'magnolia-data' to appear
> …
> failed to start service 'file-systems'
> …

This is expected: there’s no partition with that label in the VM.

You have to comment out the ‘file-system’ declaration because it doesn’t
make sense inside the VM. Perhaps ‘virtualized-operating-system’ could
do it automatically as well, not sure.

HTH,
Ludo’.
Closed
?