[PATCH] gnu: uboot: Fix same-arch? check.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
M
M
Mathieu Othacehe wrote on 5 Nov 2017 12:06
(address . guix-patches@gnu.org)(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
20171105110613.11790-1-m.othacehe@gmail.com
* gnu/packages/bootloaders.scm (make-u-boot-package): Compare %current-system
to system associated to given triplet. Comparing a system and a triplet
didn't make sense.
---
gnu/packages/bootloaders.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index be3ea18fb..179e101fd 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -333,7 +333,8 @@ also initializes the boards (RAM etc).")
(define (make-u-boot-package board triplet)
"Returns a u-boot package for BOARD cross-compiled for TRIPLET."
- (let ((same-arch? (if (string-prefix? (%current-system) triplet)
+ (let ((same-arch? (if (string-prefix? (%current-system)
+ (gnu-triplet->nix-system triplet))
`#t
`#f)))
(package
--
2.15.0
D
D
Danny Milosavljevic wrote on 5 Nov 2017 16:38
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(address . 29152@debbugs.gnu.org)
20171105163810.6f13e59b@scratchpost.org
Good catch! LGTM!
M
M
Mathieu Othacehe wrote on 6 Nov 2017 19:54
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 29152@debbugs.gnu.org)
87r2tbme4z.fsf@gmail.com
Toggle quote (2 lines)
> Good catch! LGTM!

Thanks Danny, pushed as 2ac42fe51fcbd9b9f36fcfce350da2d483dc0cc9.
M
M
Mathieu Othacehe wrote on 6 Nov 2017 20:04
control message for bug #29152
(address . control@debbugs.gnu.org)
87lgjjmdo1.fsf@gmail.com
tags 29152 fixed
close 29152
?