guix pull throws exception: wrong type argument in struct_vtable

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Marco van Hulten
Owner
unassigned
Submitted by
Marco van Hulten
Severity
normal
M
M
Marco van Hulten wrote on 12 Nov 2017 15:23
(address . bug-guix@gnu.org)
20171112152324.325b195c@graviton.instanton
I am trying to upgrade GuixSD, originally installed from the 0.13.0
amd64 USB image. However, the `guix pull' command exits badly.

```
root@watson ~# guix package -u
substitute: updating list of substitutes from 'https://mirror.hydra.gnu.org'... 100.0%
substitute: updating list of substitutes from 'https://mirror.hydra.gnu.org'... 100.0%
The following package will be upgraded:
guile-git 0.0-4.951a32c → 0.0-4.951a32c /gnu/store/cjg6sngjq540k38s5l3nfxpydybhpas0-guile-git-0.0-4.951a32c

nothing to be done
root@watson ~# guix pull
Updating from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Backtrace:
10 (primitive-load "/gnu/store/qzw8q4mbk5dymmkffi6k13jphzm…")
In guix/ui.scm:
1378:12 9 (run-guix-command _ . _)
In ice-9/boot-9.scm:
837:9 8 (catch _ _ #<procedure 7f1fa9b05b60 at guix/ui.scm:449…> …)
837:9 7 (catch _ _ #<procedure 7f1fa9b05b78 at guix/ui.scm:542…> …)
837:9 6 (catch _ _ #<procedure 7f1fa6819bc8 at guix/scripts/pu…> …)
In guix/scripts/pull.scm:
272:27 5 (_)
In guix/git.scm:
115:29 4 (latest-repository-commit #<build-daemon 256.97 33dcf50> …)
In ice-9/boot-9.scm:
849:4 3 (with-throw-handler _ _ _)
In git/clone.scm:
44:14 2 (_ _ _ _)
In git/structs.scm:
398:26 1 (clone-options->pointer #<pointer 0x0>)
In ice-9/boot-9.scm:
760:25 0 (dispatch-exception _ _ _)

ice-9/boot-9.scm:760:25: In procedure dispatch-exception:
ice-9/boot-9.scm:760:25: In procedure struct_vtable: Wrong type argument in position 1 (expecting struct): #<pointer 0x0>
```

-Marco
M
L
L
Ludovic Courtès wrote on 12 Nov 2017 21:24
Re: bug#29274: guix pull throws exception: wrong type argument in struct_vtable
(name . Marco van Hulten)(address . marco@hulten.org)(address . 29274@debbugs.gnu.org)
87zi7rckk3.fsf@gnu.org
Hi Marco,

Marco van Hulten <marco@hulten.org> skribis:

Toggle quote (9 lines)
> In guix/git.scm:
> 115:29 4 (latest-repository-commit #<build-daemon 256.97 33dcf50> …)
> In ice-9/boot-9.scm:
> 849:4 3 (with-throw-handler _ _ _)
> In git/clone.scm:
> 44:14 2 (_ _ _ _)
> In git/structs.scm:
> 398:26 1 (clone-options->pointer #<pointer 0x0>)

This has been fixed recently: https://bugs.gnu.org/29238. You’ll get
the fix on your next ‘git pull’.

In the meantime, there are 2 possible workarounds:

1. mkdir -p ~/.cache/guix/pull
cd ~/.cache/guix/pull
pjmkglp4t7znuugeurpurzikxq3tnlaywmisyr27shj7apsnalwq

2. mv ~/.config/guix/latest{,.bak} && guix pull

Let me know how it goes.

Ludo’.
M
M
Marco van Hulten wrote on 14 Nov 2017 09:05
(address . 29274@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
20171114090527.02b03283@jasniac.instanton
Ludo'-

Op 12 nov 21:24 schreef Ludovic Courtès:
Toggle quote (25 lines)
> Marco van Hulten <marco@hulten.org> skribis:
>
> > In guix/git.scm:
> > 115:29 4 (latest-repository-commit #<build-daemon 256.97 33dcf50> …)
> > In ice-9/boot-9.scm:
> > 849:4 3 (with-throw-handler _ _ _)
> > In git/clone.scm:
> > 44:14 2 (_ _ _ _)
> > In git/structs.scm:
> > 398:26 1 (clone-options->pointer #<pointer 0x0>)
>
> This has been fixed recently: <https://bugs.gnu.org/29238>. You’ll get
> the fix on your next ‘git pull’.
>
> In the meantime, there are 2 possible workarounds:
>
> 1. mkdir -p ~/.cache/guix/pull
> cd ~/.cache/guix/pull
> git clone https://git.savannah.gnu.org/git/guix.git \
> pjmkglp4t7znuugeurpurzikxq3tnlaywmisyr27shj7apsnalwq
>
> 2. mv ~/.config/guix/latest{,.bak} && guix pull
>
> Let me know how it goes.

The problem is solved after applying workaround 1.

Just now I started another `git pull' and there are again no syntax
errors (compiling...).

-Marco
M
M
Marco van Hulten wrote on 14 Nov 2017 09:05
(no subject)
(address . control@debbugs.gnu.org)
20171112152550.2e4dc83f@graviton.instanton
close 29274
L
L
Ludovic Courtès wrote on 14 Nov 2017 15:41
Re: bug#29274: guix pull throws exception: wrong type argument in struct_vtable
(name . Marco van Hulten)(address . marco@hulten.org)(address . 29274-done@debbugs.gnu.org)
878tf8exch.fsf@gnu.org
Hello,

Marco van Hulten <marco@hulten.org> skribis:

Toggle quote (28 lines)
> Op 12 nov 21:24 schreef Ludovic Courtès:
>> Marco van Hulten <marco@hulten.org> skribis:
>>
>> > In guix/git.scm:
>> > 115:29 4 (latest-repository-commit #<build-daemon 256.97 33dcf50> …)
>> > In ice-9/boot-9.scm:
>> > 849:4 3 (with-throw-handler _ _ _)
>> > In git/clone.scm:
>> > 44:14 2 (_ _ _ _)
>> > In git/structs.scm:
>> > 398:26 1 (clone-options->pointer #<pointer 0x0>)
>>
>> This has been fixed recently: <https://bugs.gnu.org/29238>. You’ll get
>> the fix on your next ‘git pull’.
>>
>> In the meantime, there are 2 possible workarounds:
>>
>> 1. mkdir -p ~/.cache/guix/pull
>> cd ~/.cache/guix/pull
>> git clone https://git.savannah.gnu.org/git/guix.git \
>> pjmkglp4t7znuugeurpurzikxq3tnlaywmisyr27shj7apsnalwq
>>
>> 2. mv ~/.config/guix/latest{,.bak} && guix pull
>>
>> Let me know how it goes.
>
> The problem is solved after applying workaround 1.

Good, thanks!

Ludo’.
Closed
?