network-manager-vpnc

  • Done
  • quality assurance status badge
Details
6 participants
  • Jelle Licht
  • Ludovic Courtès
  • Christopher Baines
  • Maxim Cournoyer
  • ng0
  • ng0
Owner
unassigned
Submitted by
ng0
Severity
normal
N
(address . guix-patches@gnu.org)
20171115104514.uxmsrft73kxhepgt@abyayala
This adds the vpnc plugin for NetworkManager.

I should add a note why the substitute happens
and why the tests are enabled.
Anything I've missed in this first crude patch,
let me know. This is just to provide a base to
help people reproduce the the current NM problem.
--
GnuPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
From 0cf7c178f8453ffa0984d1f6e18efb61cf55d0d2 Mon Sep 17 00:00:00 2001
From: ng0 <ng0@infotropique.org>
Date: Wed, 15 Nov 2017 10:40:46 +0000
Subject: [PATCH] gnu: Add network-manager-vpnc.

* gnu/packages/gnome.scm (network-manager-vpnc): New variable.
---
gnu/packages/gnome.scm | 45 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index abe430570..996f0f43b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5103,6 +5103,51 @@ to virtual private networks (VPNs) via OpenVPN.")
(license license:gpl2+)
(properties `((upstream-name . "NetworkManager-openvpn")))))
+(define-public network-manager-vpnc
+ (package
+ (name "network-manager-vpnc")
+ (version "1.2.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnome/sources/NetworkManager-vpnc/"
+ (version-major+minor version)
+ "/NetworkManager-vpnc-" version ".tar.xz"))
+ (sha256
+ (base32
+ "01gv205p51fsz2pfpch81ax0xm8gwj6646acag5hh0p931j53irr"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;test-import-export is failing
+ #:configure-flags '("--enable-absolute-paths")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-Makefile
+ (lambda _
+ (substitute* "nm-vpnc-service.conf"
+ (("own_prefix")
+ "own")))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("libtool" ,libtool)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("vpnc" ,vpnc)
+ ("network-manager" ,network-manager)
+ ("network-manager-applet" ,network-manager-applet) ;for libnma
+ ("libsecret" ,libsecret)))
+ (home-page "https://wiki.gnome.org/Projects/NetworkManager/VPN")
+ (synopsis "VPNC plug-in for NetworkManager")
+ (description
+ "This extension of NetworkManager allows it to take care of connections
+to virtual private networks (VPNs) via VPNC.")
+ (license license:gpl2+)
+ (properties `((upstream-name . "NetworkManager-vpnc")))))
+
(define-public mobile-broadband-provider-info
(package
(name "mobile-broadband-provider-info")
--
2.15.0
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEqIyK3RKYKNfqwC5S4i+bv+40hYgFAloMGroACgkQ4i+bv+40
hYh77Q//eL+ZjMtcgYQr4antB4zAK6x4O33njQ7RoXUMIhNDEZtIAPsItqAsgjCl
bLaLYGJvaMmDJBoaMH9Hc/l67q1Vvpn9/RWYmbNKXXeJFIRKDXiVoayMYHV0D9KE
jL7B4mPOfVXRsPiWNemrtSxT6JH1jMj5gU1FFx6QZbb/bDVQoKa1wUROfNfnhbs4
MPk0asmCe9BvfcM/3epr9sBrK/TOTrP9Jd8JXMOxVnHEFR8QsiqUSQPoCynx4Qqf
xYalVAefnYUg6Cqz8qmSQzhpuApa8/bi3wsqc+Ek1Ba3kNCmE0Z6D72U5GnFskAG
kIxg7zwSFJ3Oo7MkePYRRWoyOat/NA3yoZO2PsXuks1eEsL5cmw0QGMZ2Ba0KO/h
gwYFnS3ZJeZ6Qs6vH8jmFrZ1nX526krkZtKgVbt613kj6s6aVkYaqdHiOVkmaRCV
mMqJh9cc0+UE4yV/lNr5X6kxkKSKwamBuEZgu4Y2lR6M/3R/+pKRldQWbZgbCEEL
axrclaNT/6WrUOUGdr/TIe4Brj2lMuKIPV2R6h3I9USwuWl5OwE1g+1fQj0whjdQ
qJY02U2wT3U3tegOQocNNhAnW0df5yepAbrPNSMvoqoZ8RzxbziMP+MroaqGeH/4
hehfIfhfZZMsSmhFjo5FsXRMOmH9Nn5Cv39+LvVR7egtRkYfJLs=
=AcEe
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 16 Nov 2017 10:25
(name . ng0)(address . ng0@infotropique.org)(address . 29306@debbugs.gnu.org)
8760aak22g.fsf@gnu.org
Heya ng0,

ng0 <ng0@infotropique.org> skribis:

Toggle quote (7 lines)
> From 0cf7c178f8453ffa0984d1f6e18efb61cf55d0d2 Mon Sep 17 00:00:00 2001
> From: ng0 <ng0@infotropique.org>
> Date: Wed, 15 Nov 2017 10:40:46 +0000
> Subject: [PATCH] gnu: Add network-manager-vpnc.
>
> * gnu/packages/gnome.scm (network-manager-vpnc): New variable.

I don’t think this patch is crude. :-)

Minor issues:

Toggle quote (3 lines)
> + (arguments
> + '(#:tests? #f ;test-import-export is failing

Do you think you could investigate a bit?

Toggle quote (7 lines)
> + (modify-phases %standard-phases
> + (add-after 'unpack 'patch-Makefile
> + (lambda _
> + (substitute* "nm-vpnc-service.conf"
> + (("own_prefix")
> + "own")))))))

Please add a comment explaining what this does.

Toggle quote (8 lines)
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("autoconf" ,autoconf)
> + ("automake" ,automake)
> + ("pkg-config" ,pkg-config)
> + ("libtool" ,libtool)
> + ("intltool" ,intltool)))

Autoconf/Automake/Libtool are probably unnecessary.

Otherwise LGTM, thanks!

Ludo’.
C
C
Christopher Baines wrote on 19 Mar 2018 09:02
control message for bug #29306
(address . control@debbugs.gnu.org)
87y3io5w8v.fsf@cbaines.net
tags 29306 patch
C
C
Christopher Baines wrote on 19 Mar 2018 09:02
(address . control@debbugs.gnu.org)
87woy85w8t.fsf@cbaines.net
tags 29306 moreinfo
J
J
Jelle Licht wrote on 17 Jun 2019 12:26
Re: [bug#29306] network-manager-vpnc
(address . 29306@debbugs.gnu.org)
87y320pkwi.fsf@jlicht.xyz
Heya folks,

ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (11 lines)
> Heya ng0,
>
> ng0 <ng0@infotropique.org> skribis:
>
>> From 0cf7c178f8453ffa0984d1f6e18efb61cf55d0d2 Mon Sep 17 00:00:00 2001
>> From: ng0 <ng0@infotropique.org>
>> Date: Wed, 15 Nov 2017 10:40:46 +0000
>> Subject: [PATCH] gnu: Add network-manager-vpnc.
>>
>> * gnu/packages/gnome.scm (network-manager-vpnc): New variable.

Is this still being worked on/relevant? If so, I would like to verify
that it does what we want it to do, and get it merged :-).

Regards,
Jelle
L
L
Ludovic Courtès wrote on 17 Jun 2019 15:37
(name . Jelle Licht)(address . jlicht@fsfe.org)
877e9kxri6.fsf@gnu.org
Heya,

Jelle Licht <jlicht@fsfe.org> skribis:

Toggle quote (16 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Heya ng0,
>>
>> ng0 <ng0@infotropique.org> skribis:
>>
>>> From 0cf7c178f8453ffa0984d1f6e18efb61cf55d0d2 Mon Sep 17 00:00:00 2001
>>> From: ng0 <ng0@infotropique.org>
>>> Date: Wed, 15 Nov 2017 10:40:46 +0000
>>> Subject: [PATCH] gnu: Add network-manager-vpnc.
>>>
>>> * gnu/packages/gnome.scm (network-manager-vpnc): New variable.
>
> Is this still being worked on/relevant? If so, I would like to verify
> that it does what we want it to do, and get it merged :-).

Please give it a spin! It’s sad to see patches bitrot.

Cheers,
Ludo’.
N
(name . Ludovic Courtès)(address . ludo@gnu.org)
20190617140550.5v3pguhvxqmwug7c@uptimegirl
Hi Ludovic and Jelle,

Ludovic Courts transcribed 654 bytes:
Toggle quote (20 lines)
> Heya,
>
> Jelle Licht <jlicht@fsfe.org> skribis:
>
> > ludo@gnu.org (Ludovic Courtès) writes:
> >
> >> Heya ng0,
> >>
> >> ng0 <ng0@infotropique.org> skribis:
> >>
> >>> From 0cf7c178f8453ffa0984d1f6e18efb61cf55d0d2 Mon Sep 17 00:00:00 2001
> >>> From: ng0 <ng0@infotropique.org>
> >>> Date: Wed, 15 Nov 2017 10:40:46 +0000
> >>> Subject: [PATCH] gnu: Add network-manager-vpnc.
> >>>
> >>> * gnu/packages/gnome.scm (network-manager-vpnc): New variable.
> >
> > Is this still being worked on/relevant? If so, I would like to verify
> > that it does what we want it to do, and get it merged :-).

Feel free to take on this. I have started publishing my old patches,
so there could be some progress in there.
Consider all my open patches here (I have no idea how many) up for
taking (leaving me as co/author), since I'm mainly doing NetBSD and
GNUnet these days.

The last known state of this patch is here:


Cheers,
ng0
Toggle quote (4 lines)
> Please give it a spin! It’s sad to see patches bitrot.
>
> Cheers,
> Ludo’.
M
M
Maxim Cournoyer wrote on 15 Mar 2020 17:22
(name . Jelle Licht)(address . jlicht@fsfe.org)
87eett37vy.fsf@gmail.com
Jelle Licht <jlicht@fsfe.org> writes:

Toggle quote (18 lines)
> Heya folks,
>
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Heya ng0,
>>
>> ng0 <ng0@infotropique.org> skribis:
>>
>>> From 0cf7c178f8453ffa0984d1f6e18efb61cf55d0d2 Mon Sep 17 00:00:00 2001
>>> From: ng0 <ng0@infotropique.org>
>>> Date: Wed, 15 Nov 2017 10:40:46 +0000
>>> Subject: [PATCH] gnu: Add network-manager-vpnc.
>>>
>>> * gnu/packages/gnome.scm (network-manager-vpnc): New variable.
>
> Is this still being worked on/relevant? If so, I would like to verify
> that it does what we want it to do, and get it merged :-).

Closing, since you contributed a package for network-manager-vpnc back
in July of last year, with commit d376129f0b2 :-).

Maxim
Closed
?