[PATCH] gnu: gst-plugins-base: Disable tests that create network

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Roel Janssen
Owner
unassigned
Submitted by
Roel Janssen
Severity
normal
R
R
Roel Janssen wrote on 19 Apr 2018 00:01
(name . guix-patches)(address . guix-patches@gnu.org)
87tvs8fa30.fsf@gnu.org
Dear Guix,

The build for gst-plugins-base is failing, breaking the builds of quite
a few dependent packages. The attached patch disables the two tests
that are failing.

It seems that both tests attempt to set-up or connect to a TCP socket on
"localhost". Would this work in the build environment?

Is it OK to apply the following patch to fix the build for this package?

Kind regards,
Roel Janssen
From 1036f149e2117f4db4997a7427dec4707db30e9f Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Wed, 18 Apr 2018 23:55:23 +0200
Subject: [PATCH] gnu: gst-plugins-base: Disable tests that create network
connections.

* gnu/local.mk: Register patch.
* gnu/packages/gstreamer.scm: Add patch.
* gnu/packages/patches/gst-plugins-base-disable-tcp-tests.patch: New file.
---
gnu/local.mk | 1 +
gnu/packages/gstreamer.scm | 3 +-
.../gst-plugins-base-disable-tcp-tests.patch | 34 +++++++++++++++++++
3 files changed, 37 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/gst-plugins-base-disable-tcp-tests.patch

Toggle diff (68 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 056a46cb7..f2e041d05 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -750,6 +750,7 @@ dist_patch_DATA = \
%D%/packages/patches/grep-timing-sensitive-test.patch \
%D%/packages/patches/groff-source-date-epoch.patch \
%D%/packages/patches/gsl-test-i686.patch \
+ %D%/packages/patches/gst-plugins-base-disable-tcp-tests.patch \
%D%/packages/patches/gspell-dash-test.patch \
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
%D%/packages/patches/guile-2.2-default-utf8.patch \
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 6747c388d..33c4e04cd 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -157,7 +157,8 @@ This package provides the core library and elements.")
name "-" version ".tar.xz"))
(sha256
(base32
- "10i255q7i8an1hxz3szb36x1jcs9nfdy511pj2wg24h2vw1nnc2c"))))
+ "10i255q7i8an1hxz3szb36x1jcs9nfdy511pj2wg24h2vw1nnc2c"))
+ (patches (search-patches "gst-plugins-base-disable-tcp-tests.patch"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(propagated-inputs
diff --git a/gnu/packages/patches/gst-plugins-base-disable-tcp-tests.patch b/gnu/packages/patches/gst-plugins-base-disable-tcp-tests.patch
new file mode 100644
index 000000000..e58081bd4
--- /dev/null
+++ b/gnu/packages/patches/gst-plugins-base-disable-tcp-tests.patch
@@ -0,0 +1,34 @@
+This patch disables the rtspconnection test and the pipelines/tcp test because
+it attempts to set up a network connection.
+
+Patch by Roel Janssen <roel@gnu.org>
+
+*** a/tests/check/Makefile.am 2017-05-15 17:46:23.000000000 +0200
+--- b/tests/check/Makefile.am 2018-04-18 23:36:45.691293186 +0200
+***************
+*** 179,185 ****
+
+ if USE_PLUGIN_TCP
+ if USE_PLUGIN_APP
+! check_tcp = elements/multifdsink elements/multisocketsink pipelines/tcp
+ else
+ check_tcp = elements/multifdsink elements/multisocketsink
+ endif
+--- 179,185 ----
+
+ if USE_PLUGIN_TCP
+ if USE_PLUGIN_APP
+! check_tcp = elements/multifdsink elements/multisocketsink
+ else
+ check_tcp = elements/multifdsink elements/multisocketsink
+ endif
+***************
+*** 219,225 ****
+ libs/rtpbasedepayload \
+ libs/rtpbasepayload \
+ libs/rtsp \
+- libs/rtspconnection \
+ libs/sdp \
+ libs/tag \
+ libs/video \
+--- 219,224 ----
--
2.17.0
M
M
Marius Bakke wrote on 19 Apr 2018 18:11
87in8n9nx9.fsf@fastmail.com
Roel Janssen <roel@gnu.org> writes:

Toggle quote (6 lines)
> Dear Guix,
>
> The build for gst-plugins-base is failing, breaking the builds of quite
> a few dependent packages. The attached patch disables the two tests
> that are failing.

I cannot reproduce this failure, and on Hydra everything is fine:


Strange that it fails on your machine, it suggests some "impurity" in
the build environment. Can you try to figure out why it does not work?

Toggle quote (3 lines)
> It seems that both tests attempt to set-up or connect to a TCP socket on
> "localhost". Would this work in the build environment?

TCP sockets on localhost are normally fine, as long as they don't use
getaddrinfo() (I've been thinking about adding support for that).
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlrYv6IACgkQoqBt8qM6
VPqSRQf/Ryh/zJn0tMvAfSm3ccR7evCnXcRwhNkf021QGy6Liyx9brdDfn9o0YXI
1Syy4jAG4AyLf/CtnOFC/VA6eAZb6l7xnTjkYfc4nKIDX+AL2IiWYGJAiCrsEF3m
eaj/QLMAgaDdu2mmrEKr3l/YylJlO05IU4KC+PVUuZ5l6JshXRY0e/6J1//DDkuv
lVNiky3duNgA/BTJr56+w3UhvHYdWNWNFCL9SV9rciZT2InXMRLxyEYPtkQqESzw
eSLPyBvWhD6m0w+1cWdNbt4G3hJP76hDBANI4BST62vyfAqUxvPW0rhDJsAycKqS
SodpVr5WLJiYXcxnSkuYg/gfI2uE+w==
=EhmT
-----END PGP SIGNATURE-----

R
R
Roel Janssen wrote on 19 Apr 2018 19:16
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 31213-done@debbugs.gnu.org)
87lgdjw1zg.fsf@gnu.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (21 lines)
> Roel Janssen <roel@gnu.org> writes:
>
>> Dear Guix,
>>
>> The build for gst-plugins-base is failing, breaking the builds of quite
>> a few dependent packages. The attached patch disables the two tests
>> that are failing.
>
> I cannot reproduce this failure, and on Hydra everything is fine:
>
> https://hydra.gnu.org/job/gnu/master/gst-plugins-base-1.12.4.x86_64-linux
>
> Strange that it fails on your machine, it suggests some "impurity" in
> the build environment. Can you try to figure out why it does not work?
>
>> It seems that both tests attempt to set-up or connect to a TCP socket on
>> "localhost". Would this work in the build environment?
>
> TCP sockets on localhost are normally fine, as long as they don't use
> getaddrinfo() (I've been thinking about adding support for that).

Right.. So the patch is not needed.

Kind regards,
Roel Janssen
Closed
?