[PATCH 3/6] gnu: Add ghc-containers.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tonton
Owner
unassigned
Submitted by
Tonton
Severity
normal
T
T
Tonton wrote on 11 May 2018 22:34
(name . Tonton)(address . tonton@riseup.net)
20180511203408.29491-2-tonton@riseup.net
* gnu/packages/haskell.scm (ghc-containers): New variable.
---
gnu/packages/haskell.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 67faeb852..dd9d2f15d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9490,4 +9490,35 @@ within appropriate monads, as well as some instances of these classes.")
(home-page "https://hackage.haskell.org/package/array")
(license license:bsd-3)))
+(define-public ghc-containers
+ (package
+ (name "ghc-containers")
+ (version "0.5.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://hackage.haskell.org/package/containers-0.5.11.0/containers-"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0j29w09kvcn1c0yi4clmrdbgs2gqmpxs2m7q80ib2ix1smm25kaq"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-array" ,ghc-array)
+ ("ghc-deepseq" ,ghc-deepseq-generics)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-chasingbottoms" ,ghc-chasingbottoms)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-ghc-prim" ,ghc-primitive)))
+ (synopsis "Haskell containers: Assorted concrete container types")
+ (description "Haskell module providing efficient general-purpose
+implementations of various immutable container types including sets,
+maps, sequences, trees, and graphs.")
+ (home-page "https://hackage.haskell.org/package/containers")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here
--
2.17.0
L
L
Ludovic Courtès wrote on 14 May 2018 10:27
control message for bug #31420
(address . control@debbugs.gnu.org)
87sh6ubq0l.fsf@gnu.org
tags 31420 fixed
close 31420
?