[PATCH] Add emacs-build-farm

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex Kost
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alex Kost
Severity
normal
A
A
Alex Kost wrote on 26 Aug 2018 13:33
(address . guix-patches@gnu.org)
87o9dpgy6b.fsf@gmail.com
Hello,

This emacs package provides an interface for Hydra and Cuirass build
farms. AFAICT it supports everything that Cuirass and Hydra APIs
currently provide.

It is a replacement for the old 'guix-hydra-…' stuff from 'emacs-guix'
package (which will be removed in next Emacs-Guix release).

I'm going to make the announcement for it on guix-devel list after this
package will be applied to the guix tree, thanks.
From dc933a2cb96b562c16580b6fb8d79e55f3535e92 Mon Sep 17 00:00:00 2001
From: Alex Kost <alezost@gmail.com>
Date: Sun, 26 Aug 2018 14:27:33 +0300
Subject: [PATCH] gnu: Add emacs-build-farm.

* gnu/packages/emacs.scm (emacs-build-farm): New variable.
---
gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 20d5597f5..479bcddaa 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1710,6 +1710,32 @@ management tasks from Emacs. To begin with, run @code{M-x guix-about} or
@code{M-x guix-help} command.")
(license license:gpl3+)))
+(define-public emacs-build-farm
+ (package
+ (name "emacs-build-farm")
+ (version "0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/alezost-emacs/build-farm")
+ (commit "e2db66d5f6b381c8e21a5a7b95eef91e5fca6a20")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1q65ja9c52wjfbb7z16jpq5hnxv0rjg9gvs0xna2fs3phzl2lm93"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("bui" ,emacs-bui)
+ ("magit-popup" ,emacs-magit-popup)))
+ (home-page "https://gitlab.com/alezost-emacs/build-farm")
+ (synopsis "Emacs interface for Hydra and Cuirass build farms")
+ (description
+ "This Emacs package provides an interface for Hydra and
+Cuirass (build farms used by Nix and Guix). It allows you to look at
+various data related to the build farm projects, jobsets, builds and
+evaluations. The entry point is @code{M-x build-farm} command.")
+ (license license:gpl3+)))
+
(define-public emacs-d-mode
(package
(name "emacs-d-mode")
--
2.18.0
L
L
Ludovic Courtès wrote on 27 Aug 2018 13:52
(name . Alex Kost)(address . alezost@gmail.com)(address . 32532@debbugs.gnu.org)
87zhx89gcn.fsf@gnu.org
Hi Alex,

Alex Kost <alezost@gmail.com> skribis:

Toggle quote (7 lines)
> This emacs package provides an interface for Hydra and Cuirass build
> farms. AFAICT it supports everything that Cuirass and Hydra APIs
> currently provide.
>
> It is a replacement for the old 'guix-hydra-…' stuff from 'emacs-guix'
> package (which will be removed in next Emacs-Guix release).

Awesome!

Toggle quote (7 lines)
> From dc933a2cb96b562c16580b6fb8d79e55f3535e92 Mon Sep 17 00:00:00 2001
> From: Alex Kost <alezost@gmail.com>
> Date: Sun, 26 Aug 2018 14:27:33 +0300
> Subject: [PATCH] gnu: Add emacs-build-farm.
>
> * gnu/packages/emacs.scm (emacs-build-farm): New variable.

LGTM!

Regarding the code, I’m interested in adding new features to (guix ci),
the client module for Cuirass/Hydra. Just mentioning it in case it’s
something that would make sense to share with emacs-build-farm.

Thanks,
Ludo’.
A
A
Alex Kost wrote on 27 Aug 2018 17:59
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 32532@debbugs.gnu.org)
8736uzer7d.fsf@gmail.com
Ludovic Courtès (2018-08-27 13:52 +0200) wrote:

Toggle quote (1 lines)
> Alex Kost <alezost@gmail.com> skribis:
[...]
Toggle quote (9 lines)
>> From dc933a2cb96b562c16580b6fb8d79e55f3535e92 Mon Sep 17 00:00:00 2001
>> From: Alex Kost <alezost@gmail.com>
>> Date: Sun, 26 Aug 2018 14:27:33 +0300
>> Subject: [PATCH] gnu: Add emacs-build-farm.
>>
>> * gnu/packages/emacs.scm (emacs-build-farm): New variable.
>
> LGTM!

Thanks, I will commit it soon.

Toggle quote (4 lines)
> Regarding the code, I’m interested in adding new features to (guix ci),
> the client module for Cuirass/Hydra. Just mentioning it in case it’s
> something that would make sense to share with emacs-build-farm.

Sorry, I don't understand what you mean. emacs-build-farm is a pure
elisp package, it can't share any guile code with (guix ci), or did you
mean something else?

--
Alex
L
L
Ludovic Courtès wrote on 27 Aug 2018 23:14
(name . Alex Kost)(address . alezost@gmail.com)(address . 32532@debbugs.gnu.org)
871saj8qbm.fsf@gnu.org
Alex Kost <alezost@gmail.com> skribis:

Toggle quote (2 lines)
> Ludovic Courtès (2018-08-27 13:52 +0200) wrote:

[...]

Toggle quote (8 lines)
>> Regarding the code, I’m interested in adding new features to (guix ci),
>> the client module for Cuirass/Hydra. Just mentioning it in case it’s
>> something that would make sense to share with emacs-build-farm.
>
> Sorry, I don't understand what you mean. emacs-build-farm is a pure
> elisp package, it can't share any guile code with (guix ci), or did you
> mean something else?

I know it’s pure elisp, which is why I wrote “in case it’s something
that would make sense.” That is, if you think we could share that
Scheme code, we can do it (but emacs-build-farm would have to use
Geiser); if you don’t want to, that’s also fine. I hope it’s clearer
now.

Ludo’.
A
A
Alex Kost wrote on 28 Aug 2018 11:25
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 32532-done@debbugs.gnu.org)
87in3ualmz.fsf@gmail.com
Ludovic Courtès (2018-08-27 23:14 +0200) wrote:

Toggle quote (19 lines)
> Alex Kost <alezost@gmail.com> skribis:
>
>> Ludovic Courtès (2018-08-27 13:52 +0200) wrote:
>
> [...]
>
>>> Regarding the code, I’m interested in adding new features to (guix ci),
>>> the client module for Cuirass/Hydra. Just mentioning it in case it’s
>>> something that would make sense to share with emacs-build-farm.
>>
>> Sorry, I don't understand what you mean. emacs-build-farm is a pure
>> elisp package, it can't share any guile code with (guix ci), or did you
>> mean something else?
>
> I know it’s pure elisp, which is why I wrote “in case it’s something
> that would make sense.” That is, if you think we could share that
> Scheme code, we can do it (but emacs-build-farm would have to use
> Geiser); if you don’t want to, that’s also fine.

Oh, no, no. emacs-build-farm will not use any scheme code. There is no
reason for that. Emacs has in-built "json" library, so parsing json
from Hydra/Cuirass using elisp is easy. Using additional scheme code
for that would be a big unneeded complication.

Toggle quote (2 lines)
> I hope it’s clearer now.

Yes, thanks for explaining.

Applied as 40f7ebac66913a531854cc18f9b417624508d654.

--
Alex
Closed
?