Cuirass: Crash and unable to restart when an input is unreachable

  • Done
  • quality assurance status badge
Details
2 participants
  • Clément Lassieur
  • Ludovic Courtès
Owner
unassigned
Submitted by
Clément Lassieur
Severity
normal
C
C
Clément Lassieur wrote on 20 Sep 2018 10:28
(address . bug-guix@gnu.org)
877ejgd13u.fsf@lassieur.org
Hi,

Cuirass is unable to recover from this crash, which happens when
'github.com' (which is one of my inputs) is unreachable.

The Shepherd can't restart it (because 'github.com' is still
unreachable) so it disables it.

Toggle snippet (38 lines)
2018-09-20T01:23:31 running Fibers on 4 kernel threads
2018-09-20T01:23:31 marking stale builds as "scheduled"...
2018-09-20T01:23:31 listening on 0.0.0.0:8081
2018-09-20T01:23:31 retrieving list of pending builds...
2018-09-20T01:23:31 heap: 11.68 MiB; threads: 10; file descriptors: 48
2018-09-20T01:23:31 canceling 0 stale builds
2018-09-20T01:23:31 restarting 0 pending builds
2018-09-20T01:23:31 building 0 derivations in batches of 200
2018-09-20T01:23:31 done with 0 derivations
2018-09-20T01:23:31 done with restarted builds
2018-09-20T01:23:31 fetching input 'packages' of spec 'guix-manifest-clem'
2018-09-20T01:23:31 fetching input 'clem-conf' of spec 'guix-manifest-clem'
2018-09-20T01:23:31 fetching input 'guix-clem' of spec 'guix-manifest-clem'
2018-09-20T01:23:31 fetching input 'mathieu-conf' of spec 'guix-manifest-clem'
2018-09-20T01:23:31 fatal: uncaught exception 'git-error' in 'build' fiber!
2018-09-20T01:23:31 exception arguments: (#<<git-error> code: -1 message: "failed to resolve address for github.com: Name or service not known" class: 12>)
In ice-9/boot-9.scm:
829:9 9 (catch #t #<procedure 2d2c260 at ice-9/eval.scm:330:13?> ?)
705:2 8 (call-with-prompt ("break") #<procedure 2cf9a20 at ice?> ?)
705:2 7 (call-with-prompt ("continue") #<procedure 2cf96a0 at ?> ?)
In ice-9/eval.scm:
619:8 6 (_ #(#(#<directory (guile-user) 23ba140> #<variable?> ?)))
In srfi/srfi-1.scm:
640:9 5 (for-each #<procedure process (spec)> (((# . "gu?") ?) ?))
In ice-9/boot-9.scm:
751:25 4 (dispatch-exception 0 git-error (#<<git-error> code: -?>))
In cuirass/utils.scm:
181:8 3 (_ _ #<<git-error> code: -1 message: "failed to resolve?>)
In ice-9/boot-9.scm:
829:9 2 (catch #t #<procedure 2c2d240 at cuirass/utils.scm:181?> ?)
In cuirass/utils.scm:
182:22 1 (_)
In unknown file:
0 (make-stack #t)
ERROR: In procedure make-stack:
Throw to key `git-error' with args `(#<<git-error> code: -1 message: "failed to resolve address for github.com: Name or service not known" class: 12>)'.

Clément
L
L
Ludovic Courtès wrote on 20 Nov 2018 16:57
(name . Clément Lassieur)(address . clement@lassieur.org)(address . 32779-done@debbugs.gnu.org)
874lcbzqqt.fsf@gnu.org
Hello,

Clément Lassieur <clement@lassieur.org> skribis:

Toggle quote (23 lines)
> 2018-09-20T01:23:31 fatal: uncaught exception 'git-error' in 'build' fiber!
> 2018-09-20T01:23:31 exception arguments: (#<<git-error> code: -1 message: "failed to resolve address for github.com: Name or service not known" class: 12>)
> In ice-9/boot-9.scm:
> 829:9 9 (catch #t #<procedure 2d2c260 at ice-9/eval.scm:330:13?> ?)
> 705:2 8 (call-with-prompt ("break") #<procedure 2cf9a20 at ice?> ?)
> 705:2 7 (call-with-prompt ("continue") #<procedure 2cf96a0 at ?> ?)
> In ice-9/eval.scm:
> 619:8 6 (_ #(#(#<directory (guile-user) 23ba140> #<variable?> ?)))
> In srfi/srfi-1.scm:
> 640:9 5 (for-each #<procedure process (spec)> (((# . "gu?") ?) ?))
> In ice-9/boot-9.scm:
> 751:25 4 (dispatch-exception 0 git-error (#<<git-error> code: -?>))
> In cuirass/utils.scm:
> 181:8 3 (_ _ #<<git-error> code: -1 message: "failed to resolve?>)
> In ice-9/boot-9.scm:
> 829:9 2 (catch #t #<procedure 2c2d240 at cuirass/utils.scm:181?> ?)
> In cuirass/utils.scm:
> 182:22 1 (_)
> In unknown file:
> 0 (make-stack #t)
> ERROR: In procedure make-stack:
> Throw to key `git-error' with args `(#<<git-error> code: -1 message: "failed to resolve address for github.com: Name or service not known" class: 12>)'.

Fixed in 27f14634102a73d4252d86b912f67e9ad464be1e. Now it’ll log the
error and keep going.

Ludo’.
Closed
C
C
Clément Lassieur wrote on 20 Nov 2018 17:04
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 32779-done@debbugs.gnu.org)
875zwr7n2b.fsf@lassieur.org
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (32 lines)
> Hello,
>
> Clément Lassieur <clement@lassieur.org> skribis:
>
>> 2018-09-20T01:23:31 fatal: uncaught exception 'git-error' in 'build' fiber!
>> 2018-09-20T01:23:31 exception arguments: (#<<git-error> code: -1 message: "failed to resolve address for github.com: Name or service not known" class: 12>)
>> In ice-9/boot-9.scm:
>> 829:9 9 (catch #t #<procedure 2d2c260 at ice-9/eval.scm:330:13?> ?)
>> 705:2 8 (call-with-prompt ("break") #<procedure 2cf9a20 at ice?> ?)
>> 705:2 7 (call-with-prompt ("continue") #<procedure 2cf96a0 at ?> ?)
>> In ice-9/eval.scm:
>> 619:8 6 (_ #(#(#<directory (guile-user) 23ba140> #<variable?> ?)))
>> In srfi/srfi-1.scm:
>> 640:9 5 (for-each #<procedure process (spec)> (((# . "gu?") ?) ?))
>> In ice-9/boot-9.scm:
>> 751:25 4 (dispatch-exception 0 git-error (#<<git-error> code: -?>))
>> In cuirass/utils.scm:
>> 181:8 3 (_ _ #<<git-error> code: -1 message: "failed to resolve?>)
>> In ice-9/boot-9.scm:
>> 829:9 2 (catch #t #<procedure 2c2d240 at cuirass/utils.scm:181?> ?)
>> In cuirass/utils.scm:
>> 182:22 1 (_)
>> In unknown file:
>> 0 (make-stack #t)
>> ERROR: In procedure make-stack:
>> Throw to key `git-error' with args `(#<<git-error> code: -1 message: "failed to resolve address for github.com: Name or service not known" class: 12>)'.
>
> Fixed in 27f14634102a73d4252d86b912f67e9ad464be1e. Now it’ll log the
> error and keep going.
>
> Ludo’.

Thank you!
Closed
?