[PATCH] gnu: update python-biopython to 1.72

  • Done
  • quality assurance status badge
Details
5 participants
  • Andreas Enge
  • Brett Gilio
  • Sarah Morgensen
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal
B
B
Brett Gilio wrote on 13 Oct 2018 05:49
(address . guix-patches@gnu.org)(name . Brett Gilio)(address . brettg@posteo.net)
20181013034945.9545-1-brettg@posteo.net
---
gnu/packages/bioinformatics.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 91bb94c54..2f59211ab 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018 Brett Gilio <brettg@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -732,14 +733,14 @@ provide a coordinated and extensible framework to do computational biology.")
(define-public python-biopython
(package
(name "python-biopython")
- (version "1.70")
+ (version "1.72")
(source (origin
(method url-fetch)
;; use PyPi rather than biopython.org to ease updating
(uri (pypi-uri "biopython" version))
(sha256
(base32
- "0nz4n9d2y2dg849gn1z0vjlkwcpzzkzy3fij7x94a6ixy2c54z2a"))))
+ "18p5dk9hdjq1p8sz3fgld0yajsdf0bb28gbv4rk0rfdd8cj4jsxb"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.19.1
L
L
Ludovic Courtès wrote on 21 Oct 2018 23:40
(name . Brett Gilio)(address . brettg@posteo.net)(address . 33032@debbugs.gnu.org)
87o9bn6krx.fsf@gnu.org
Hi Brett,

Brett Gilio <brettg@posteo.net> skribis:

Toggle quote (4 lines)
> ---
> gnu/packages/bioinformatics.scm | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)

[...]

Toggle quote (4 lines)
> (name "python-biopython")
> - (version "1.70")
> + (version "1.72")

I applied the patch and built tried to build the packages that depend on
it, as returned by:

guix refresh -l python-biopython python2-biopython

Unfortunately that triggers a test failure in ‘seqmagic’ (I didn’t see
whether others are failing):

Toggle snippet (46 lines)
ERROR: test_dna_protein_nogap_stop (seqmagick.test.test_transform.TranslateTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
File "/tmp/guix-build-seqmagick-0.7.0.drv-0/seqmagick-0.7.0/seqmagick/test/test_transform.py", line 513, in test_dna_protein_nogap_stop
self.assertEqual(expected, [str(i.seq) for i in actual])
File "/tmp/guix-build-seqmagick-0.7.0.drv-0/seqmagick-0.7.0/seqmagick/test/test_transform.py", line 513, in <listcomp>
self.assertEqual(expected, [str(i.seq) for i in actual])
File "/tmp/guix-build-seqmagick-0.7.0.drv-0/seqmagick-0.7.0/seqmagick/transform.py", line 703, in translate
protein = seq.translate(table, to_stop=to_stop)
File "/gnu/store/ng8rrazi7kwchsmnhmhkjdfgjsv3lngv-python-biopython-1.72/lib/python3.6/site-packages/Bio/Seq.py", line 1163, in translate
cds, gap=gap)
File "/gnu/store/ng8rrazi7kwchsmnhmhkjdfgjsv3lngv-python-biopython-1.72/lib/python3.6/site-packages/Bio/Seq.py", line 2543, in _translate_str
dual_coding = [c for c in stop_codons if c in forward_table]
File "/gnu/store/ng8rrazi7kwchsmnhmhkjdfgjsv3lngv-python-biopython-1.72/lib/python3.6/site-packages/Bio/Seq.py", line 2543, in <listcomp>
dual_coding = [c for c in stop_codons if c in forward_table]
File "/tmp/guix-build-seqmagick-0.7.0.drv-0/seqmagick-0.7.0/seqmagick/transform.py", line 663, in __getitem__
elif '-' in codon:
TypeError: argument of type 'int' is not iterable
-------------------- >> begin captured logging << --------------------
root: INFO: Applying translation generator: operation to perform is dna2proteinstop.
--------------------- >> end captured logging << ---------------------

----------------------------------------------------------------------
Ran 164 tests in 1.530s

FAILED (errors=7, skipped=7)
Test failed: <unittest.runner.TextTestResult run=164 errors=7 failures=0>
error: Test failed: <unittest.runner.TextTestResult run=164 errors=7 failures=0>
Backtrace:
5 (primitive-load "/gnu/store/hg9qrk8cr2aw2y4ylxdcnlvpb3y…")
In ice-9/eval.scm:
191:35 4 (_ _)
In srfi/srfi-1.scm:
640:9 3 (for-each #<procedure 94c140 at /gnu/store/5sy3815dpjc…> …)
In /gnu/store/5sy3815dpjcvxhssaba6g2ilxm29va9n-module-import/guix/build/gnu-build-system.scm:
799:31 2 (_ _)
In /gnu/store/5sy3815dpjcvxhssaba6g2ilxm29va9n-module-import/guix/build/python-build-system.scm:
142:8 1 (check #:tests? _ #:test-target _ #:use-setuptools? _)
In /gnu/store/5sy3815dpjcvxhssaba6g2ilxm29va9n-module-import/guix/build/utils.scm:
616:6 0 (invoke _ . _)

/gnu/store/5sy3815dpjcvxhssaba6g2ilxm29va9n-module-import/guix/build/utils.scm:616:6: In procedure invoke:
Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "python" arguments: ("-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test") exit-status: 1 term-signal: #f stop-signal: #f] 99fec0>)'.
builder for `/gnu/store/a6zljh5pn0agm0rdf8bhx7c8hk9hia1d-seqmagick-0.7.0.drv' failed with exit code 1

Could you take a look?

Thank you!

Ludo’.
L
L
Ludovic Courtès wrote on 27 Dec 2018 11:59
control message for bug #33032
(address . control@debbugs.gnu.org)
877efvb5g2.fsf@gnu.org
tags 33032 moreinfo
A
A
Andreas Enge wrote on 5 Sep 2020 22:36
Update
(address . 33032@debbugs.gnu.org)
20200905203639.GA24538@jurong
Hello,

I just updated seqmagick to 0.8.0.

Then I tried to update python-biopython to the latest version, 1.78. With it,
seqmagick fails to compile with the following message:

mportError: cannot import name 'triefind' from 'Bio' (/gnu/store/9cr6885z39yb5x3pbanva5h9nacmlkvz-python-biopython-1.78/lib/python3.8/site-packages/Bio/__init__.py)

======================================================================
ERROR: Failure: ImportError (Bio.Alphabet has been removed from Biopython. In many cases, the alphabet can simply be ignored and removed from scripts. In a few cases, you may need to specify the ``molecule_type`` as an annotation on a SeqRecord for your script to work correctly. Please see https://biopython.org/wiki/Alphabetfor more information.)


Andreas
S
S
Sarah Morgensen wrote on 14 Sep 2021 05:32
(name . Andreas Enge)(address . andreas@enge.fr)(address . 33032@debbugs.gnu.org)
86o88vj0h3.fsf@mgsn.dev
Hello,

Andreas Enge <andreas@enge.fr> writes:

Toggle quote (17 lines)
> Hello,
>
> I just updated seqmagick to 0.8.0.
>
> Then I tried to update python-biopython to the latest version, 1.78. With it,
> seqmagick fails to compile with the following message:
>
> mportError: cannot import name 'triefind' from 'Bio'
> (/gnu/store/9cr6885z39yb5x3pbanva5h9nacmlkvz-python-biopython-1.78/lib/python3.8/site-packages/Bio/__init__.py)
>
> ======================================================================
> ERROR: Failure: ImportError (Bio.Alphabet has been removed from Biopython. In
> many cases, the alphabet can simply be ignored and removed from scripts. In a
> few cases, you may need to specify the ``molecule_type`` as an annotation on a
> SeqRecord for your script to work correctly. Please see
> https://biopython.org/wiki/Alphabet for more information.)

I think this may be fixed by updating seqmagick to 0.8.1 (current
release 0.8.4) and packaging its new dependency, pygtrie, which provides
that removed functionality.

--
Sarah
Z
Z
zimoun wrote on 7 Apr 2022 14:03
Re: bug#33032: [PATCH] gnu: update python-biopython to 1.72
(name . Brett Gilio)(address . brettg@posteo.net)(address . 33032-done@debbugs.gnu.org)
86zgkx2j8x.fsf@gmail.com
Hi,

Thank for your contribution. Currently Guix provides more recent
versions of BioPython.


On Fri, 12 Oct 2018 at 22:49, Brett Gilio <brettg@posteo.net> wrote:

Toggle quote (4 lines)
> (name "python-biopython")
> - (version "1.70")
> + (version "1.72")

Toggle snippet (5 lines)
$ guix show python-biopython | recsel -C -p version
version: 1.76
version: 1.73

Therefore, closing!


Cheers,
simon
Closed
?