scmutils fails to build

  • Done
  • quality assurance status badge
Details
One participant
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 25 Jan 2019 23:15
(address . bug-guix@gnu.org)
87d0okv0yh.fsf@elephly.net
scmutils fails to build with the current MIT Scheme. I first thought it
might just be minor problems, so I applied some patches in build phases:

Toggle snippet (34 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index bcaccb452..bb2a9f9fb 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -680,8 +680,25 @@ threads.")
"(disk-save \"edwin-mechanics.com\")'"
"| mit-scheme")))
(with-directory-excursion "scmutils/scmutils"
- (and (zero? (system "mit-scheme < compile.scm"))
- (zero? (system make-img))))
+ ;; Case seems to be important.
+ (substitute* "kernel/utils.scm"
+ (("#F") "#f"))
+ (substitute* "display/exdisplay.scm"
+ (("SPACE") "space"))
+ (substitute* "enclose/jinx-utils.scm"
+ (("Space") "space"))
+ ;; These files only contain comments, so don't compile them
+ ;; or else we get an error.
+ (substitute* "mechanics/compile.scm"
+ (("\"Lagrangian-evolution\"") "")
+ (("\"Hamiltonian-evolution\"") "")
+ (("\"generating-functions\"") ""))
+ (substitute* "compile.scm"
+ (("\\(cf \"./patch\"\\)") "(display \"skipping\")"))
+
+ (invoke "mit-scheme" "--load" "compile.scm")
+ (unless (zero? (system make-img))
+ (error "could not build scmutils")))
#t)))
(add-before 'install 'fix-directory-names
;; Correct directory names in the startup script.

Unfortunately, this is not enough as some procedure bindings have
disappeared, such as “guarantee-procedure-arity”.

The compilation results in a lot of warnings; I’m not sure if they are
harmless. There is no more recent release of scmutils. There is a port
to Guile 2.0, but it is not obvious how to compile it:


--
Ricardo
R
R
Ricardo Wurmus wrote on 29 Apr 2019 17:22
(address . 34203-done@debbugs.gnu.org)
87k1fc6dlq.fsf@elephly.net
Toggle quote (2 lines)
> scmutils fails to build with the current MIT Scheme.

I have removed the scmutils package with commit 4267481a4e.

--
Ricardo
Closed
?