Add package: Emacs-shroud; Emacs interface for shroud

  • Done
  • quality assurance status badge
Details
4 participants
  • Brett Gilio
  • Marius Bakke
  • Amar Singh
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Amar Singh
Severity
normal
A
A
Amar Singh wrote on 7 Feb 2019 10:11
(address . guix-patches@gnu.org)
878sysotda.fsf@disroot.org
This is not a polished software by any means.
This is an interface for the shroud password manager

Patch:

From b7f9ec3820158d2b6fdde64dfed0fa7233ec5951 Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Thu, 7 Feb 2019 14:37:25 +0530
Subject: [PATCH] add emacs-shroud; emacs interface for shroud

Signed-off-by: Amar Singh <nly@disroot.org>
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 960518f9d..d43153b55 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8518,6 +8518,28 @@ close, copy, cut, paste, undo, redo.")
standard Unix password manager\").")
(license license:gpl2+)))
+(define-public emacs-shroud
+ (package
+ (name "emacs-shroud")
+ (version "0.1")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/o-nly/" name "/archive/release-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jxfa2fa6r0ay9c6nf4xwz5vddb1v45cgaxkgdxxhck0l527i3yc"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)
+ ("shroud" ,shroud)))
+ (home-page "http://nly.info.tm:9001/emacs/shroud.el")
+ (synopsis "Shroud (gpg) support for Emacs")
+ (description
+ "This package provides functions for working with shroud password manager.")
+ (license license:gpl3+)))
+
(define-public emacs-pass
(package
(name "emacs-pass")
--
2.20.1
R
R
Ricardo Wurmus wrote on 20 Feb 2019 22:36
Re: bug#34595: [PATCH] gnu: Add emacs-shroud
(name . Amar Singh)(address . nly@disroot.org)
874l8y5ehq.fsf@elephly.net
Hi,

Toggle quote (4 lines)
> Shroud is a password manager written in Guile which uses GnuPG in the
> backend. This package is an Emacs interface to Shroud using the Buffers
> User Interface library.

You have previously already submitted a variant of this:


Please don’t open more tickets for this but instead send updates to the
same ticket. I’m closing this issue, because what you attached is not a
git formatted patch.

Toggle quote (2 lines)
> +(define-public nly/emacs-shroud

We don’t use personal prefixes like “nly/” in Guix.

Toggle quote (4 lines)
> + (package
> + (name "emacs-shroud")
> + (version "ad5de6d")

A version string must be monotonically increasing over time. Commit
hashes don’t do that, so we use (git-version last-release revision
commit) instead.

We prefer releases over arbitrary commits. Since you are the developer,
could you please tell us what the difference is between this version and
the previous release? Could you make a new release instead?

Toggle quote (9 lines)
> + (build-system emacs-build-system)
> + (propagated-inputs
> + `(("emacs-f" ,emacs-f)
> + ("emacs-s" ,emacs-s)
> + ("emacs-bui" ,emacs-bui)
> + ("shroud" ,shroud)))
> + (home-page "http://nly.info.tm:9001/emacs/shroud.el")
> + (synopsis "Shroud (gpg) support for Emacs")

Why “(gpg)”? It’s probably better to say “Shroud password manager
interface for Emacs”.

Toggle quote (4 lines)
> + (description
> + "This package provides functions for working with shroud password
> manager.")

I’d not say “functions”. How about

This package provides an Emacs minor mode for working with the Shroud
password manager.

Could you please send an updated patch?

--
Ricardo
B
B
Brett Gilio wrote on 20 Feb 2019 22:44
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87ftsi2kzj.fsf@posteo.net
Ricardo Wurmus writes:

Toggle quote (9 lines)
>
> A version string must be monotonically increasing over time. Commit
> hashes don’t do that, so we use (git-version last-release revision
> commit) instead.
>
> We prefer releases over arbitrary commits. Since you are the developer,
> could you please tell us what the difference is between this version and
> the previous release? Could you make a new release instead?

To the OP, there are several packages that use this form. You can look
at some and pretty much directly copy their content and fill in your
relevant information.
N
(address . 34364@debbugs.gnu.org)
c6a0231a841275c7a93c8b00e5643e21@disroot.org
February 21, 2019 3:07 AM, "Ricardo Wurmus" <rekado@elephly.net> wrote:

Toggle quote (14 lines)
> Hi,
>
>> Shroud is a password manager written in Guile which uses GnuPG in the
>> backend. This package is an Emacs interface to Shroud using the Buffers
>> User Interface library.
>
> You have previously already submitted a variant of this:
>
> https://issues.guix.info/issue/34364
>
> Please don’t open more tickets for this but instead send updates to the
> same ticket. I’m closing this issue, because what you attached is not a
> git formatted patch.

Thanks for closing the other issue, i was oblivious of debbugs until today.

Toggle quote (18 lines)
>
>> +(define-public nly/emacs-shroud
>
> We don’t use personal prefixes like “nly/” in Guix.
>
>> + (package
>> + (name "emacs-shroud")
>> + (version "ad5de6d")
>
> A version string must be monotonically increasing over time. Commit
> hashes don’t do that, so we use (git-version last-release revision
> commit) instead.
>
> We prefer releases over arbitrary commits. Since you are the developer,
> could you please tell us what the difference is between this version and
> the previous release? Could you make a new release instead?
>

Thanks, got it. Now looks like (git-version "v1" "1" commit)

Toggle quote (12 lines)
>> + (build-system emacs-build-system)
>> + (propagated-inputs
>> + `(("emacs-f" ,emacs-f)
>> + ("emacs-s" ,emacs-s)
>> + ("emacs-bui" ,emacs-bui)
>> + ("shroud" ,shroud)))
>> + (home-page "http://nly.info.tm:9001/emacs/shroud.el")
>> + (synopsis "Shroud (gpg) support for Emacs")
>
> Why “(gpg)”? It’s probably better to say “Shroud password manager
> interface for Emacs”.

New synopsis: Emacs interface for Shroud password manager

Toggle quote (10 lines)
>
>> + (description
>> + "This package provides functions for working with shroud password
>> manager.")
>
> I’d not say “functions”. How about
>
> This package provides an Emacs minor mode for working with the Shroud
> password manager.

This package doesn't include any minor-mode so I assume it would become misleading.

Toggle quote (6 lines)
>
> Could you please send an updated patch?
>
> --
> Ricardo

I hope web mail doesn't html-ize the patch.

This is great, It feels awesome to get in a personal package I've been using for months.

Thanks,
Amar

From 0309576d26ce92ec2324c0505599da95408b1235 Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Mon, 22 Apr 2019 01:28:32 +0530
Subject: [PATCH] gnu: Add emacs-shroud.

* gnu/packages/emacs-xyz.scm (emacs-shroud): New variable.
---
gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 54663496fe..d7c1245f43 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15306,3 +15306,35 @@ numbers within that region will be incremented/decremented (unlike in Vim).
It is a fork of https://github.com/cofi/evil-numbers, which is unmaintained.")
(license license:gpl3+))))
+
+(define-public emacs-shroud
+ (let
+ ((commit "dc68f5538692bf07376cd5395b87102025549f32"))
+ (package
+ (name "emacs-shroud")
+ (version
+ (git-version "v1" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/o-nly/emacs-shroud")
+ (commit commit)))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32
+ "17a3z5p252nbj3y7rwbvx1jk2bizzdcina6vw8blnks4dvv30k87"))))
+ (build-system emacs-build-system)
+ (inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-bui" ,emacs-bui)
+ ("shroud" ,shroud)))
+ (home-page "http://git.nly.info.tm:9001/shroud.git")
+ (synopsis "Emacs interface for Shroud password manager")
+ (description
+ "This package provides functions for working with shroud
+password manager using Elisp, a reader for Shroud DB, and an Buffers
+User Interface for using shroud password database.")
+ (license license:gpl3+))))
--
2.21.0
A
A
Amar Singh wrote on 26 May 2019 18:35
[PATCH] gnu: Add emacs-shroud.
(address . 34364@debbugs.gnu.org)
85ef4l6umv.fsf@disroot.org
Updated emacs-shroud. It should be usable now.
From 06b1b2d4567adf27d4e980bcdf9c2886d9afdcbd Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Mon, 22 Apr 2019 01:28:32 +0530
Subject: [PATCH] gnu: Add emacs-shroud.

* gnu/packages/emacs-xyz.scm (emacs-shroud): New variable.
---
gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9199b45e40..d97914faef 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15620,3 +15620,33 @@ verb commands which would are normally destructive (such as deletion) are
provided. Those alternative commands are and bound by default to their
corresponding Evil keys.")
(license license:expat))))
+
+(define-public emacs-shroud
+ (package
+ (name "emacs-shroud")
+ (version "1.15.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/o-nly/emacs-shroud.git")
+ (commit version)))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32
+ "0wvm4lxqcc1p8v7rpqal3bnqgnpk1gs7v18i83f6cvi5d88jkgdg"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("shroud" ,shroud)
+ ("emacs-f" ,emacs-f)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-s" ,emacs-s)
+ ("emacs-bui" ,emacs-bui)
+ ("gnupg" ,gnupg)))
+ (home-page "http://git.nly.info.tm:9001/shroud.git")
+ (synopsis "Emacs interface for Shroud password manager")
+ (description
+ "Provides Emacs interface to the Shroud password manager.")
+ (license license:gpl3+)))
--
2.21.0
M
M
Marius Bakke wrote on 27 Jan 2020 23:13
Re: [bug#34364] Add package: Emacs-shroud; Emacs interface for shroud
87eevksg2t.fsf@devup.no
This was pushed in a38525789cdb6b4baa440cdf9f265085d4378ec5.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl4vYJoACgkQoqBt8qM6
VPoRGAf/WDdn5QnrOFFc446BefE20OVxZfL9ATp4UAPfJA72PuKII3CDvh5ITHQi
wIYqr4etoMzr/ee/OlC5LK2dBZz/oozyMLpASUbiY8ry725+fejhvGZsrPKmz5D0
XQGtKhxvNxa+6Z5zrRDnp7T43nlyyw/9Rt4+J6WnkNsGD19gYN/7quE73IEFKvvW
L34TK08y/KiN3SME0WscueGytBk0tTJD6WNjpdo8bTBNKTFKDuO9KybLn/N1MhGL
MtnVIhKr/BkepEYryVILxwb9iXZb/riqjOEd+tmOFy/MJq1cr8lsvI1sToAKFSpT
FXnfCRjXJUD8M+kGCSEruxybET9ZUw==
=Cf0t
-----END PGP SIGNATURE-----

Closed
?