[PATCH] gnu: Add emacs-shroud

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Amar Singh
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Amar Singh
Severity
normal
A
A
Amar Singh wrote on 20 Feb 2019 21:41
(address . bug-guix@gnu.org)
87o976p4z3.fsf@disroot.org
Shroud is a password manager written in Guile which uses GnuPG in the
backend. This package is an Emacs interface to Shroud using the Buffers
User Interface library.

Beta quality.

Thanks

--------------------------------------------------------------------------------
Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cedc1efbc..a498c8012 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2233,6 +2233,31 @@ IRC bouncer with ERC.")
Emacs shell script.")
(license license:expat)))
+(define-public nly/emacs-shroud
+ (package
+ (name "emacs-shroud")
+ (version "ad5de6d")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/o-nly/emacs-shroud")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bw7lwssv7my41d8qw9dzzl8k6jwq01ks01dxkkpr6j82bcwlqrd"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)
+ ("emacs-bui" ,emacs-bui)
+ ("shroud" ,shroud)))
+ (home-page "http://nly.info.tm:9001/emacs/shroud.el")
+ (synopsis "Shroud (gpg) support for Emacs")
+ (description
+ "This package provides functions for working with shroud password manager.")
+ (license license:gpl3+)))
+
(define-public emacs-undercover
(package
(name "emacs-undercover")
R
R
Ricardo Wurmus wrote on 20 Feb 2019 22:36
(name . Amar Singh)(address . nly@disroot.org)
874l8y5ehq.fsf@elephly.net
Hi,

Toggle quote (4 lines)
> Shroud is a password manager written in Guile which uses GnuPG in the
> backend. This package is an Emacs interface to Shroud using the Buffers
> User Interface library.

You have previously already submitted a variant of this:


Please don’t open more tickets for this but instead send updates to the
same ticket. I’m closing this issue, because what you attached is not a
git formatted patch.

Toggle quote (2 lines)
> +(define-public nly/emacs-shroud

We don’t use personal prefixes like “nly/” in Guix.

Toggle quote (4 lines)
> + (package
> + (name "emacs-shroud")
> + (version "ad5de6d")

A version string must be monotonically increasing over time. Commit
hashes don’t do that, so we use (git-version last-release revision
commit) instead.

We prefer releases over arbitrary commits. Since you are the developer,
could you please tell us what the difference is between this version and
the previous release? Could you make a new release instead?

Toggle quote (9 lines)
> + (build-system emacs-build-system)
> + (propagated-inputs
> + `(("emacs-f" ,emacs-f)
> + ("emacs-s" ,emacs-s)
> + ("emacs-bui" ,emacs-bui)
> + ("shroud" ,shroud)))
> + (home-page "http://nly.info.tm:9001/emacs/shroud.el")
> + (synopsis "Shroud (gpg) support for Emacs")

Why “(gpg)”? It’s probably better to say “Shroud password manager
interface for Emacs”.

Toggle quote (4 lines)
> + (description
> + "This package provides functions for working with shroud password
> manager.")

I’d not say “functions”. How about

This package provides an Emacs minor mode for working with the Shroud
password manager.

Could you please send an updated patch?

--
Ricardo
Closed
R
R
Ricardo Wurmus wrote on 20 Feb 2019 22:44
(address . control@debbugs.gnu.org)
871s425e4z.fsf@elephly.net
reassign 34595 guix-patches
merge 34595 34364
thanks

--
Ricardo
B
B
Brett Gilio wrote on 20 Feb 2019 22:44
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87ftsi2kzj.fsf@posteo.net
Ricardo Wurmus writes:

Toggle quote (9 lines)
>
> A version string must be monotonically increasing over time. Commit
> hashes don’t do that, so we use (git-version last-release revision
> commit) instead.
>
> We prefer releases over arbitrary commits. Since you are the developer,
> could you please tell us what the difference is between this version and
> the previous release? Could you make a new release instead?

To the OP, there are several packages that use this form. You can look
at some and pretty much directly copy their content and fill in your
relevant information.
Closed
?