[PATCH 1/1] gnu: tryton: Add tryton 5.0.6.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Jovany Leandro G.C
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jovany Leandro G.C
Severity
normal
J
J
Jovany Leandro G.C wrote on 23 Feb 2019 20:09
(address . guix-patches@gnu.org)
20190223140939.54371269@riseup.net
From 693d00d1df68ada3bb43cbaecdd2823976e87bd4 Mon Sep 17 00:00:00 2001
From: "Jovany Leandro G.C" <bit4bit@riseup.net>
Date: Sat, 23 Feb 2019 14:08:01 -0500
Subject: [PATCH 1/1] gnu: tryton: Add tryton 5.0.6.

* gnu/packages/tryton.scm (tryton-5): New variable.
---
gnu/packages/tryton.scm | 42 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 31a2d481e..871537745 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
+;;; Copyright © 2019 Jovany Leandro G.C <bit4bit@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -96,6 +97,47 @@ and security.")
(description "This package is the client component of Tryton.")
(license license:gpl3+)))
+(define-public tryton-5
+ (package
+ (name "tryton")
+ (version "5.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tryton" version))
+ (sha256
+ (base32
+ "1lgkyyin5ydfl7qz692cvgswwyhnbc51r9krfz5k9rhq06ayaq4v"))))
+ (build-system python-build-system)
+ (arguments
+ `(;;_XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix
will not be created.
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+ (wrap-program (string-append out "/bin/tryton")
+ `("GI_TYPELIB_PATH" ":" prefix (, gi-typelib-path))))
+ #t))
+ (add-after 'unpack 'set-home-directory
+ ;; [Errno 13] Permission denied: '/homeless-shelter'
+ (lambda _ (setenv "HOME" "/tmp")
+ #t))
+ )))
+ (native-inputs
+ `(("gtk+" ,gtk+)
+ ("librsvg" ,librsvg)))
+ (inputs
+ `(("python-pycairo" ,python-pycairo)
+ ("python-pygobject" ,python-pygobject)
+ ("python-dateutil" ,python-dateutil)))
+ (home-page "http://www.tryton.org/")
+ (synopsis "Client component of Tryton 5")
+ (description "This package is the client component of Tryton 5.")
+ (license license:gpl3)))
+
(define-public python-trytond-country
(package
(name "python-trytond-country")
--
2.19.0
L
L
Ludovic Courtès wrote on 11 Mar 2019 23:15
(name . Jovany Leandro G.C)(address . bit4bit@riseup.net)(address . 34634@debbugs.gnu.org)
87r2bdrras.fsf@gnu.org
Hi Jovany,

Your email client mangled the patch. In the future could you send
patches as attachments or use ‘git send-email’?

"Jovany Leandro G.C" <bit4bit@riseup.net> skribis:

Toggle quote (7 lines)
> From 693d00d1df68ada3bb43cbaecdd2823976e87bd4 Mon Sep 17 00:00:00 2001
> From: "Jovany Leandro G.C" <bit4bit@riseup.net>
> Date: Sat, 23 Feb 2019 14:08:01 -0500
> Subject: [PATCH 1/1] gnu: tryton: Add tryton 5.0.6.
>
> * gnu/packages/tryton.scm (tryton-5): New variable.

Do you think we should keep both version 4 and version 5? Is it
generally useful today to have these two versions available?

Toggle quote (5 lines)
> +(define-public tryton-5
> + (package
> + (name "tryton")
> + (version "5.0.6")

Should it inherit from ‘tryton’?

Toggle quote (5 lines)
> + (arguments
> + `(;;_XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix
> will not be created.
> + #:tests? #f

Could you try adding a phase before ‘check’ that spawns Xvfb? There are
several examples of this.

Toggle quote (2 lines)
> + (license license:gpl3)))

Version 3 only, or version 3 “or any later version”?

Could you send an updated patch?

Thank you,
Ludo’.
J
J
Jovany Leandro G.C wrote on 12 Mar 2019 22:58
(name . Ludovic Courtès)(address . ludo@gnu.org)
20190312165842.1dc6b8cf@riseup.net
El Mon, 11 Mar 2019 23:15:39 +0100
Ludovic Courtès <ludo@gnu.org> escribió:
Toggle quote (4 lines)
> Hi Jovany,
>
> Your email client mangled the patch. In the future could you send
> patches as attachments or use ‘git send-email’?
ok sorry, i will be more alert with this
Toggle quote (13 lines)
>
> "Jovany Leandro G.C" <bit4bit@riseup.net> skribis:
>
> > From 693d00d1df68ada3bb43cbaecdd2823976e87bd4 Mon Sep 17 00:00:00
> > 2001 From: "Jovany Leandro G.C" <bit4bit@riseup.net>
> > Date: Sat, 23 Feb 2019 14:08:01 -0500
> > Subject: [PATCH 1/1] gnu: tryton: Add tryton 5.0.6.
> >
> > * gnu/packages/tryton.scm (tryton-5): New variable.
>
> Do you think we should keep both version 4 and version 5? Is it
> generally useful today to have these two versions available?
>
yeah it's very useful, tryton 4 and 5 both have updates, now 5 will be
LTS
Toggle quote (6 lines)
> > +(define-public tryton-5
> > + (package
> > + (name "tryton")
> > + (version "5.0.6")
>
> Should it inherit from ‘tryton’?
what it's the best path for this?
a guide please
Toggle quote (6 lines)
> > + (arguments
> > + `(;;_XSERVTransmkdir: ERROR: euid !=
> > 0,directory /tmp/.X11-unix will not be created.
> > + #:tests? #f
>
> Could you try adding a phase before ‘check’ that spawns Xvfb? There
ok, i try before send the patch, and not work but will try again
Toggle quote (6 lines)
> are several examples of this.
>
> > + (license license:gpl3)))
>
> Version 3 only, or version 3 “or any later version”?
>
Toggle quote (5 lines)
> Could you send an updated patch?
>
> Thank you,
> Ludo’.

yeah i will work on it.


thanks for you time and work
L
L
Ludovic Courtès wrote on 13 Mar 2019 11:31
(name . Jovany Leandro G.C)(address . bit4bit@riseup.net)(address . 34634@debbugs.gnu.org)
875zsn9ibs.fsf@gnu.org
Hello Jovany,

"Jovany Leandro G.C" <bit4bit@riseup.net> skribis:

Toggle quote (3 lines)
> El Mon, 11 Mar 2019 23:15:39 +0100
> Ludovic Courtès <ludo@gnu.org> escribió:

[...]

Toggle quote (15 lines)
>> "Jovany Leandro G.C" <bit4bit@riseup.net> skribis:
>>
>> > From 693d00d1df68ada3bb43cbaecdd2823976e87bd4 Mon Sep 17 00:00:00
>> > 2001 From: "Jovany Leandro G.C" <bit4bit@riseup.net>
>> > Date: Sat, 23 Feb 2019 14:08:01 -0500
>> > Subject: [PATCH 1/1] gnu: tryton: Add tryton 5.0.6.
>> >
>> > * gnu/packages/tryton.scm (tryton-5): New variable.
>>
>> Do you think we should keep both version 4 and version 5? Is it
>> generally useful today to have these two versions available?
>>
> yeah it's very useful, tryton 4 and 5 both have updates, now 5 will be
> LTS

OK, sounds good.

Toggle quote (9 lines)
>> > +(define-public tryton-5
>> > + (package
>> > + (name "tryton")
>> > + (version "5.0.6")
>>
>> Should it inherit from ‘tryton’?
> what it's the best path for this?
> a guide please

You would write something like:

(define-public tryton-5
(package
(inherit tryton)
(version "5.0.6")
;; …
))

and you only need to specify fields that differ from those of ‘tryton’.
See for example ‘guile-2.0.13’ in (gnu packages guile).

Toggle quote (7 lines)
>> > + (license license:gpl3)))
>>
>> Version 3 only, or version 3 “or any later version”?
>>
> http://hg.tryton.org/tryton/file/5.0/LICENSE
> yeah GPL-3+

Right, and specifically there are no source file headers that say
“version 3 only”, so ‘gpl3+’ indeed!

Thanks,
Ludo’.

PS: Please keep 34634@debbugs.gnu.org Cc’d.
A
A
Andreas Enge wrote on 5 Sep 2020 22:52
Closing
(address . 34634-done@debbugs.gnu.org)
20200905205211.GA24889@jurong
We have tryton-5.6.0 now, so the problem is solved. Closing.

Andreas
Closed
?