[PATCH] gnu: Add emacs-xterm-color

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Frederickson
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jonathan Frederickson
Severity
normal
J
J
Jonathan Frederickson wrote on 2 Jun 2019 04:59
(address . guix-patches@gnu.org)(name . Jonathan Frederickson)(address . jonathan@terracrypt.net)
20190602025956.1666-1-jonathan@terracrypt.net
* gnu/packages/emacs-xyz.scm: (emacs-xterm-color) new variable.
---
gnu/packages/emacs-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9199b45e40..70dd9e599b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15620,3 +15620,21 @@ verb commands which would are normally destructive (such as deletion) are
provided. Those alternative commands are and bound by default to their
corresponding Evil keys.")
(license license:expat))))
+
+(define-public emacs-xterm-color
+ (package
+ (name "emacs-xterm-color")
+ (version "20190519.1243")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://melpa.org/packages/xterm-color-"
+ version
+ ".el"))
+ (sha256
+ (base32 "0cdl8cpqv3x23y4vpfib4kjncy9xslvka04gpszdnasf7av5g8g7"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/atomontage/xterm-color")
+ (synopsis "ANSI & xterm-256 color text property translator for Emacs")
+ (description "@code{xterm-color.el} is an ANSI control sequence to text-property translator")
+ (license license:bsd-2)))
--
2.21.0
L
L
Ludovic Courtès wrote on 5 Jun 2019 17:27
(name . Jonathan Frederickson)(address . jonathan@terracrypt.net)(address . 36050@debbugs.gnu.org)
87r288yrw9.fsf@gnu.org
Hi Jonathan,

Jonathan Frederickson <jonathan@terracrypt.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm: (emacs-xterm-color) new variable.

[...]

Toggle quote (5 lines)
> + (uri (string-append
> + "https://melpa.org/packages/xterm-color-"
> + version
> + ".el"))

melpa.org URLs are not stable: files get modified in place. For that
reason, we usually refer directly to upstream VCS repositories.

Could you modify the patch accordingly?

Toggle quote (3 lines)
> + (synopsis "ANSI & xterm-256 color text property translator for Emacs")
> + (description "@code{xterm-color.el} is an ANSI control sequence to text-property translator")

Please add a period at the end of the sentence. :-)

Thank you,
Ludo’.
J
J
Jonathan Frederickson wrote on 7 Jun 2019 05:40
[PATCH] gnu: Add emacs-xterm-color
(address . 36050@debbugs.gnu.org)
20190607034000.21850-1-jonathan@terracrypt.net
* gnu/packages/emacs-xyz.scm: (emacs-xterm-color) new variable.
---
gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9199b45e40..3224883969 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15620,4 +15620,23 @@ verb commands which would are normally destructive (such as deletion) are
provided. Those alternative commands are and bound by default to their
corresponding Evil keys.")
(license license:expat))))
+
+(define-public emacs-xterm-color
+ (let ((commit "a452ab38a7cfae97078062ff8885b5d74fd1e5a6")
+ (version "1.8")
+ (revision "1"))
+ (package
+ (name "emacs-xterm-color")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atomontage/xterm-color.git")
+ (commit commit)))
+ (sha256
+ (base32 "02kpajb993yshhjhsizpfcbrcndyzkf4dqfipifhxxng50dhp95i"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/atomontage/xterm-color")
+ (synopsis "ANSI & xterm-256 color text property translator for Emacs")
+ (description "@code{xterm-color.el} is an ANSI control sequence to text-property translator.")
+ (license license:bsd-2))))
--

Here's a revised version - I saw there were a few different
conventions for packages with git sources, but I figured using both a
numeric version for the version I intended and a git hash for
stability would be desirable.
L
L
Ludovic Courtès wrote on 7 Jun 2019 09:30
(name . Jonathan Frederickson)(address . jonathan@terracrypt.net)(address . 36050-done@debbugs.gnu.org)
875zphkg2m.fsf@gnu.org
Hi,

Jonathan Frederickson <jonathan@terracrypt.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm: (emacs-xterm-color) new variable.

Applied, thanks!

I followed up with a commit to address ‘guix lint’ warnings.

Ludo’.
Closed
?