[PATCH] gnu: emacs-perspective: Update to 2.2

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Joseph LaFreniere
  • Ricardo Wurmus
  • swedebugia
Owner
unassigned
Submitted by
Joseph LaFreniere
Severity
normal
J
J
Joseph LaFreniere wrote on 9 Jun 2019 04:16
(address . guix-patches@gnu.org)
87ftoijzh6.fsf@odyssey.lafreniere.xyz
* gnu/packages/emacs-xyz.scm (emacs-perspective): Update to 2.2
---
gnu/packages/emacs-xyz.scm | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/emacs-xyz.scm
b/gnu/packages/emacs-xyz.scm
index 7db46e81c5..7986203155 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4213,16 +4213,17 @@ regexp that matches all known keywords.")
(define-public emacs-perspective
(package
(name "emacs-perspective")
- (version "1.12")
+ (version "2.2")
(source
(origin
- (method url-fetch)
- (uri (string-append
"https://github.com/nex3/perspective-el/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nex3/perspective-el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
-
"078ahh0kmhdylq5ib9c81c76kz1n02xwc83pm729d00i84ibviic"))))
+
"0pd5sqrrz6y3md20yh6ffy32jdcgb1gc9b4j14pm6r54bqxik68h"))))
(build-system emacs-build-system)
(home-page "https://github.com/nex3/perspective-el")
(synopsis "Switch between named \"perspectives\"")
--
2.21.0
E
E
Efraim Flashner wrote on 13 Jun 2019 09:49
(name . LaFreniere, Joseph)(address . joseph@lafreniere.xyz)
20190613074916.GB1145@macbook41
Patch pushed with some changes to the commit message.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl0B//wACgkQQarn3Mo9
g1FhSRAAj+H0kQN6DDHvvFWzGL829klxzO6SUW1XSCZsB8xBrh5Z1CdZdl5pY4aJ
HkYaBmLnkGyZ8ogRkLIqAAPejsjapNLT5whdTxms/j+qiMKupf9W3+LdO/gEDQ9O
j1U6vnrPupJoxFYQ2JEe7Ticw27XOxSximTsp4ygUgGj32yEj98fvVASLDcwdCzG
RwOEFRQ5BlSrC470ondwi/g6Miy8+bUVIt8r50W+2OwIc8pXoryW/gIWtj6bGT0W
bXYXS7jsATwd5fJ6KDU68WlAlOwJe6YLPCuv4lhshFLauwn+fuWG4bCh9CpOXtit
HiB2bJ76yoYlbf+S5ImMy89aZNgyMyqr2Pt2Fciv1ZA9kki9Rr734zfr1ImJCzIU
g+G/11flVK6nd02quwMOUOJf1OTmYWhvuZpaaLeQXBQl252WfVB9NM/j6GM3doXG
jTGxOkGFacA6k78C3S3LywY8jAvIfB0/dcVO/BUAnowK+m6O4ldDNOlc4PL5SkRu
bf8NmXFKdpCaLgiqIZ/rvyT0KEq0o0CmIlEhTYiTizzqIkdaiGGjbuSUt1J5feuI
mmMn95jrotx4vHT7y70dwUBJQPqCv7xhkPpm1bDJ5AAXWheKHX3kBG6dj5N2MyL/
SYdxuHolnZa1/HcP2CmXoIUJwtsG25npcLSOM/HsM2DHNr+lMtU=
=Dytf
-----END PGP SIGNATURE-----


Closed
S
S
swedebugia wrote on 28 Jun 2019 07:46
Re: [bug#36152] [PATCH] gnu: emacs-perspective: Update to 2.2
(address . guix-patches@gnu.org)
bee37512-8b3b-c093-ff2e-f13411c3beba@riseup.net
On 2019-06-09 04:16, Joseph LaFreniere wrote:
Toggle quote (42 lines)
>
> * gnu/packages/emacs-xyz.scm (emacs-perspective): Update to 2.2
> ---
> gnu/packages/emacs-xyz.scm | 13 +++++++------
> 1 file changed, 7 insertions(+), 6 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 7db46e81c5..7986203155 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -4213,16 +4213,17 @@ regexp that matches all known keywords.")
> (define-public emacs-perspective
>   (package
>     (name "emacs-perspective")
> -    (version "1.12")
> +    (version "2.2")
>     (source
>      (origin
> -       (method url-fetch)
> -       (uri (string-append
> "https://github.com/nex3/perspective-el/"
> -                           "archive/" version ".tar.gz"))
> -       (file-name (string-append name "-" version ".tar.gz"))
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/nex3/perspective-el.git")
> +             (commit version)))
> +       (file-name (git-file-name name version))
>        (sha256
>         (base32
> -          "078ahh0kmhdylq5ib9c81c76kz1n02xwc83pm729d00i84ibviic"))))
> + "0pd5sqrrz6y3md20yh6ffy32jdcgb1gc9b4j14pm6r54bqxik68h"))))
>     (build-system emacs-build-system)
>     (home-page "https://github.com/nex3/perspective-el")
>     (synopsis "Switch between named \"perspectives\"")
> --
> 2.21.0
>
>
>
>

for the record. has been applied

--
Cheers Swedebugia
R
R
Ricardo Wurmus wrote on 28 Jun 2019 15:20
(address . swedebugia@riseup.net)(address . 36152-done@debbugs.gnu.org)
87ftntx2w2.fsf@elephly.net
swedebugia <swedebugia@riseup.net> writes:

Toggle quote (6 lines)
> On 2019-06-09 04:16, Joseph LaFreniere wrote:
>>
>> * gnu/packages/emacs-xyz.scm (emacs-perspective): Update to 2.2
>
> for the record. has been applied

Indeed. Thanks. I’m closing this issue.

--
Ricardo
Closed
?