[PATCH] gnu: Add emacs-org-noter

  • Done
  • quality assurance status badge
Details
2 participants
  • Dimakakos Dimos
  • Ludovic Courtès
Owner
unassigned
Submitted by
Dimakakos Dimos
Severity
normal
D
D
Dimakakos Dimos wrote on 12 Jun 2019 15:26
(address . guix-patches@gnu.org)(name . Dimakakos Dimos)(address . bendersteed@teknik.io)
20190612132604.4880-1-bendersteed@teknik.io
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ca1eb586df..e7ae46cecc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15863,3 +15863,31 @@ corresponding Evil keys.")
(description "@code{xterm-color.el} is an ANSI control sequence to
text-property translator.")
(license license:bsd-2))))
+
+(define-public emacs-org-noter
+ (package
+ (name "emacs-org-noter")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://stable.melpa.org/packages/org-noter-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "1hczwva73gsyanl1ldhdvql01gy0hy2g861yzkaklyb763sx58x4"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-org" ,emacs-org)))
+ (home-page
+ "https://github.com/weirdNox/org-noter")
+ (synopsis
+ "Synchronized, Org-mode, document annotator")
+ (description
+ "The idea is to let you create notes that are kept in sync when you
+scroll through the document, but that are external to it - the notes
+themselves live in an Org-mode file. As such, this leverages the power of
+Org-mode (the notes may have outlines, latex fragments, babel, etc...) while
+acting like notes that are made /in/ the document.")
+ (license license:gpl3+)))
--
2.22.0
L
L
Ludovic Courtès wrote on 13 Jun 2019 23:26
(name . Dimakakos Dimos)(address . bendersteed@teknik.io)(address . 36181-done@debbugs.gnu.org)
87v9x9yy5x.fsf@gnu.org
Hello Dimakakos,

Dimakakos Dimos <bendersteed@teknik.io> skribis:

Toggle quote (4 lines)
> ---
> gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
> 1 file changed, 28 insertions(+)

Applied with the minor changes below and with a commit log following our
conventions.

Thank you!

Ludo’.
Toggle diff (24 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a8eb141452..d341501cc0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16005,14 +16005,12 @@ text-property translator.")
"1hczwva73gsyanl1ldhdvql01gy0hy2g861yzkaklyb763sx58x4"))))
(build-system emacs-build-system)
(propagated-inputs `(("emacs-org" ,emacs-org)))
- (home-page
- "https://github.com/weirdNox/org-noter")
- (synopsis
- "Synchronized, Org-mode, document annotator")
+ (home-page "https://github.com/weirdNox/org-noter")
+ (synopsis "Synchronized, Org-mode, document annotator")
(description
- "The idea is to let you create notes that are kept in sync when you
-scroll through the document, but that are external to it - the notes
+ "This package lets you create notes that are kept in sync when you
+scroll through the document, but that are external to it---the notes
themselves live in an Org-mode file. As such, this leverages the power of
Org-mode (the notes may have outlines, latex fragments, babel, etc...) while
-acting like notes that are made /in/ the document.")
+acting like notes that are made @emph{in} the document.")
(license license:gpl3+)))
Closed
?