[PATCH] gnu: ungoogled-chromium: Install icons.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex Griffin
  • Marius Bakke
Owner
unassigned
Submitted by
Alex Griffin
Severity
normal
A
A
Alex Griffin wrote on 19 Jun 2019 06:43
(address . guix-patches@gnu.org)
ca06e026-57b8-48b0-8eef-1e84f5ed91f6@www.fastmail.com
This patch installs the application icons in the ungoogled-chromium package.
--
Alex Griffin
From 605782cf5da5faa668692ea31834dcfe324a357e Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Tue, 18 Jun 2019 14:55:30 -0500
Subject: [PATCH] gnu: ungoogled-chromium: Install icons.

* gnu/packages/chromium.scm (ungoogled-chromium)[arguments]: Install icons.
---
gnu/packages/chromium.scm | 21 +++++++++++++--------
1 file changed, 13 insertions(+), 8 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 2127e402d7..3a242220f6 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -650,12 +651,6 @@ from forcing GEXP-PROMISE."
(scandir "." (cut regexp-exec install-regexp <>)))
(copy-file "chrome" (string-append lib "/chromium"))
- ;; TODO: Install icons from "../../chrome/app/themes" into
- ;; "out/share/icons/hicolor/$size".
- (install-file
- "product_logo_48.png"
- (string-append out "/share/icons/48x48/chromium.png"))
-
(copy-recursively "locales" locales)
(copy-recursively "resources" resources)
@@ -669,8 +664,18 @@ from forcing GEXP-PROMISE."
(,(string-append lib ":" nss "/lib/nss:" mesa "/lib:"
udev "/lib")))
;; Avoid file manager crash. See <https://bugs.gnu.org/26593>.
- `("XDG_DATA_DIRS" ":" prefix (,(string-append gtk+ "/share"))))
- #t)))))))
+ `("XDG_DATA_DIRS" ":" prefix (,(string-append gtk+ "/share")))))
+
+ (with-directory-excursion "chrome/app/theme/chromium"
+ (for-each
+ (lambda (size)
+ (let ((icons (string-append out "/share/icons/hicolor/"
+ size "x" size "/apps")))
+ (mkdir-p icons)
+ (copy-file (string-append "product_logo_" size ".png")
+ (string-append icons "/chromium.png"))))
+ '("22" "24" "48" "64" "128" "256")))
+ #t))))))
(native-inputs
`(("bison" ,bison)
("gcc" ,gcc-8)
--
2.22.0
M
M
Marius Bakke wrote on 20 Jun 2019 23:05
87a7ec2cio.fsf@devup.no
"Alex Griffin" <a@ajgrf.com> writes:

Toggle quote (2 lines)
> This patch installs the application icons in the ungoogled-chromium package.

Pushed in 3df7b15e6c9a11cedba1451f0459c715b8ce3ca1, thank you!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl0L9R8ACgkQoqBt8qM6
VPrAjAgAjCr8AxJg3bkCoJVyp57mqdUIr/aEZjdiivWQ0cZpa1wHpXjfAilZizXS
yh06Rd1rm4vcDHORfL98DZ5QDyE7kJIuDedKQ5I/hm5qvrZC48Q2ChBXh8yp0s14
+UmApOveniD/2KPiMejn8OMDWB1f6niIJ8kmH8FVg4YrQ8TW2JiIweyinkcglN2y
kodppYYaiZo/FU/tf/z71Sf/ZngaYH0xqmWiM/lu7yw5yntPAOjcY+hUTLkGIARd
t3HOukbMn0ECdOUxh+O1K0Xl3C9yrKIcsCxDpUZCg+6von0i/Y3SoB9HgpITUZgM
gQg0xUrEQmKxaMOwT2VIbuKS8KkBtw==
=i8kt
-----END PGP SIGNATURE-----

Closed
?