[PATCH] Add grisbi

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Timothy Sample
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 30 Jun 2019 13:54
(address . guix-patches@gnu.org)
20190630115445.e4td6p7upcsrk6hg@melmoth
---
gnu/packages/finance.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (74 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index e1a1e8ab6f..d3e12c2618 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -11,6 +11,7 @@
;;; Copyright � 2018 Adriano Peluso <catonano@gmail.com>
;;; Copyright � 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright � 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright � 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
@@ -45,9 +47,12 @@
#:use-module (gnu packages dns)
#:use-module (gnu packages emacs)
#:use-module (gnu packages dbm)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages groff)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages libedit)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libunwind)
@@ -1028,3 +1033,38 @@ Its features are:
@item get account amount.
@end itemize")
(license license:agpl3+)))
+
+(define-public grisbi
+ (package
+ (name "grisbi")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/grisbi/grisbi%20stable/1.2.x"
+ "/" version "/grisbi-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1piiyyxjsjbw9gcqydvknzxmmfgh8kdqal12ywrxyxih2afwnvbw"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:configure-flags (list "--without-ofx")))
+ (propagated-inputs
+ `(("dconf" ,dconf)))
+ (native-inputs
+ `(("glib" ,glib "bin") ; glib-compile-schemas
+ ("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("libgsf" ,libgsf)))
+ (synopsis "Personnal accounting application")
+ (description "Grisbi is an application written by French developers,
+so it perfectly respects French accounting rules. Grisbi can manage
+multiple accounts, currencies and users. It manages third party,
+expenditure and receipt categories, budgetary lines, financial years,
+budget estimates, bankcard management and other information that make Grisbi
+adapted for associations.")
+ (home-page "http://grisbi.org")
+ (license license:gpl2+)))
--
2.21.0
E
E
Efraim Flashner wrote on 2 Jul 2019 11:33
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 36446@debbugs.gnu.org)
20190702093317.GD22794@macbook41
I haven't checked the package, but one thing stood out to me:

On Sun, Jun 30, 2019 at 01:54:45PM +0200, Tanguy Le Carrour wrote:
Toggle quote (8 lines)
> ---
> + (version "1.2.2")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "mirror://sourceforge/grisbi/grisbi%20stable/1.2.x"

1.2.x could instead be:
(verion-major+minor version) ".x"

Toggle quote (4 lines)
> + "/" version "/grisbi-" version ".tar.bz2"))
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl0bJNkACgkQQarn3Mo9
g1E3uA//b+XCzknLTOaUUc5R6nmLollVMSi9aqGENIdJ2gAhMlZsMXifkOdUYgPc
TnbwtN0MEnySYQP2iShmEAh9zTSxReMm6kHuO+S7Mjm/tG1KWlyurukkJxQVyCvS
6AaAeqW4MdIkNRmHC15lpf6a0pqTxzLmncCfTNjFykcBIuoPnnmOwLbvbM2VNkn3
bOONjDPAcfpxv7xyu3hwHaAlWw73rVCNJzRAgH9xlGE688xK0AUtta4bA86YhUky
qFmlMg1QdK9qkl++B8Fgbd5XMNznACE85dNCUQ3F0y+nqB8UgM8cnNEjZM3BKvle
vG4Kg21dDG6DOA1n6PmK5maQUmH2AUAmD882smAMZ9w5JJd35EsRAjDBqnG95XhK
mJkfvpC1AEqNqpyvzhOwJrxRkIKV+TqCj7ay7Y+raHyua5FOYczt+t/qfdhXdwxp
N3fE3yYqrQmLcZ59uABJe5loEDy2RX8em9PbDygSUr3R7ghO9JxErUMK1HqNV4k+
VHDi9h4S5UbaF1YMEsHZttXQbGAAhaO3FrGasJwoketRLUlWEk5ZKcKMtKr9EsYL
IuLSnia5iEHzN6uQ32MFAZyQMZ4C5+gQldY8/BiKx6AgckPJctAE/GwPftl3F4Og
LCbI9ts9UZXKNRGiNVQDIswIsOftq++I8a77Dw7zbYvw8ILjFTA=
=QvLX
-----END PGP SIGNATURE-----


T
T
Tanguy Le Carrour wrote on 3 Jul 2019 09:00
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 36446@debbugs.gnu.org)
20190703070011.6oywboheryvbsnua@rafflesia.localdomain
Le 07/02, Efraim Flashner a �crit :
Toggle quote (14 lines)
> I haven't checked the package, but one thing stood out to me:
>
> On Sun, Jun 30, 2019 at 01:54:45PM +0200, Tanguy Le Carrour wrote:
> > ---
> > + (version "1.2.2")
> > + (source
> > + (origin
> > + (method url-fetch)
> > + (uri (string-append
> > + "mirror://sourceforge/grisbi/grisbi%20stable/1.2.x"
>
> 1.2.x could instead be:
> (verion-major+minor version) ".x"

Thanks for the tip! I didn't know about this one, but it makes perfect
sense!
Am I supposed to update my patch and re-submit it? (sorry, newbie! ^_^')

--
Tanguy
T
T
Tanguy Le Carrour wrote on 7 Jul 2019 17:40
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 36446@debbugs.gnu.org)
20190707154044.bstjb7fwu4nez2hu@melmoth
Thanks again for reading it. Here is the updated (and rebased) version.

---
gnu/packages/finance.scm | 41 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 550354b650..c0a56f5180 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -12,6 +12,7 @@
;;; Copyright � 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright � 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright � 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright � 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
+ #:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
@@ -47,9 +49,12 @@
#:use-module (gnu packages dns)
#:use-module (gnu packages emacs)
#:use-module (gnu packages dbm)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages groff)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages libedit)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libunwind)
@@ -1050,3 +1055,39 @@ Its features are:
@item get account amount.
@end itemize")
(license license:agpl3+)))
+
+(define-public grisbi
+ (package
+ (name "grisbi")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/grisbi/grisbi%20stable"
+ "/" (version-major+minor version) ".x"
+ "/" version "/grisbi-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1piiyyxjsjbw9gcqydvknzxmmfgh8kdqal12ywrxyxih2afwnvbw"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:configure-flags (list "--without-ofx")))
+ (propagated-inputs
+ `(("dconf" ,dconf)))
+ (native-inputs
+ `(("glib" ,glib "bin") ; glib-compile-schemas
+ ("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("libgsf" ,libgsf)))
+ (synopsis "Personnal accounting application")
+ (description "Grisbi is an application written by French developers,
+so it perfectly respects French accounting rules. Grisbi can manage
+multiple accounts, currencies and users. It manages third party,
+expenditure and receipt categories, budgetary lines, financial years,
+budget estimates, bankcard management and other information that make Grisbi
+adapted for associations.")
+ (home-page "http://grisbi.org")
+ (license license:gpl2+)))
--
2.22.0


--
Tanguy
T
T
Timothy Sample wrote on 12 Jul 2019 18:26
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
87tvbrp6b6.fsf@ngyro.com
Hi Tanguy,

Tanguy Le Carrour <tanguy@bioneland.org> writes:

Toggle quote (2 lines)
> Thanks again for reading it. Here is the updated (and rebased) version.

With the minor changes to the synopsis and description that I mentioned
before, I pushed this as 90bb244f29cacba8a098c07cd7c19a77d16f6cfb.

Thanks!

(As a note for the future, please be sure your patches apply. I had to
fix the boundaries on one of the hunks.)


-- Tim
Closed
T
T
Tanguy Le Carrour wrote on 15 Jul 2019 08:55
(name . Timothy Sample)(address . samplet@ngyro.com)
20190715065537.o6h2kog3lbujmy4m@rafflesia.localdomain
Hi Timothy,

Le 07/12, Timothy Sample a �crit :
Toggle quote (4 lines)
> Tanguy Le Carrour <tanguy@bioneland.org> writes:
> With the minor changes to the synopsis and description that I mentioned
> before, I pushed this as 90bb244f29cacba8a098c07cd7c19a77d16f6cfb.

Thank you so much for that!

Toggle quote (3 lines)
> (As a note for the future, please be sure your patches apply. I had to
> fix the boundaries on one of the hunks.)

I'm really sorry to hear that! I'll do my best next time not to give you
extra work!

Best regards!

--
Tanguy
Closed
?