[PATCH] gnu: services: nginx: Pass run-directory on config test

  • Done
  • quality assurance status badge
Details
3 participants
  • Jonathan Brielmaier
  • Ludovic Courtès
  • Robert Vollmert
Owner
unassigned
Submitted by
Robert Vollmert
Severity
normal
R
R
Robert Vollmert wrote on 30 Jun 2019 22:56
(address . guix-patches@gnu.org)(name . Robert Vollmert)(address . rob@vllmrt.net)
20190630205625.54814-1-rob@vllmrt.net
This fixes error logging errors in the activation script.

* gnu/services/web.scm (nginx-activation): Add "-p" flag.
---
gnu/services/web.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/services/web.scm b/gnu/services/web.scm
index 35efddb0ae..56971238ab 100644
--- a/gnu/services/web.scm
+++ b/gnu/services/web.scm
@@ -682,7 +682,8 @@ of index files."
(system* (string-append #$nginx "/sbin/nginx")
"-c" #$(or file
(default-nginx-config config))
- "-t"))))
+ "-p" #$run-directory
+ "-t"))))
(define (nginx-shepherd-service config)
(match-record config
--
2.20.1 (Apple Git-117)
R
R
Robert Vollmert wrote on 30 Jun 2019 23:03
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 36450@debbugs.gnu.org)
288AB338-2451-4928-B925-7D101CD9BB0A@vllmrt.net
Toggle quote (7 lines)
> On 30. Jun 2019, at 23:02, Jonathan Brielmaier <jonathan.brielmaier@web.de> wrote:
>
> On 30.06.19 22:56, Robert Vollmert wrote:
>> This fixes error logging errors in the activation script.
>
> What does it fix? I don't get it.

J
J
Jonathan Brielmaier wrote on 30 Jun 2019 23:02
7cdcfe15-0831-5c93-8758-aea7abc92a79@web.de
On 30.06.19 22:56, Robert Vollmert wrote:
Toggle quote (2 lines)
> This fixes error logging errors in the activation script.

What does it fix? I don't get it.
L
L
Ludovic Courtès wrote on 4 Sep 2019 15:29
(name . Robert Vollmert)(address . rob@vllmrt.net)(address . 36450-done@debbugs.gnu.org)
87k1ao196r.fsf@gnu.org
Hi,

Robert Vollmert <rob@vllmrt.net> skribis:

Toggle quote (4 lines)
> This fixes error logging errors in the activation script.
>
> * gnu/services/web.scm (nginx-activation): Add "-p" flag.

Added a “Fixes” line in the log and committed, at last.

Thanks!

Ludo’.
Closed
?