[PATCH] gnu: Add anonip.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hartmut Goebel
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Hartmut Goebel
Severity
normal
H
H
Hartmut Goebel wrote on 2 Jul 2019 16:20
(address . guix-patches@gnu.org)
20190702142003.14302-1-h.goebel@crazy-compilers.com
* gnu/packages/web.scm (anonip): New variable.
---
gnu/packages/web.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 124cc93e68..386564206e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6498,3 +6499,34 @@ update an existing mirrored site, and resume interrupted downloads.
HTTrack is fully configurable, and has an integrated help system.")
(license license:gpl3+)))
+
+(define-public anonip
+ (package
+ (name "anonip")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "anonip" version))
+ (sha256
+ (base32
+ "0ckn9nnfhpdnz8b92q8pkysdqj6pdh71ckfqvfj0z01cq0hzbhd2"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-3" ,python-3)))
+ (home-page
+ "https://github.com/DigitaleGesellschaft/Anonip")
+ (synopsis
+ "Anonymize IP-addresses in log-files")
+ (description
+ "Anonip masks the last bits of IPv4 and IPv6 addresses in log-files.
+That way most of the relevant information is preserved, while the IP-address
+does not match a particular individuum anymore.
+
+Depending on your webserver software, the log entries may directly get piped
+to Anonip or read via a FIFO (named pipe). Thus the unmasked IP addresses
+will never be written to any file.
+
+It's also possible to rewrite existing log files.
+
+Anonip can also be uses as a Python module in your own Python application.")
+ (license license:bsd-3)))
--
2.13.7
T
T
Tobias Geerinckx-Rice wrote on 2 Jul 2019 16:59
(address . guix-patches@gnu.org)(address . 36476@debbugs.gnu.org)
877e9032jx.fsf@nckx
Hartmut,

Thanks! This should nicely replace some (probably buggy) ad-hoc
code of mine :-)

Hartmut Goebel wrote:
Toggle quote (40 lines)
> * gnu/packages/web.scm (anonip): New variable.
> ---
> gnu/packages/web.scm | 32 ++++++++++++++++++++++++++++++++
> 1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index 124cc93e68..386564206e 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -33,6 +33,7 @@
> ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
> ;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
> ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
> +;;; Copyright © 2019 Hartmut Goebel
> <h.goebel@crazy-compilers.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -6498,3 +6499,34 @@ update an existing mirrored site, and
> resume interrupted downloads.
>
> HTTrack is fully configurable, and has an integrated help
> system.")
> (license license:gpl3+)))
> +
> +(define-public anonip
> + (package
> + (name "anonip")
> + (version "1.0.0")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "anonip" version))
> + (sha256
> + (base32
> +
> "0ckn9nnfhpdnz8b92q8pkysdqj6pdh71ckfqvfj0z01cq0hzbhd2"))))
> + (build-system python-build-system)
> + (inputs
> + `(("python-3" ,python-3)))

I'm surprised: the python-build-system should take care of this.
Does the package fail without it? How?

Toggle quote (5 lines)
> + (home-page
> + "https://github.com/DigitaleGesellschaft/Anonip")
> + (synopsis
> + "Anonymize IP-addresses in log-files")

IP addresses; log files.

I'm not a fan of the way the Pypi importer needlessly indents
home-page and synopsis (both fit on one line just fine), but it's
up to you.

Toggle quote (4 lines)
> + (description
> + "Anonip masks the last bits of IPv4 and IPv6 addresses in
> log-files.

As above, so below: ‘log files’ &c.

Toggle quote (7 lines)
> +That way most of the relevant information is preserved, while
> the IP-address
> +does not match a particular individuum anymore.
> +
> +Depending on your webserver software, the log entries may
> directly get piped

Web server. I'd drop ‘software’ and say ‘piped directly’.

Toggle quote (3 lines)
> +to Anonip or read via a FIFO (named pipe). Thus the unmasked
> IP addresses

‘read from’.

Toggle quote (8 lines)
> +will never be written to any file.
> +
> +It's also possible to rewrite existing log files.
> +
> +Anonip can also be uses as a Python module in your own Python
> application.")
> + (license license:bsd-3)))

Otherwise LGTM!

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl0bcVIACgkQ2Imw8BjF
STyxoA/6AwPOn9d2F5Pivs+YemOEistYRLTq+sfhAELC8ZZs6YxRt8OShQcPw3du
P/kDFT+kSkI9mmP/9ehEhvSh5ZIDwVhW2I0BLOKXOZ8f0Ii82ih88NPorPA7IFbZ
I9BOqr2E8j3lw8Is7LSvjCYsI7QKpoQ8V10n6RG4koV3f0AwQrWjzj+/cOVPNWSk
/cjL3TnCSRiy8TvMGUmu6ypKjB2N9vY+ocDefp9v5ZIHTOj2mcuwjHyLp608hS4D
QaS3wr6H7O8SePYdTXS28yf7Ja+4W5WuxekySOtH51wXdLycxa2CW7CakwYAa7m8
I9AFT3oFeMvdqLLt6uAB+QSxUOABDu75dBnoDL8QcLZQnbwdMVQVkC7vt94lV1U4
miAKyHd+SesKnIflmQp7iLosUjAx9lJZGGOVsxSLuXRcsG22WAdq0ODv/aYE3AHU
p0b8B/Bj4FVR6VdxRhQJ/fSlomtwgBJp6TbbXn/lbRBmQ/pCF5FarFLWqWwKRcOg
SyLyMG8Z9B8gNddJCn0znZgcLoUBrWAPDWsZ0lqW2kzd/DnmaxyWCZC2iEKOc4+k
41WQk8EZ+q5JO1ugF/rlWfg/OI8zHL3kuIy6lGinOy1UEqhUgvaGTnYkWUKpVB9d
q/leGRODob1henENKYW1uVYw3Xly1nJVhJ4QesGPoBpvH5RPKMY=
=zIYa
-----END PGP SIGNATURE-----

H
H
Hartmut Goebel wrote on 9 Jul 2019 13:24
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 36476-close@debbugs.gnu.org)
2e57b964-9f99-36bb-5a98-083fceccb15c@crazy-compilers.com
Tobias,

Thanks for your review. Committed as
582de58c69bd46385196e26434951e1e2d5f32f2

Toggle quote (3 lines)
> Thanks!  This should nicely replace some (probably buggy) ad-hoc code
> of mine :-)

:-)

Toggle quote (6 lines)
> +    (inputs
>> +     `(("python-3" ,python-3)))
>
> I'm surprised: the python-build-system should take care of this. Does
> the package fail without it?  How?

You are right, this is not required. I copied this without questioning
from some other python application (don't remember which one).


Toggle quote (7 lines)
>> +Depending on your webserver software, the log entries may directly
>> get piped
>> +to Anonip or read via a FIFO (named pipe).  Thus the unmasked IP
>> addresses
>
> ‘read from’.

I rephrased this into "Depending on your Web server, the log entries may
be piped to Anonip directly
or via a FIFO (named pipe)."  This emphases on piping


--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
Attachment: signature.asc
?