texlive-union: Build missing font maps.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Pierre Neidhardt
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 5 Jul 2019 17:54
(address . guix-patches@gnu.org)(address . ludo@gnu.org)
87d0ioschd.fsf@elephly.net
Hi Guix,

this patch causes texlive-union to include pdftex.map, among other font
map files. This is achieved by running updmap in the builder.

This should fix a couple of problems.

Unfortunately, this doesn’t fix the same problem with the profile hook,
so I think this means that the profile hook should be using
texlive-union to avoid duplication.

What do you think?

--
Ricardo
From 11900d109a617d07e0085a25e747da76fcb12c2e Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Fri, 5 Jul 2019 17:48:45 +0200
Subject: [PATCH] gnu: texlive-union: Build font maps.

* gnu/packages/tex.scm (texlive-union)[arguments]: Execute updmap to generate
missing font maps.
[native-inputs]: Add coreutils, sed, and updmap.cfg.
---
gnu/packages/tex.scm | 38 ++++++++++++++++++++++++++++++++++----
1 file changed, 34 insertions(+), 4 deletions(-)

Toggle diff (77 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ec35315f22..85c72e006a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2387,16 +2387,18 @@ standard LaTeX packages."
#:builder
(begin
(use-modules (ice-9 match)
+ (ice-9 popen)
(srfi srfi-26)
(guix build union)
(guix build utils)
(guix build texlive-build-system))
(let* ((out (assoc-ref %outputs "out"))
(texmf.cnf (string-append out "/share/texmf-dist/web2c/texmf.cnf")))
- ;; Build a modifiable union of all inputs (but exclude bash)
+ ;; Build a modifiable union of all inputs (but exclude bash and
+ ;; the updmap.cfg file)
(match (filter (match-lambda
((name . _)
- (not (string=? "bash" name))))
+ (not (member name '("bash" "updmap.cfg")))))
%build-inputs)
(((names . directories) ...)
(union-build (assoc-ref %outputs "out")
@@ -2413,19 +2415,47 @@ standard LaTeX packages."
(string-append "TEXMFROOT = " out "/share\n"))
(("^TEXMF = .*")
"TEXMF = $TEXMFROOT/share/texmf-dist\n"))
- (setenv "PATH" (string-append (assoc-ref %build-inputs "bash")
- "/bin"))
+ (setenv "PATH" (string-append
+ (assoc-ref %build-inputs "bash") "/bin:"
+ (assoc-ref %build-inputs "coreutils") "/bin:"
+ (string-append out "/bin")))
(for-each
(cut wrap-program <>
`("TEXMFCNF" ":" suffix (,(dirname texmf.cnf)))
`("TEXMF" ":" suffix (,(string-append out "/share/texmf-dist"))))
(find-files (string-append out "/bin") ".*"))
+
+ ;; Remove invalid maps from config file.
+ (let ((port (open-pipe* OPEN_WRITE "updmap-sys"
+ "--syncwithtrees"
+ "--nohash"
+ (assoc-ref %build-inputs "updmap.cfg"))))
+ (display "Y\n" port)
+ (when (not (zero? (status:exit-val (close-pipe port))))
+ (error "failed to filter updmap.cfg")))
+ ;; Generate maps.
+ (invoke "updmap-sys" "--force"
+ (string-append out "/share/texmf-config/web2c/updmap.cfg"))
#t))))
(inputs
`(("bash" ,bash)
,@(map (lambda (package)
(list (package-name package) package))
(append default-packages packages))))
+ (native-inputs
+ `(("coreutils" ,coreutils)
+ ("sed" ,sed)
+ ("updmap.cfg"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "https://tug.org/svn/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/web2c/updmap.cfg"
+ "?revision=" (number->string %texlive-revision)))
+ (file-name (string-append "updmap.cfg-"
+ (number->string %texlive-revision)))
+ (sha256
+ (base32
+ "06mwpy5i218g5k3sf4gba0fmxgas82hkzx9fhwn67z5ik37d8apq"))))))
(home-page (package-home-page texlive-bin))
(synopsis "Union of TeX Live packages")
(description "This package provides a subset of the TeX Live
--
2.21.0
L
L
Ludovic Courtès wrote on 15 Jul 2019 22:31
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 36513@debbugs.gnu.org)
87muhfghu4.fsf@gnu.org
Hello,

Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (9 lines)
>>From 11900d109a617d07e0085a25e747da76fcb12c2e Mon Sep 17 00:00:00 2001
> From: Ricardo Wurmus <rekado@elephly.net>
> Date: Fri, 5 Jul 2019 17:48:45 +0200
> Subject: [PATCH] gnu: texlive-union: Build font maps.
>
> * gnu/packages/tex.scm (texlive-union)[arguments]: Execute updmap to generate
> missing font maps.
> [native-inputs]: Add coreutils, sed, and updmap.cfg.

I’m blissfully ignorant about TeX’s font maps, but I can say that this
fixes a warning about missing font maps that I had when using a
‘texlive-union’ as a package input.

Now, that probably leads to a big rebuild. Can we estimate the number
of dependents?

Thank you!

Ludo’.
R
R
Ricardo Wurmus wrote on 15 Jul 2019 22:47
(name . Ludovic Courtès)(address . ludo@gnu.org)
87zhlfgh4g.fsf@elephly.net
Hi Ludo,

Toggle quote (18 lines)
> Ricardo Wurmus <rekado@elephly.net> skribis:
>
>>>From 11900d109a617d07e0085a25e747da76fcb12c2e Mon Sep 17 00:00:00 2001
>> From: Ricardo Wurmus <rekado@elephly.net>
>> Date: Fri, 5 Jul 2019 17:48:45 +0200
>> Subject: [PATCH] gnu: texlive-union: Build font maps.
>>
>> * gnu/packages/tex.scm (texlive-union)[arguments]: Execute updmap to generate
>> missing font maps.
>> [native-inputs]: Add coreutils, sed, and updmap.cfg.
>
> I’m blissfully ignorant about TeX’s font maps, but I can say that this
> fixes a warning about missing font maps that I had when using a
> ‘texlive-union’ as a package input.
>
> Now, that probably leads to a big rebuild. Can we estimate the number
> of dependents?

In addition to this change I just pushed to wip-texlive a number of
changes that may lead to an even bigger number of rebuilds due to
changes in the svn fetcher and even more TeX packages.

(I noticed that the branch name “wip-texlive” was already taken by the
attempt to add a new importer, so I just cherry-picked that commit and
replaced the branch.)

I don’t know yet if it leads to practical improvements for users, but at
least it greatly simplifies the definition of texlive-* packages.

I have yet to double check the often unclear licenses of the
texlive-hyphen-* packages. Other than that and the WIP commit by Pierre
at the tip I think these changes are very close to their final form.

--
Ricardo
L
L
Ludovic Courtès wrote on 19 Jul 2019 14:04
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87tvbib587.fsf@gnu.org
Hello,

Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (15 lines)
> In addition to this change I just pushed to wip-texlive a number of
> changes that may lead to an even bigger number of rebuilds due to
> changes in the svn fetcher and even more TeX packages.
>
> (I noticed that the branch name “wip-texlive” was already taken by the
> attempt to add a new importer, so I just cherry-picked that commit and
> replaced the branch.)
>
> I don’t know yet if it leads to practical improvements for users, but at
> least it greatly simplifies the definition of texlive-* packages.
>
> I have yet to double check the often unclear licenses of the
> texlive-hyphen-* packages. Other than that and the WIP commit by Pierre
> at the tip I think these changes are very close to their final form.

Yay, very nice!

When it’s ready, we can ask berlin to build it as a separate branch and
merge it once it’s done.

Thanks a lot!

Ludo’.
R
R
Ricardo Wurmus wrote on 22 Jul 2019 21:28
(name . Ludovic Courtès)(address . ludo@gnu.org)
87imrtdg3j.fsf@elephly.net
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (22 lines)
> Ricardo Wurmus <rekado@elephly.net> skribis:
>
>> In addition to this change I just pushed to wip-texlive a number of
>> changes that may lead to an even bigger number of rebuilds due to
>> changes in the svn fetcher and even more TeX packages.
>>
>> (I noticed that the branch name “wip-texlive” was already taken by the
>> attempt to add a new importer, so I just cherry-picked that commit and
>> replaced the branch.)
>>
>> I don’t know yet if it leads to practical improvements for users, but at
>> least it greatly simplifies the definition of texlive-* packages.
>>
>> I have yet to double check the often unclear licenses of the
>> texlive-hyphen-* packages. Other than that and the WIP commit by Pierre
>> at the tip I think these changes are very close to their final form.
>
> Yay, very nice!
>
> When it’s ready, we can ask berlin to build it as a separate branch and
> merge it once it’s done.

The “wip-texlive” branch is now being built on Berlin.

(I removed the WIP importer from “wip-texlive” and pushed it to a new
“wip-texlive-importer” branch instead.)

--
Ricardo
P
P
Pierre Neidhardt wrote on 22 Jul 2019 22:19
(address . 36513@debbugs.gnu.org)
87zhl5stz8.fsf@ambrevar.xyz
Thanks for making progress on this! :)

Out of curiosity, why bother renaming the branches and not simply choose
a different name, e.g. wip-texlive-union? Is there something special with
the "wip-texlive" name?

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl02GjsACgkQm9z0l6S7
zH/dPgf/Tqcvy4UKIqasj9GLXiPsSkpDz+GV5oCNHKn7YRKrJrdAvZrjU2gfDkh5
IIi7ViQI4APnBKptBJjakHqJ114D0YxmWKJVb3Tsq6SHTSMSbZstWtida1Ta4q8F
ERdxYiY2BAGIk2WdCgcoPVhCB138AhoBr5yTkeA7coxv8sF0L7rT/3YNyEZc3Cyp
pTv5uP2bomRTDKSk7zN8EVD9EV4uEwFK0Jw0DehHFpNJcPvIFIUbydeD3+muMr/h
0KZoJKHxIG1Q4+PE/b21B5rDysWsb7OSVsOOtqgKvz4Qwb4e6arYnYPNLER+IZIg
8QvPbP3jBxIqDjyQlFd0XJBV5bnT2g==
=sU+H
-----END PGP SIGNATURE-----

R
R
Ricardo Wurmus wrote on 22 Jul 2019 23:27
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
87h87ddajv.fsf@elephly.net
Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (6 lines)
> Thanks for making progress on this! :)
>
> Out of curiosity, why bother renaming the branches and not simply choose
> a different name, e.g. wip-texlive-union? Is there something special with
> the "wip-texlive" name?

No. It’s just the name I picked.

At first I thought I could include the importer but then noticed that it
isn’t close enough to finished, so I moved it out again. Had I known
this earlier I would have picked a different branch for my work in the
first place.

--
Ricardo
L
L
Ludovic Courtès wrote on 4 Sep 2019 15:37
(name . Ricardo Wurmus)(address . rekado@elephly.net)
877e6o18t0.fsf@gnu.org
Hey!

Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (8 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Ricardo Wurmus <rekado@elephly.net> skribis:
>>
>>> In addition to this change I just pushed to wip-texlive a number of
>>> changes that may lead to an even bigger number of rebuilds due to
>>> changes in the svn fetcher and even more TeX packages.

[...]

Toggle quote (2 lines)
> The “wip-texlive” branch is now being built on Berlin.

We’ll probably need to rebase it now, but otherwise it seemed to be in

Thoughts?

Ludo’.
R
R
Ricardo Wurmus wrote on 4 Sep 2019 16:17
(name . Ludovic Courtès)(address . ludo@gnu.org)
87k1aof8ni.fsf@elephly.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (17 lines)
> Ricardo Wurmus <rekado@elephly.net> skribis:
>
>> Ludovic Courtès <ludo@gnu.org> writes:
>>
>>> Ricardo Wurmus <rekado@elephly.net> skribis:
>>>
>>>> In addition to this change I just pushed to wip-texlive a number of
>>>> changes that may lead to an even bigger number of rebuilds due to
>>>> changes in the svn fetcher and even more TeX packages.
>
> [...]
>
>> The “wip-texlive” branch is now being built on Berlin.
>
> We’ll probably need to rebase it now, but otherwise it seemed to be in
> good shape: <https://berlin.guixsd.org/jobset/wip-texlive>.

It has already been merged some time ago. I did however notice a couple
more problems with our TeX Live packages that will require some deep
rebuilds again.

I’m very close to fixing these problems, but I’m currently stuck with a
confusing search path issue that I have yet to fully understand. Once
that’s done I’ll push my work to wip-texlive and have Berlin build it
again.

My fixes should finally solve the font problems. (I’m using my WIP
package for “guile-cv” as a test case, which currently cannot be built
as it fails to find certain fonts.)

--
Ricardo
P
P
Pierre Neidhardt wrote on 4 Sep 2019 16:51
(address . 36513@debbugs.gnu.org)
87h85sdsiv.fsf@ambrevar.xyz
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (4 lines)
> My fixes should finally solve the font problems. (I’m using my WIP
> package for “guile-cv” as a test case, which currently cannot be built
> as it fails to find certain fonts.)

Is this font problem related to LaTeX's "tabular" not working?

(And sorry for not helping much on this, I'd love to but really no time
at the moment.)

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl1vz1gACgkQm9z0l6S7
zH/VOwf/bZAzqkNMPdshzHJR/KJ9jQoDmwCF/ILgnBXct60P7AJ6ASjXuA0d+Z8F
HF0PwHbCT0/GbH7qneXkTmx0VP0JLBlNe8iy1j9l8QoB7ATw8zDl0hXVk1U1VO67
Ld9ivQQPEVV95sBPX1ETOzhlJxpiZ/dO4T1sx5Y7w2mR79nWZ1bOr188M8x845tK
0/PTgtsiv0LIYGhrCeZ6vudjHBPueLc1Uq5sd4tnRFD7sV+L5i+UpEcG+3YjoEmP
CEk4M5CLMuVHrtIDtWohvHt+urlyHySJW8nuheGoz2d3W6EzCcQG6wtyCBaFydn1
u0tB/0ahMN94tNOU+v8zxICGpfXuaw==
=f0UY
-----END PGP SIGNATURE-----

R
R
Ricardo Wurmus wrote on 4 Sep 2019 18:07
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
87h85sf3k3.fsf@elephly.net
Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (8 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> My fixes should finally solve the font problems. (I’m using my WIP
>> package for “guile-cv” as a test case, which currently cannot be built
>> as it fails to find certain fonts.)
>
> Is this font problem related to LaTeX's "tabular" not working?

I haven’t even looked at “tabular”, but broken font maps can lead to all
sorts of problems. I had made a rather silly mistake in running updmap,
which had no effect at all on the list of enabled font maps.

Another problem is that certain files are missing from one of the
packages. (This was reported on IRC shortly after merging wip-texlive.)

--
Ricardo
L
L
Ludovic Courtès wrote on 5 Sep 2019 10:35
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87ftlbi1je.fsf@gnu.org
Moin!

Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (28 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Ricardo Wurmus <rekado@elephly.net> skribis:
>>
>>> Ludovic Courtès <ludo@gnu.org> writes:
>>>
>>>> Ricardo Wurmus <rekado@elephly.net> skribis:
>>>>
>>>>> In addition to this change I just pushed to wip-texlive a number of
>>>>> changes that may lead to an even bigger number of rebuilds due to
>>>>> changes in the svn fetcher and even more TeX packages.
>>
>> [...]
>>
>>> The “wip-texlive” branch is now being built on Berlin.
>>
>> We’ll probably need to rebase it now, but otherwise it seemed to be in
>> good shape: <https://berlin.guixsd.org/jobset/wip-texlive>.
>
> It has already been merged some time ago. I did however notice a couple
> more problems with our TeX Live packages that will require some deep
> rebuilds again.
>
> I’m very close to fixing these problems, but I’m currently stuck with a
> confusing search path issue that I have yet to fully understand. Once
> that’s done I’ll push my work to wip-texlive and have Berlin build it
> again.

Ah OK, sounds good.

Toggle quote (4 lines)
> My fixes should finally solve the font problems. (I’m using my WIP
> package for “guile-cv” as a test case, which currently cannot be built
> as it fails to find certain fonts.)

Cool, thanks for explaining!

Ludo’.
R
R
Ricardo Wurmus wrote on 17 Oct 2020 12:07
texlive-union: Build missing font maps.
(address . 36513-done@debbugs.gnu.org)
87imb9w4h6.fsf@elephly.net
The wip-texlive branch has already been merged. Closing!

--
Ricardo
Closed
?