[PATCH] gnu: Add emacs-zerodark-theme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Giacomo Leidi
  • Ludovic Courtès
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 15 Jul 2019 11:28
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20190715092818.2490-1-goodoldpaul@autistici.org
* gnu/packages/emacs-xyz.scm (emacs-zerodark-theme): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 47edbaeeb6..0376dc5069 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -49,6 +49,7 @@
;;; Copyright © 2019 LaFreniere, Joseph <joseph@lafreniere.xyz>
;;; Copyright © 2019 Amar Singh <nly@disroot.org>
;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autitici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16564,3 +16565,29 @@ directories, direct visualisation of image files, jumping directly to links by
name (with autocompletion), a simple bookmark management system and
connections using TLS encryption.")
(license license:gpl3+)))
+
+(define-public emacs-zerodark-theme
+ (package
+ (name "emacs-zerodark-theme")
+ (version "20190528.923")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://melpa.org/packages/zerodark-theme-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "0ajmkf6y7lvxr89cliq194qb8vzfgx4qj5c34b1pr5lrrxxaws0h"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-all-the-icons" ,emacs-all-the-icons)))
+ (home-page
+ "https://github.com/NicolasPetton/zerodark-theme")
+ (synopsis
+ "A dark, medium contrast theme for Emacs")
+ (description
+ "A dark theme inspired from One Dark and Niflheim.
+An optional mode-line format can be enabled with 'zerodark-setup-modeline-format'.")
+ (license license:gpl3+)))
--
2.22.0
L
L
Ludovic Courtès wrote on 17 Jul 2019 15:35
(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)(address . 36658@debbugs.gnu.org)
87blxsbx7x.fsf@gnu.org
Hello,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-zerodark-theme): New variable.

Thanks for this patch! Below are a couple of suggestions.

Toggle quote (3 lines)
> +(define-public emacs-zerodark-theme
> + (package
> + (name "emacs-zerodark-theme")
^
The indentation is off here (you can do M-q to fix it if you use
paredit).

Toggle quote (9 lines)
> + (version "20190528.923")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://melpa.org/packages/zerodark-theme-"
> + version
> + ".el"))

This URL is unstable: the file will be modified in place regularly.
Consequently, could you instead use the upstream Git repository URL
along with the ‘git-fetch’ method?

Toggle quote (2 lines)
> + (synopsis
> + "A dark, medium contrast theme for Emacs")
^
Please remove “A”, as suggested by ‘guix lint’.

Toggle quote (3 lines)
> + (description
> + "A dark theme inspired from One Dark and Niflheim.

Please write a full sentence (info "(guix) Synopses and Descriptions").

Toggle quote (1 lines)
> +An optional mode-line format can be enabled with 'zerodark-setup-modeline-format'.")
^
Please use @code as suggested by ‘guix lint’.

Could you send an updated patch?

Thanks!

Ludo’.
T
T
Tino il Cotechino wrote on 19 Jul 2019 12:30
(address . 36658@debbugs.gnu.org)
29622ca8a83facccb8744c132c2b413eb63515ab.camel@autistici.org
Hello,

I'm not sure why but I was convinced that guix import would run guix
lint on the generated package, so I didn't even try to run it. I'll pay
more attention next time.

The attached patch should fix all previous problems.

Thank you for your review!

Giacomo




On Wed, 2019-07-17 at 15:35 +0200, Ludovic Courtès wrote:
Toggle quote (52 lines)
> Hello,
>
> Giacomo Leidi <goodoldpaul@autistici.org> skribis:
>
> > * gnu/packages/emacs-xyz.scm (emacs-zerodark-theme): New variable.
>
> Thanks for this patch! Below are a couple of suggestions.
>
> > +(define-public emacs-zerodark-theme
> > + (package
> > + (name "emacs-zerodark-theme")
>
> ^
> The indentation is off here (you can do M-q to fix it if you use
> paredit).
>
> > + (version "20190528.923")
> > + (source
> > + (origin
> > + (method url-fetch)
> > + (uri (string-append
> > + "https://melpa.org/packages/zerodark-theme-"
> > + version
> > + ".el"))
>
> This URL is unstable: the file will be modified in place regularly.
> Consequently, could you instead use the upstream Git repository URL
> along with the ‘git-fetch’ method?
>
> > + (synopsis
> > + "A dark, medium contrast theme for Emacs")
>
> ^
> Please remove “A”, as suggested by ‘guix lint’.
>
> > + (description
> > + "A dark theme inspired from One Dark and Niflheim.
>
> Please write a full sentence (info "(guix) Synopses and
> Descriptions").
>
> > +An optional mode-line format can be enabled with 'zerodark-setup-
> > modeline-format'.")
>
> ^
> Please use @code as suggested by ‘guix lint’.
>
> Could you send an updated patch?
>
> Thanks!
>
> Ludo’.
From 392b3a7c34198f47f19fb6b678662971aa8a371f Mon Sep 17 00:00:00 2001
From: Giacomo Leidi <goodoldpaul@autistici.org>
Date: Mon, 15 Jul 2019 11:21:24 +0200
Subject: [PATCH] gnu: Add emacs-zerodark-theme.

* gnu/packages/emacs-xyz.scm (emacs-zerodark-theme): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 47edbaeeb6..fe4c3a6cd4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -49,6 +49,7 @@
;;; Copyright © 2019 LaFreniere, Joseph <joseph@lafreniere.xyz>
;;; Copyright © 2019 Amar Singh <nly@disroot.org>
;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autitici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16564,3 +16565,29 @@ directories, direct visualisation of image files, jumping directly to links by
name (with autocompletion), a simple bookmark management system and
connections using TLS encryption.")
(license license:gpl3+)))
+
+(define-public emacs-zerodark-theme
+ (package
+ (name "emacs-zerodark-theme")
+ (version "4.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.petton.fr/nico/zerodark-theme.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nnlxzsmhsbszqigcyxak9i1a0digrd13gv6v18ck4h760mihh1m"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-all-the-icons" ,emacs-all-the-icons)))
+ (home-page
+ "https://gitlab.petton.fr/nico/zerodark-theme")
+ (synopsis
+ "Dark, medium contrast theme for Emacs")
+ (description
+ "Zerodark is a dark theme inspired from One Dark and Niflheim.
+An optional mode-line format can be enabled with @code{zerodark-setup-modeline-format}.")
+ (license license:gpl3+)))
--
2.22.0
L
L
Ludovic Courtès wrote on 20 Jul 2019 00:59
(name . Tino il Cotechino)(address . goodoldpaul@autistici.org)(address . 36658-done@debbugs.gnu.org)
87a7d9aawf.fsf@gnu.org
Hi,

Tino il Cotechino <goodoldpaul@autistici.org> skribis:

Toggle quote (7 lines)
> From 392b3a7c34198f47f19fb6b678662971aa8a371f Mon Sep 17 00:00:00 2001
> From: Giacomo Leidi <goodoldpaul@autistici.org>
> Date: Mon, 15 Jul 2019 11:21:24 +0200
> Subject: [PATCH] gnu: Add emacs-zerodark-theme.
>
> * gnu/packages/emacs-xyz.scm (emacs-zerodark-theme): New variable.

Applied, thanks!

Ludo’.
Closed
?