[PATCH] tests: Sort scheme tests alphabetically

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Robert Vollmert
Owner
unassigned
Submitted by
Robert Vollmert
Severity
normal
R
R
Robert Vollmert wrote on 15 Jul 2019 12:59
(address . guix-patches@gnu.org)(name . Robert Vollmert)(address . rob@vllmrt.net)
20190715105915.23913-1-rob@vllmrt.net
* Makefile.am (SCM_TESTS): Sort.
---
Makefile.am | 102 ++++++++++++++++++++++++++--------------------------
1 file changed, 51 insertions(+), 51 deletions(-)

Toggle diff (134 lines)
diff --git a/Makefile.am b/Makefile.am
index 6e2124a263..6151afd6a1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -362,76 +362,76 @@ TEST_EXTENSIONS = .scm .sh
if CAN_RUN_TESTS
SCM_TESTS = \
+ tests/accounts.scm \
tests/base16.scm \
tests/base32.scm \
tests/base64.scm \
+ tests/bournish.scm \
+ tests/builders.scm \
+ tests/build-utils.scm \
+ tests/cache.scm \
+ tests/challenge.scm \
tests/channels.scm \
+ tests/combinators.scm \
+ tests/containers.scm \
tests/cpan.scm \
tests/cpio.scm \
+ tests/cran.scm \
tests/crate.scm \
- tests/gem.scm \
- tests/pki.scm \
- tests/print.scm \
- tests/sets.scm \
- tests/modules.scm \
- tests/gnu-maintenance.scm \
- tests/substitute.scm \
- tests/builders.scm \
+ tests/cve.scm \
+ tests/debug-link.scm \
tests/derivations.scm \
- tests/glob.scm \
- tests/grafts.scm \
- tests/ui.scm \
- tests/status.scm \
- tests/records.scm \
- tests/processes.scm \
- tests/upstream.scm \
- tests/combinators.scm \
tests/discovery.scm \
- tests/utils.scm \
- tests/build-utils.scm \
- tests/packages.scm \
- tests/snix.scm \
- tests/hackage.scm \
- tests/cran.scm \
tests/elpa.scm \
- tests/texlive.scm \
- tests/store.scm \
- tests/monads.scm \
+ tests/file-systems.scm \
+ tests/gem.scm \
tests/gexp.scm \
- tests/nar.scm \
- tests/union.scm \
- tests/profiles.scm \
- tests/search-paths.scm \
- tests/syscalls.scm \
- tests/inferior.scm \
+ tests/glob.scm \
+ tests/gnu-maintenance.scm \
+ tests/grafts.scm \
+ tests/graph.scm \
tests/gremlin.scm \
- tests/debug-link.scm \
- tests/bournish.scm \
+ tests/hackage.scm \
+ tests/import-utils.scm \
+ tests/inferior.scm \
tests/lint.scm \
- tests/publish.scm \
- tests/scripts.scm \
- tests/size.scm \
- tests/graph.scm \
- tests/challenge.scm \
- tests/cache.scm \
- tests/cve.scm \
- tests/workers.scm \
- tests/zlib.scm \
tests/lzlib.scm \
- tests/file-systems.scm \
- tests/uuid.scm \
- tests/system.scm \
- tests/accounts.scm \
- tests/services.scm \
- tests/scripts-build.scm \
- tests/containers.scm \
+ tests/modules.scm \
+ tests/monads.scm \
+ tests/nar.scm \
tests/opam.scm \
+ tests/packages.scm \
tests/pack.scm \
+ tests/pki.scm \
+ tests/print.scm \
+ tests/processes.scm \
+ tests/profiles.scm \
+ tests/publish.scm \
tests/pypi.scm \
- tests/import-utils.scm \
+ tests/records.scm \
+ tests/scripts-build.scm \
+ tests/scripts.scm \
+ tests/search-paths.scm \
+ tests/services.scm \
+ tests/sets.scm \
+ tests/size.scm \
+ tests/snix.scm \
+ tests/status.scm \
tests/store-database.scm \
tests/store-deduplication.scm \
- tests/store-roots.scm
+ tests/store-roots.scm \
+ tests/store.scm \
+ tests/substitute.scm \
+ tests/syscalls.scm \
+ tests/system.scm \
+ tests/texlive.scm \
+ tests/ui.scm \
+ tests/union.scm \
+ tests/upstream.scm \
+ tests/utils.scm \
+ tests/uuid.scm \
+ tests/workers.scm \
+ tests/zlib.scm
SH_TESTS = \
tests/guix-build.sh \
--
2.20.1 (Apple Git-117)
E
E
Efraim Flashner wrote on 15 Jul 2019 14:01
(name . Robert Vollmert)(address . rob@vllmrt.net)(address . 36661@debbugs.gnu.org)
20190715120117.GE22158@macbook41
Can you make the backslashes line up also?


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl0saw0ACgkQQarn3Mo9
g1GsEg/9Ezb9U3VcjESfgjsckWtjICFj1lDQoydvyk/P0rEDlVOMVQd9Y403mBVp
nmrulXvAWaH+CZf4kV4c4Q8bBZL75+ptkrL+AbcrCxWP89O52OWVe4w5IIEteUsN
wvpw6J2kwRCzYJZfjzAEZ2g3UHAv7KOgOBClCjHrSviOgCEaNej7pu6jR2DcnWtF
EKY3J/p9HIYYQAlfP/CY/zrZ4JJIzVWdO2rWrJ3bjFJuV57XG5p6IW62dVP9ph46
zTkUlDqFR9cPn7Lh2T0BTvClM59FbBJfAPSP4q3+XQ2SDHcimamvFw0BuP6tPyNY
4OzksRXc5WHrXWY/fdC7czwOYfRrEUUfO36Cw3qdKXaIIjQqjrs76hpRUf6Dxt8o
pIPMorZ+r5stv30Q+4vg5J9hIzOYhZkSDo74d2eLAIeurpwPI7qAbVvAS3F2ZCH6
oeMPSW/jdZwpEktAx1RemUQCTa1XwjTF749EbTB9awkF8Ep31p4vWL2sLb77YYSC
dKiaHwq2JC5JreWrZRedEUIedYFtJXDKTV3H8fJ21Xsls/6nAnQrEAY9bPpLHsEg
j5RVNtSKdvQdc4aTrJR2IRMm1GZV6wD/PvS2gBODVURoM7/NCeVrxJGe0zbWNv+G
Xt8PLgFsUZhGZHrg21f6nLimbYHntAfcjVjhZssak0yO+O65qDQ=
=Q/mt
-----END PGP SIGNATURE-----


R
R
Robert Vollmert wrote on 15 Jul 2019 15:00
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 36661@debbugs.gnu.org)
E39CA501-2CC8-431B-96FD-167E51C7993F@vllmrt.net
Toggle quote (4 lines)
> On 15. Jul 2019, at 14:01, Efraim Flashner <efraim@flashner.co.il> wrote:
>
> Can you make the backslashes line up also?

They do?
R
R
Robert Vollmert wrote on 22 Jul 2019 22:03
bump
(address . 36661@debbugs.gnu.org)
84C9E62E-1F7E-463B-8702-2A20203B6223@vllmrt.net
Hi,

would someone be so kind as to apply this? It’s a bit of a pain
having to rebase it over test file additions.

(If you’re worried about the backslashes being non-aligned: Note
that this appears so in the patch for module names of lengths
3, 11, ….)

Robert
E
E
Efraim Flashner wrote on 23 Jul 2019 08:57
(name . Robert Vollmert)(address . rob@vllmrt.net)(address . 36661-done@debbugs.gnu.org)
20190723065741.GD780@macbook41
I forgot about this. Patch applied.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl02r+UACgkQQarn3Mo9
g1F1rhAAkmLA5M9t/TMuaZe65rzRpZ2/6Nn6aPd+/twWNaS4bHIrOcVtM5B4MvX2
nPxNCMitb+dSknuRVp/amE2CwC+ZaBn7tWcC0yWELqWRrFdGHP2oDnWn2kK2M8hD
MnVItBKLX53HdsmRyNOiozf2KPdWhlOnhbF3s3IOcHb9IxcXaZ5Nwn0p5m9J8g5v
Dq+S/r5q6mwV7OqXX5pwezOe65gGMTGeVj8LWO2ip9uGTHrDxtEdwAskBYaS8gc0
XS2mxJJmxMDlPDrwUd/XFpY6W57RFj6MHeND1miJbbT82TlJGlXuUJ0nGY8wWv5x
BUCc/+NrDdxt+iN1MzZvX10yzlb6cVeX6PY15DmeTCgmZNCvcWN6pezTImt42yui
5wNANz8pW1IHuqlhoON7h2o8Znu15glBBn8TzXB6wQZqeLyRhGL04ZzxgiPG7oht
6Cy0h0YleXWv6TYleZ+c30N9Tmgw4HV38ud0G2kOcnYGbOu4QwBIYgY/NJuqt58S
Pn8pO4itMaaCaDVBNN+3XYic6Ug/HBi6luJMslDeiMPV+hzG7xeQswGJZzDxyUxf
uAVb5osMG44JE+RSFI3ADWN2jgjnVs6+7DC2HEMiRlc0P5sJxMFntiQRbVvtWdbz
NzKPbUtQCecV9i31XWUpTEoy1nZD3LLzck/jR6sVZtnXZN8W/tI=
=VM9I
-----END PGP SIGNATURE-----


Closed
?