"View build log" - but it's empty (at first)!

  • Done
  • quality assurance status badge
Details
2 participants
  • Chris Marusich
  • Ludovic Courtès
Owner
unassigned
Submitted by
Chris Marusich
Severity
normal
C
C
Chris Marusich wrote on 16 Jul 2019 08:41
(address . bug-guix@gnu.org)
87blxu1ny5.fsf@gmail.com
Hi,

Sometimes, I see an error like the following (it is not specific to
ant-bootstrap):

Toggle snippet (12 lines)
$ guix package -m ~/profile-packages.scm
...
building /gnu/store/76apf0hpcdabpjy0839nhkwgfrz3m8z5-ant-bootstrap-1.8.4.drv...
| 'build' phasebuilder for `/gnu/store/76apf0hpcdabpjy0839nhkwgfrz3m8z5-ant-bootstrap-1.8.4.drv' failed with exit code 1
build of /gnu/store/76apf0hpcdabpjy0839nhkwgfrz3m8z5-ant-bootstrap-1.8.4.drv failed
View build log at '/var/log/guix/drvs/76/apf0hpcdabpjy0839nhkwgfrz3m8z5-ant-bootstrap-1.8.4.drv.bz2'.
cannot build derivation `/gnu/store/3l11fmnyc4k1dcwlijk4vdsq70jc4lqs-icedtea-3.7.0.drv': 1 dependencies couldn't be built
killing process 20600
cannot build derivation `/gnu/store/b071r8bm2n01mp50g6r5ghxl0m09akdx-profile.drv': 1 dependencies couldn't be built
guix package: error: build of `/gnu/store/b071r8bm2n01mp50g6r5ghxl0m09akdx-profile.drv' failed

But when I try to view the log file very quickly after getting these
messages (within about 1 minute or so), I get:

Toggle snippet (4 lines)
$ file /var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2
/var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2: empty

However, when I come back a few minutes later, mysteriously the file has
been populated:

Toggle snippet (4 lines)
$ file /var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2
/var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2: bzip2 compressed data, block size = 900k

Indeed, I was originally going to report that the file was empty, but
while I was writing this email, it filled up! Is this behavior
expected? I anticipated that the file would be finalized (empty or not)
before the helpful message "View built log at ..." was printed, but it
seems like that message is proleptic, which makes it a little confusing.

--
Chris
C
C
Chris Marusich wrote on 16 Jul 2019 08:47
(address . bug-guix@gnu.org)
877e8i1nnm.fsf@gmail.com
Chris Marusich <cmmarusich@gmail.com> writes:

Toggle quote (34 lines)
> Sometimes, I see an error like the following (it is not specific to
> ant-bootstrap):
>
> $ guix package -m ~/profile-packages.scm
> ...
> building /gnu/store/76apf0hpcdabpjy0839nhkwgfrz3m8z5-ant-bootstrap-1.8.4.drv...
> | 'build' phasebuilder for `/gnu/store/76apf0hpcdabpjy0839nhkwgfrz3m8z5-ant-bootstrap-1.8.4.drv' failed with exit code 1
> build of /gnu/store/76apf0hpcdabpjy0839nhkwgfrz3m8z5-ant-bootstrap-1.8.4.drv failed
> View build log at '/var/log/guix/drvs/76/apf0hpcdabpjy0839nhkwgfrz3m8z5-ant-bootstrap-1.8.4.drv.bz2'.
> cannot build derivation `/gnu/store/3l11fmnyc4k1dcwlijk4vdsq70jc4lqs-icedtea-3.7.0.drv': 1 dependencies couldn't be built
> killing process 20600
> cannot build derivation `/gnu/store/b071r8bm2n01mp50g6r5ghxl0m09akdx-profile.drv': 1 dependencies couldn't be built
> guix package: error: build of `/gnu/store/b071r8bm2n01mp50g6r5ghxl0m09akdx-profile.drv' failed
>
>
> But when I try to view the log file very quickly after getting these
> messages (within about 1 minute or so), I get:
>
> $ file /var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2
> /var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2: empty
>
>
> However, when I come back a few minutes later, mysteriously the file has
> been populated:
>
> $ file /var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2
> /var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2: bzip2 compressed data, block size = 900k
>
> Indeed, I was originally going to report that the file was empty, but
> while I was writing this email, it filled up! Is this behavior
> expected? I anticipated that the file would be finalized (empty or not)
> before the helpful message "View built log at ..." was printed, but it
> seems like that message is proleptic, which makes it a little confusing.

Whoops, I got my wires crossed. Those build logs are for
evolution-data-server, not ant-bootstrap. However, the same problem
holds for evolution-data-server - I built it, it failed, it said I could
find the logs at
/var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2,
it was empty at first, but then it became full.

In fact, it is only partially full, since the file ends unexpectedly:

Toggle snippet (15 lines)
$ bzcat /var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2 > /dev/null

bzcat: Compressed file ends unexpectedly;
perhaps it is corrupted? *Possible* reason follows.
bzcat: Success
Input file = /var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2, output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.


Sorry for the initial confusion, but I believe this is still a potential
issue, and I wonder if others have observed similar behavior.

--
Chris
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEy/WXVcvn5+/vGD+x3UCaFdgiRp0FAl0tcv0ACgkQ3UCaFdgi
Rp1sMg//fE7B5P1yRcwNsbttEQDnNRhpMmyjuSm6QrRYpXad70xjiQ3wJP/o26Hs
KBfULmDp8s1uFkbRdzxSg/9KEvGdy2yk+GgXE3U/86b7HZtSJwxrVSaWrs6qi+8U
9Kj9ud4zajwlqrcP2vipHpD884fvd6p8wmW6sis/jISuzAHKeFrsh9xwrWWnekKK
5JD9i3NZKSBBfybaKdrTJLcDaszL5ctOaPaovsT+xz7CmMFoU0DpcMuC5sFxIDAw
MhkRSyxjDe97lBvJgdbdRijjrD8mxT5TmpjY1Mll+MXR2YSm29mN7dTfTbPw7NUq
yYr2HEtH5CthHYzzpvxYPlp/w8vrLPzH6YueDIWWa5KH4Dlr9p8mew5DY5k2RlH3
jxJzwi76DTQtGc8Fous9rzrDI7ooDHSL/3z9euImzUcjBwiZ/mpsqirsCEFHE8Cg
LQOGbBIcrDer3a81J/o3x0qov73ZPkLflxf/oSshteOZxFpKeGchO5WP2OLV5IF4
220yZGPKGnLFCMvZqqXHgs/qxkusoCdZesTpsj6VMR1HsFEZMUfNEXU4/EbM0qPY
rfh52D1bGFfJp1MWPJ/P59KgS5y8kNtPCilZJB4lQfQBznDbBorsOWU/xlTJ4liV
X24ikqw310YS6ZxW+mlWzsfeGHqWZTPT0daSMDurdGzjCWdGx2s=
=PY6j
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 17 Jul 2019 21:57
Re: bug#36684: "View build log" - but it's empty (at first)!
(name . Chris Marusich)(address . cmmarusich@gmail.com)(address . 36684@debbugs.gnu.org)
877e8ga0ye.fsf@gnu.org
Hi Chris,

Chris Marusich <cmmarusich@gmail.com> skribis:

Toggle quote (7 lines)
> Whoops, I got my wires crossed. Those build logs are for
> evolution-data-server, not ant-bootstrap. However, the same problem
> holds for evolution-data-server - I built it, it failed, it said I could
> find the logs at
> /var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2,
> it was empty at first, but then it became full.

I guess there’s a small window during which the bzip file handle hasn’t
been closed, and so you could see an empty file. However, that window
should be extremely small: as soon as the client disconnects or the
build terminates, the daemon closes the log.

Toggle quote (15 lines)
> In fact, it is only partially full, since the file ends unexpectedly:
>
> $ bzcat /var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2 > /dev/null
>
> bzcat: Compressed file ends unexpectedly;
> perhaps it is corrupted? *Possible* reason follows.
> bzcat: Success
> Input file = /var/log/guix/drvs/7f/n896phqyv9r636yhjipa9k4qm7g9ni-evolution-data-server-3.30.2.drv.bz2, output file = (stdout)
>
> It is possible that the compressed file(s) have become corrupted.
> You can use the -tvv option to test integrity of such files.
>
> You can use the `bzip2recover' program to attempt to recover
> data from undamaged sections of corrupted files.

So this particular log file remained truncated?

I’ve never experienced it. Is there a scenario that allows you to
reproduce it?

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 24 Aug 2019 15:20
control message for bug #36684
(address . control@debbugs.gnu.org)
87k1b2ya1t.fsf@gnu.org
tags 36684 + unreproducible
quit
C
C
Chris Marusich wrote on 17 Nov 2019 00:32
Re: bug#36684: "View build log" - but it's empty (at first)!
(name . Ludovic Courtès)(address . ludo@gnu.org)
87zhgv5re5.fsf@garuda.local.i-did-not-set--mail-host-address--so-tickle-me
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (3 lines)
> I’ve never experienced it. Is there a scenario that allows you to
> reproduce it?

I have not been able to reproduce this issue; maybe I was simply
confused when I opened the bug report. Let's close this for now.

--
Chris
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEy/WXVcvn5+/vGD+x3UCaFdgiRp0FAl3QhxIACgkQ3UCaFdgi
Rp35Mg//QE+ZIJCTkropOJHHOzm920vSX2TopdZwIBnO4F9lTykF0VpfeYSG27qL
79+3spRleqn54ew6SBaRNqeG8QMoFJG5hRwKzMSkRj6DWjxGWOkFYzdib0+Vj+Di
65wobZSoE1JgfgHLBkzz1u1go45x5PTWy2xAO3Fm3j9aTrfkVcSg2NxXYTRTCnoT
sb+K4LUyu+61HS4PmcbqBA7+EFZl7HFSjYS7jHN+0+7/lR6SFeHOO9Ae5kWotLTU
NysofLw29XRgOauBNoSJZpu/AhQxCUVoXJtNLJ+/OBIrPklKpJ3Ek6zfDtB8uWBc
QcqeuxyL2JOzG4U4+o7Rnii1zzgQUO6ll2bzVRfZySkmaf7kRaThItHkn8Dwcmxn
QNjv3th0e+HjoGILSa3uo+VOYvQJdFcNpAeOJI90+H4hoH+wVGCobpdvxGhAB/ec
Luw43q27iPddR5jODUYC8dyNx43FzQV9NoDrt/Xt0+yc5DjgVkn6Waw8TTEjAo7y
BtrIfSdAUijlcxx/TZRj2me6TEPHvuwLMN06FiJPjLBxD++lov9bXZUUP68rs2gn
MHYRcuyAEtirQyIlGvTB3J1inKJ15tNwvUfAmebK8YTH2kUxlySLwlojYYRU0hsO
Cp9KZB0oTZnfolmix80rztB4+yAEWylwv780G+FJop2y4MX1YZw=
=zWxv
-----END PGP SIGNATURE-----

?