[PATCH] gnu: Add emacs-ox-hugo.

  • Done
  • quality assurance status badge
Details
2 participants
  • Dimakakos Dimos
  • Marius Bakke
Owner
unassigned
Submitted by
Dimakakos Dimos
Severity
normal
D
D
Dimakakos Dimos wrote on 21 Jul 2019 20:22
(address . guix-patches@gnu.org)(name . Dimakakos Dimos)(address . bendersteed@teknik.io)
20190721182234.12071-1-bendersteed@teknik.io
gnu/packages/emacs-xyz.scm (emacs-ox-hugo): New variable
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a808749444..82bf0847ed 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16747,3 +16747,28 @@ connections using TLS encryption.")
"Zerodark is a dark theme inspired from One Dark and Niflheim.
An optional mode-line format can be enabled with @code{zerodark-setup-modeline-format}.")
(license license:gpl3+)))
+
+(define-public emacs-ox-hugo
+ (package
+ (name "emacs-ox-hugo")
+ (version "v0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kaushalmodi/ox-hugo.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11h464cyc28ld0b0zridgm4drydc1qjxbm1y24zrwlkyqqjk6yr7"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-org" ,emacs-org)))
+ (home-page "https://ox-hugo.scripter.co")
+ (synopsis
+ "Hugo Markdown Back-End for Org Export Engine")
+ (description
+ "Ox-hugo is an Org exporter backend that exports Org to Hugo-compatible
+Markdown, Blackfriday, and also generates the front-matter in TOML or YAML
+format.")
+ (license license:gpl3+)))
--
2.22.0
M
M
Marius Bakke wrote on 8 Aug 2019 20:20
87ef1vikn2.fsf@devup.no
Dimakakos Dimos via Guix-patches <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> gnu/packages/emacs-xyz.scm (emacs-ox-hugo): New variable

[...]

Toggle quote (5 lines)
> +(define-public emacs-ox-hugo
> + (package
> + (name "emacs-ox-hugo")
> + (version "v0.8")

I moved the "v" out of the version field and added it in the source URI
below.

Toggle quote (13 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/kaushalmodi/ox-hugo.git")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "11h464cyc28ld0b0zridgm4drydc1qjxbm1y24zrwlkyqqjk6yr7"))))
> + (build-system emacs-build-system)
> + (propagated-inputs `(("emacs-org" ,emacs-org)))

I also removed propagation here, because users might want to use this
with custom Org packages. Let me know if this was a mistake :-)

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl1MaAEACgkQoqBt8qM6
VPpMiwgAslxKnL6kEN47/HLJ1/TipSX2MRN9HDyLKICIRdkQnE9RXvXZnwhRbsZh
CsZpmoZETdWOeX2HDZLwhOX1hMjV38InqRhq7/zqR4v672eHsC3fIs6s+r61CAA9
3G5EoDqAj7qgnPMDLKDvM/2b+5dZaEQJKAf/sood9q+Qs68pcy4PXl2uic/aKUlL
2gNyxFu0WK00IMLpUdM5ncDqIW1uDprSld08UxsFcimKRzcS5duFsw/EsOpRW+Ta
/8z3slKBuwyyPdTlBR3bYl0OwRpu18/7+qoFLn1V+gmK5ypIAplmeq6RLULzck7z
jPcI/J6vtuuhBQuz5RIcNqc1AsxLOg==
=8vaV
-----END PGP SIGNATURE-----

Closed
?