[PATCH 01/11] gnu: Add r-umap.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Merged with
Z
Z
zimoun wrote on 24 Jul 2019 20:21
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20190724182204.6818-2-zimon.toutoune@gmail.com
* gnu/packages/cran.scm (r-umap): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3f0d819df7..768a7d09c5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14530,3 +14530,30 @@ including regression, classification and ranking. The package is made to be
extensible, so that users are also allowed to define their own objectives
easily.")
(license license:asl2.0)))
+
+(define-public r-umap
+ (package
+ (name "r-umap")
+ (version "0.2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "umap" version))
+ (sha256
+ (base32
+ "1s82w9gy1387h7cprjfbhp49l89zbmn3gc9s0wzqb1s73nza9n31"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)
+ ("r-reticulate" ,r-reticulate)
+ ("r-rspectra" ,r-rspectra)))
+ (home-page "https://github.com/tkonopka/umap")
+ (synopsis
+ "Uniform Manifold Approximation and Projection")
+ (description
+ "Uniform manifold approximation and projection is a technique for
+dimension reduction. The algorithm was described by McInnes and Healy (2018)
+in <arXiv:1802.03426>. This package provides an interface to the UMAP
+algorithm in R, including a translation of the original algorithm into R with
+minimal dependencies.")
+ (license license:expat)))
--
2.21.0
T
T
Tobias Geerinckx-Rice wrote on 24 Jul 2019 20:36
(no subject)
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
87lfwni8k4.fsf@nckx
merge 36789 36790
merge 36789 36791
merge 36789 36792
merge 36789 36793
merge 36789 36794
merge 36789 36795
merge 36789 36796
merge 36789 36797
merge 36789 36798
merge 36789 36799
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXTilKwAKCRANsP+IT1Vt
efwCAPwMFfiT2lvcwMNzzwkToDSGCWdwSxssz16tTMeFjdOR8QEA/0yecSJc7Tlg
WzetWDVAWg15OT5glks97g4iaGnfGQE=
=Lk9Y
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 24 Jul 2019 21:17
Merge 36789 36790
CAJ3okZ2J2BW+HmW+K6ziyED4x4NQb80ucCuf9Mpb+nuVBFT7Qg@mail.gmail.com
merge 36789 36790
thanks
?