[PATCH 09/11] gnu: Add r-flowsom.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Merged with
Z
Z
zimoun wrote on 24 Jul 2019 20:22
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20190724182204.6818-10-zimon.toutoune@gmail.com
* gnu/packages/bioconductor.scm (r-flowsom): New variable.
---
gnu/packages/bioconductor.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ab4d9f4075..dd6570ed17 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4930,3 +4930,32 @@ and to both short and long sequence reads.")
"This package provides a fast and automatic clustering to classify the cells into subpopulations based on finding the peaks from the overall density function generated by K-means.")
(license license:artistic2.0))) ;TODO: artistic1.0 does not exist
+(define-public r-flowsom
+ (package
+ (name "r-flowsom")
+ (version "1.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "FlowSOM" version))
+ (sha256
+ (base32
+ "03wl3xk7g7vajc4kkrqa0gsbjfxlqr918qi849h5nir31963398l"))))
+ (properties `((upstream-name . "FlowSOM")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-consensusclusterplus"
+ ,r-consensusclusterplus)
+ ("r-flowcore" ,r-flowcore)
+ ("r-flowutils" ,r-flowutils)
+ ("r-igraph" ,r-igraph)
+ ("r-tsne" ,r-tsne)
+ ("r-xml" ,r-xml)))
+ (home-page "http://www.r-project.org")
+ (synopsis
+ "Using self-organizing maps for visualization and interpretation of cytometry data")
+ (description
+ "FlowSOM offers visualization options for cytometry data, by using Self-Organizing Map clustering and Minimal Spanning Trees.")
+ (license license:gpl2+)))
+
--
2.21.0
T
T
Tobias Geerinckx-Rice wrote on 24 Jul 2019 20:36
(no subject)
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
87lfwni8k4.fsf@nckx
merge 36789 36790
merge 36789 36791
merge 36789 36792
merge 36789 36793
merge 36789 36794
merge 36789 36795
merge 36789 36796
merge 36789 36797
merge 36789 36798
merge 36789 36799
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXTilKwAKCRANsP+IT1Vt
efwCAPwMFfiT2lvcwMNzzwkToDSGCWdwSxssz16tTMeFjdOR8QEA/0yecSJc7Tlg
WzetWDVAWg15OT5glks97g4iaGnfGQE=
=Lk9Y
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 24 Jul 2019 21:17
Merge 36789 36790
CAJ3okZ2J2BW+HmW+K6ziyED4x4NQb80ucCuf9Mpb+nuVBFT7Qg@mail.gmail.com
merge 36789 36790
thanks
?