[PATCH] gnu: Add xchm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jovany Leandro G.C
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Jovany Leandro G.C
Severity
normal
J
J
Jovany Leandro G.C wrote on 25 Jul 2019 03:35
(address . guix-patches@gnu.org)(name . Jovany Leandro G.C)(address . bit4bit@riseup.net)
20190725013515.6097-1-bit4bit@riseup.net
* gnu/packages/ebook.scm (xchm): New variable.
---
gnu/packages/ebook.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index cf424f285d..7c919710d4 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -330,3 +330,31 @@ following formats:
@item XHTML
@end enumerate")
(license license:gpl2+)))
+
+(define-public xchm
+ (package
+ (name "xchm")
+ (version "1.30")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/rzvncj/xCHM/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "13733g2bz84a15z08qwhrdcn0ff6g9c0aabdn0kzvx0nanj9vra9"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("wxwidgets" ,wxwidgets)
+ ("chmlib" ,chmlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("gettext" ,gettext-minimal)))
+ (home-page "https://github.com/rzvncj/xCHM")
+ (synopsis "UNIX CHM Viewer")
+ (description "xCHM is a cross-platform GPL frontend for CHMLIB written
+with the wxWidgets framework.")
+ (license license:gpl2+)))
--
2.19.0
R
R
Ricardo Wurmus wrote on 25 Jul 2019 09:23
(address . 36804-done@debbugs.gnu.org)(name . Jovany Leandro G.C)(address . bit4bit@riseup.net)
87ftmua86v.fsf@elephly.net
Hi,

thank you for your patch.

Toggle quote (24 lines)
> * gnu/packages/ebook.scm (xchm): New variable.
> ---
> gnu/packages/ebook.scm | 28 ++++++++++++++++++++++++++++
> 1 file changed, 28 insertions(+)
>
> diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
> index cf424f285d..7c919710d4 100644
> --- a/gnu/packages/ebook.scm
> +++ b/gnu/packages/ebook.scm
> @@ -330,3 +330,31 @@ following formats:
> @item XHTML
> @end enumerate")
> (license license:gpl2+)))
> +
> +(define-public xchm
> + (package
> + (name "xchm")
> + (version "1.30")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/rzvncj/xCHM/archive/"
> + version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))

The project provides a bootstrapped tarball. We avoid the “/archive”
URLs on Github as they may change over time.

Toggle quote (14 lines)
> + (sha256
> + (base32
> + "13733g2bz84a15z08qwhrdcn0ff6g9c0aabdn0kzvx0nanj9vra9"))))
> + (build-system gnu-build-system)
> + (inputs
> + `(("wxwidgets" ,wxwidgets)
> + ("chmlib" ,chmlib)))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("autoconf" ,autoconf)
> + ("automake" ,automake)
> + ("libtool" ,libtool)
> + ("gettext" ,gettext-minimal)))

When using the bootstrapped tarball most of these inputs are not needed.

Toggle quote (5 lines)
> + (synopsis "UNIX CHM Viewer")
> + (description "xCHM is a cross-platform GPL frontend for CHMLIB written
> +with the wxWidgets framework.")

I have changed both synopsis and description. We don’t usually mention
UNIX, nor do we repeat the license or the inputs in the description.

You missed the import of (gnu packages wxwidgets), which makes me think
that you haven’t tried building this patch.

I have pushed this to the master branch with commit 7c0411879b after
including my changes.

Thanks!

--
Ricardo
Closed
J
J
Jovany Leandro G.C wrote on 25 Jul 2019 17:05
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 36804-done@debbugs.gnu.org)
4155934b43d0cbd851f62b889e8fe673@riseup.net
On 2019-07-25 07:23, Ricardo Wurmus wrote:
Toggle quote (65 lines)
> Hi,
>
> thank you for your patch.
>
>> * gnu/packages/ebook.scm (xchm): New variable.
>> ---
>> gnu/packages/ebook.scm | 28 ++++++++++++++++++++++++++++
>> 1 file changed, 28 insertions(+)
>>
>> diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
>> index cf424f285d..7c919710d4 100644
>> --- a/gnu/packages/ebook.scm
>> +++ b/gnu/packages/ebook.scm
>> @@ -330,3 +330,31 @@ following formats:
>> @item XHTML
>> @end enumerate")
>> (license license:gpl2+)))
>> +
>> +(define-public xchm
>> + (package
>> + (name "xchm")
>> + (version "1.30")
>> + (source (origin
>> + (method url-fetch)
>> + (uri (string-append "https://github.com/rzvncj/xCHM/archive/"
>> + version ".tar.gz"))
>> + (file-name (string-append name "-" version ".tar.gz"))
>
> The project provides a bootstrapped tarball. We avoid the “/archive”
> URLs on Github as they may change over time.
>
>> + (sha256
>> + (base32
>> + "13733g2bz84a15z08qwhrdcn0ff6g9c0aabdn0kzvx0nanj9vra9"))))
>> + (build-system gnu-build-system)
>> + (inputs
>> + `(("wxwidgets" ,wxwidgets)
>> + ("chmlib" ,chmlib)))
>> + (native-inputs
>> + `(("pkg-config" ,pkg-config)
>> + ("autoconf" ,autoconf)
>> + ("automake" ,automake)
>> + ("libtool" ,libtool)
>> + ("gettext" ,gettext-minimal)))
>
> When using the bootstrapped tarball most of these inputs are not needed.
>
>> + (home-page "https://github.com/rzvncj/xCHM")
>> + (synopsis "UNIX CHM Viewer")
>> + (description "xCHM is a cross-platform GPL frontend for CHMLIB written
>> +with the wxWidgets framework.")
>
> I have changed both synopsis and description. We don’t usually mention
> UNIX, nor do we repeat the license or the inputs in the description.
>
> You missed the import of (gnu packages wxwidgets), which makes me think
> that you haven’t tried building this patch.
>
> I have pushed this to the master branch with commit 7c0411879b after
> including my changes.
>
> Thanks!
>
> --
> Ricardo
thanks for your time, sorry i already build with rounds=2, but i have
the source
in other place when i sure it's build and i use for a time i merge the
patch to guix-dev, i miss the import sorry.

si 'guix lint' show about tarball but i was not sure what to do
thanks
Closed
?