[PATCH] machine: Rename 'system' field.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Lemmer Webber
  • Jakob L. Kreuze
Owner
unassigned
Submitted by
Jakob L. Kreuze
Severity
normal
J
J
Jakob L. Kreuze wrote on 30 Jul 2019 00:38
(address . guix-patches@gnu.org)
87h874ihzo.fsf@sdf.lonestar.org
* gnu/machine.scm (machine-system): Delete variable.
(machine-operating-system): New variable.
* doc/guix.texi (Invoking guix deploy): Use the
'machine-operating-system' accessor rather than 'machine-system'.
---
doc/guix.texi | 4 ++--
gnu/machine.scm | 12 ++++++------
2 files changed, 8 insertions(+), 8 deletions(-)

Toggle diff (57 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index ccc36a8a97..cb3778af51 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -25507,7 +25507,7 @@ evaluates to. As an example, @var{file} might contain a definition like this:
%base-services))))
(list (machine
- (system %system)
+ (operating-system %system)
(environment managed-host-environment-type)
(configuration (machine-ssh-configuration
(host-name "localhost")
@@ -25532,7 +25532,7 @@ This is the data type representing a single machine in a heterogeneous Guix
deployment.
@table @asis
-@item @code{system}
+@item @code{operating-system}
The object of the operating system configuration to deploy.
@item @code{environment}
diff --git a/gnu/machine.scm b/gnu/machine.scm
index 0b79402b0a..30ae97f6ec 100644
--- a/gnu/machine.scm
+++ b/gnu/machine.scm
@@ -34,7 +34,7 @@
machine?
this-machine
- machine-system
+ machine-operating-system
machine-environment
machine-configuration
machine-display-name
@@ -85,14 +85,14 @@
make-machine
machine?
this-machine
- (system machine-system) ; <operating-system>
- (environment machine-environment) ; symbol
- (configuration machine-configuration ; configuration object
- (default #f))) ; specific to environment
+ (operating-system machine-operating-system) ; <operating-system>
+ (environment machine-environment) ; symbol
+ (configuration machine-configuration ; configuration object
+ (default #f))) ; specific to environment
(define (machine-display-name machine)
"Return the host-name identifying MACHINE."
- (operating-system-host-name (machine-system machine)))
+ (operating-system-host-name (machine-operating-system machine)))
(define (machine-remote-eval machine exp)
"Evaluate EXP, a gexp, on MACHINE. Ensure that all the elements EXP refers to
--
2.22.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEa1VJLOiXAjQ2BGSm9Qb9Fp2P2VoFAl0/dWsACgkQ9Qb9Fp2P
2VqnyhAApkapBUt5pUZ2sB5nxaZbb6pFxe00Do+upFmLYNZFRgSFpZxKXJALYadV
jh0CT0jXxOqWxvH5+26LqJzmSSt0YohGab875zvzBHdupgOu/MPGOCYltrBvrzOk
Pr/nxNAt+OckhFKKrCaKV85hONC0YiGPyBGuE0PVuib28SAXy8C73rwSlC47M4mZ
sX1/Pl6X6K50sHXgFluWwzC8tU8S1dTMBHARjHsNPbCN5qYFORKsysn970WqOhM2
fQKiydhRtuA8chJAdN4ecaTHCV20g0Gjm5NdDT4mFj37WFuM/SfGs5Zu7KazNr2o
qv8+yGohBvzpgzu50mzy/42UX1X+Ytz+ELFPsTwamU9JUdFO8CQV1+oeqtJ6OZrE
rMP29y3jKQBC7O5SrPsP4sYY+jyYwo9+A8wb4rMZHtAFKKoLL61d0aRwV4edSinD
+tbt6Za14q/IdIuhXiyY2HWsproDDaDHkgCjQ1sp7flBNqP/QI6UgZnCnAPXE2sp
Yj4Vwio9Tc8hMI69Aauvdu8WiP/DyljTSAv/6FFIBX8YwTWPY3Z6hGKLUybQ9ckU
nkhb/NTW50g0CKkXr75TuVyt/x3aUv1vEhPGVURly+1QmUSzGDQVyMdSmCj2Ie0E
aoCHc6srNSD4kIjcqq9A7tcr5gTlME8clzIgKBMhk700fFr4tOY=
=B51g
-----END PGP SIGNATURE-----

J
J
Jakob L. Kreuze wrote on 30 Jul 2019 19:48
[PATCH v2] machine: Rename 'system' field.
(address . guix-patches@gnu.org)
87r267v2fj.fsf@sdf.lonestar.org
* gnu/machine.scm (machine-system): Delete variable.
(machine-operating-system): New variable.
All callers changed.
* doc/guix.texi (Invoking guix deploy): Use the
'machine-operating-system' accessor rather than 'machine-system'.
---
doc/guix.texi | 4 ++--
gnu/machine.scm | 12 ++++++------
gnu/machine/ssh.scm | 2 +-
3 files changed, 9 insertions(+), 9 deletions(-)

Toggle diff (70 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index ccc36a8a97..cb3778af51 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -25507,7 +25507,7 @@ evaluates to. As an example, @var{file} might contain a definition like this:
%base-services))))
(list (machine
- (system %system)
+ (operating-system %system)
(environment managed-host-environment-type)
(configuration (machine-ssh-configuration
(host-name "localhost")
@@ -25532,7 +25532,7 @@ This is the data type representing a single machine in a heterogeneous Guix
deployment.
@table @asis
-@item @code{system}
+@item @code{operating-system}
The object of the operating system configuration to deploy.
@item @code{environment}
diff --git a/gnu/machine.scm b/gnu/machine.scm
index 0b79402b0a..30ae97f6ec 100644
--- a/gnu/machine.scm
+++ b/gnu/machine.scm
@@ -34,7 +34,7 @@
machine?
this-machine
- machine-system
+ machine-operating-system
machine-environment
machine-configuration
machine-display-name
@@ -85,14 +85,14 @@
make-machine
machine?
this-machine
- (system machine-system) ; <operating-system>
- (environment machine-environment) ; symbol
- (configuration machine-configuration ; configuration object
- (default #f))) ; specific to environment
+ (operating-system machine-operating-system) ; <operating-system>
+ (environment machine-environment) ; symbol
+ (configuration machine-configuration ; configuration object
+ (default #f))) ; specific to environment
(define (machine-display-name machine)
"Return the host-name identifying MACHINE."
- (operating-system-host-name (machine-system machine)))
+ (operating-system-host-name (machine-operating-system machine)))
(define (machine-remote-eval machine exp)
"Evaluate EXP, a gexp, on MACHINE. Ensure that all the elements EXP refers to
diff --git a/gnu/machine/ssh.scm b/gnu/machine/ssh.scm
index 552eafa9de..d1c90b6313 100644
--- a/gnu/machine/ssh.scm
+++ b/gnu/machine/ssh.scm
@@ -166,7 +166,7 @@ of MACHINE's system profile, ordered from most recent to oldest."
environment type of 'managed-host."
(maybe-raise-unsupported-configuration-error machine)
(mlet %store-monad ((boot-parameters (machine-boot-parameters machine)))
- (let* ((os (machine-system machine))
+ (let* ((os (machine-operating-system machine))
(eval (cut machine-remote-eval machine <>))
(menu-entries (map boot-parameters->menu-entry boot-parameters))
(bootloader-configuration (operating-system-bootloader os))
--
2.22.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEa1VJLOiXAjQ2BGSm9Qb9Fp2P2VoFAl1AgvAACgkQ9Qb9Fp2P
2VrlmxAAqrAXp2RNpF9dtPzWrr70uXYTAZq4f66rxHpm44wt96TurSBaywXtv2aJ
Ru9ZP7glGoi+qlv9vb1u3CWCRWaeXFORnKoynGjiZ2LHU8Q+hhcotxbN9Ob6MsmG
JKln2s+SlHohzlxQUhwa5CS5nvoGExq9e0lXAtNr5JoXZ75BKHhCY3hFhozulJdl
XoriA7pndU77OVRE5Duund46uv6KljqjoKE9qhGnC1W14eDrN2j2fGnm+G034zI5
+rinLgqN8AnLG9n0Qn7bQkg7z6TPlkWNN0sKcTOJ9thmVioURbnUbU1bByXgPk9c
1LqRQljwviJoSlWv5kavzyOPrR5R6m3LsqGiK9xQmPTpoD6mGHm5+8UP8I2dJc30
GeTZAHUUG/L4nrjovAXjfumhOf06GC4Iez+brlVcmciGPbGt333Sy2lXrVyfLD7I
dipEJQ+6VmlM6Flr1NadtYvNie8QMR7HpXLO0JpdApxW+uolB2OQBQ+z6ku9uB0w
Gu1ibLhUaYcC6+6ad4Vu+ksrM7KgWVolj2kswaxzMvq82KtV9x8lpsysI9nsxxVa
DcMwNzctN5ydZTeh++mpTZD9NLPkG0HtR/nSOPewOxNbyxQY0Vo8XwjvBeCBM8+K
vBsAoDgqhl6mQkh92keiHhr2HW2FE5RpeNBJ34QqZA7dE2a5DTA=
=W12Y
-----END PGP SIGNATURE-----

C
C
Christopher Lemmer Webber wrote on 6 Aug 2019 21:59
(address . guix-patches@gnu.org)(address . 36847-done@debbugs.gnu.org)
87h86uoyjt.fsf@dustycloud.org
Merged & pushed.

Jakob L. Kreuze writes:

Toggle quote (79 lines)
> * gnu/machine.scm (machine-system): Delete variable.
> (machine-operating-system): New variable.
> All callers changed.
> * doc/guix.texi (Invoking guix deploy): Use the
> 'machine-operating-system' accessor rather than 'machine-system'.
> ---
> doc/guix.texi | 4 ++--
> gnu/machine.scm | 12 ++++++------
> gnu/machine/ssh.scm | 2 +-
> 3 files changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/doc/guix.texi b/doc/guix.texi
> index ccc36a8a97..cb3778af51 100644
> --- a/doc/guix.texi
> +++ b/doc/guix.texi
> @@ -25507,7 +25507,7 @@ evaluates to. As an example, @var{file} might contain a definition like this:
> %base-services))))
>
> (list (machine
> - (system %system)
> + (operating-system %system)
> (environment managed-host-environment-type)
> (configuration (machine-ssh-configuration
> (host-name "localhost")
> @@ -25532,7 +25532,7 @@ This is the data type representing a single machine in a heterogeneous Guix
> deployment.
>
> @table @asis
> -@item @code{system}
> +@item @code{operating-system}
> The object of the operating system configuration to deploy.
>
> @item @code{environment}
> diff --git a/gnu/machine.scm b/gnu/machine.scm
> index 0b79402b0a..30ae97f6ec 100644
> --- a/gnu/machine.scm
> +++ b/gnu/machine.scm
> @@ -34,7 +34,7 @@
> machine?
> this-machine
>
> - machine-system
> + machine-operating-system
> machine-environment
> machine-configuration
> machine-display-name
> @@ -85,14 +85,14 @@
> make-machine
> machine?
> this-machine
> - (system machine-system) ; <operating-system>
> - (environment machine-environment) ; symbol
> - (configuration machine-configuration ; configuration object
> - (default #f))) ; specific to environment
> + (operating-system machine-operating-system) ; <operating-system>
> + (environment machine-environment) ; symbol
> + (configuration machine-configuration ; configuration object
> + (default #f))) ; specific to environment
>
> (define (machine-display-name machine)
> "Return the host-name identifying MACHINE."
> - (operating-system-host-name (machine-system machine)))
> + (operating-system-host-name (machine-operating-system machine)))
>
> (define (machine-remote-eval machine exp)
> "Evaluate EXP, a gexp, on MACHINE. Ensure that all the elements EXP refers to
> diff --git a/gnu/machine/ssh.scm b/gnu/machine/ssh.scm
> index 552eafa9de..d1c90b6313 100644
> --- a/gnu/machine/ssh.scm
> +++ b/gnu/machine/ssh.scm
> @@ -166,7 +166,7 @@ of MACHINE's system profile, ordered from most recent to oldest."
> environment type of 'managed-host."
> (maybe-raise-unsupported-configuration-error machine)
> (mlet %store-monad ((boot-parameters (machine-boot-parameters machine)))
> - (let* ((os (machine-system machine))
> + (let* ((os (machine-operating-system machine))
> (eval (cut machine-remote-eval machine <>))
> (menu-entries (map boot-parameters->menu-entry boot-parameters))
> (bootloader-configuration (operating-system-bootloader os))
?