[PATCH] gnu: Add zutils.

  • Done
  • quality assurance status badge
Details
One participant
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Tobias Geerinckx-Rice
Severity
normal
T
T
Tobias Geerinckx-Rice wrote on 31 Jul 2019 01:00
(address . guix-patches@gnu.org)
20190730230029.9269-1-me@tobias.gr
* gnu/packages/compression.scm (zutils): New public variable.
---
gnu/packages/compression.scm | 46 ++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 9834fcbe63..bda43bfd18 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1954,3 +1954,49 @@ reading from and writing to ZIP archives. ")
;; Project is distributed under LGPL, but "quazip/z*" "quazip/unzip.*" are
;; distributed under zlib terms.
(license (list license:lgpl2.1+ license:zlib))))
+
+(define-public zutils
+ (package
+ (name "zutils")
+ ;; Check and remove the lint-hidden-cve property when updating.
+ (version "1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/zutils/zutils-" version ".tar.lz"))
+ (sha256
+ (base32 "0dx35mv78fgqgz6sszs05ng8ipz2xy09ry9vpmka2rmy08b7x907"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--sysconfdir=/etc")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (apply invoke "make" "install"
+ (string-append "sysconfdir=" (assoc-ref outputs "out")
+ "/etc")
+ make-flags))))))
+ (native-inputs
+ ;; Needed to extract the source tarball and run the test suite.
+ `(("lzip" ,lzip)))
+ (properties `((lint-hidden-cve . ("CVE-2018-1000637"))))
+ (home-page "https://www.nongnu.org/zutils/zutils.html")
+ (synopsis "Utilities that transparently operate on compressed files")
+ (description
+ "Zutils is a collection of utilities able to process any combination of
+compressed and uncompressed files transparently. If any given file, including
+standard input, is compressed, its decompressed content is used instead.
+
+@command{zcat}, @command{zcmp}, @command{zdiff}, and @command{zgrep} are
+improved replacements for the shell scripts provided by GNU gzip.
+@command{ztest} tests the integrity of supported compressed files.
+@command{zupdate} recompresses files with lzip, similar to gzip's
+@command{znew}.
+
+Supported compression formats are bzip2, gzip, lzip, and xz. Zutils uses
+external compressors: the compressor to be used for each format is configurable
+at run time, and must be installed separately.")
+ (license (list license:bsd-2 ; arg_parser.{cc,h}
+ license:gpl2+)))) ; the rest
--
2.22.0
T
T
Tobias Geerinckx-Rice wrote on 22 Aug 2019 15:37
(no subject)
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
87zhk1codx.fsf@nckx
close 36863
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXV6aigAKCRANsP+IT1Vt
eUAqAQCiLNWAWWn+Khu28rQDYlsChI6TFLiVFjdYns1FbIKviwEA9EXPh4shyQ8U
/ArTFs7rhFG1SNycHsOfNEqj7oub6QY=
=A/81
-----END PGP SIGNATURE-----

?