[PATCH 0/2] gnu: Add emacs-mu4e-jump-to-list and emacs-mu4e-patch.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Pierre Langlois
Owner
unassigned
Submitted by
Pierre Langlois
Severity
normal
P
P
Pierre Langlois wrote on 3 Aug 2019 16:04
(address . guix-patches@gnu.org)(name . Pierre Langlois)(address . pierre.langlois@gmx.com)
87imreibui.fsf@gmx.com
Hello Guix!

Here are a couple of new packages that extend mu4e, notably, mu4e-patch
makes emails with patches look nice :-).

As a side-note, I wasn't able to run `guix lint`:

~~~
$ ./pre-inst-env guix lint emacs-mu4e-patch
Backtrace:macs-mu4e-patch@0.1.0-1.522da46 [refresh]...
9 (apply-smob/1 #<catch-closure 1cab900>)
In ice-9/boot-9.scm:
705:2 8 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
In ice-9/eval.scm:
619:8 7 (_ #(#(#<directory (guile-user) 1d36140>)))
In guix/ui.scm:
1692:12 6 (run-guix-command _ . _)
In srfi/srfi-1.scm:
640:9 5 (for-each #<procedure 21938a0 at guix/scripts/lint.scm…> …)
In guix/scripts/lint.scm:
57:4 4 (run-checkers _ _)
In srfi/srfi-1.scm:
640:9 3 (for-each #<procedure 4003e60 at guix/scripts/lint.scm…> …)
In guix/scripts/lint.scm:
64:17 2 (_ _)
In guix/lint.scm:
1010:2 1 (check-for-updates #<package emacs-mu4e-patch@0.1.0-1.5…>)
In ice-9/boot-9.scm:
829:9 0 (catch srfi-34 #<procedure 6c89570 at guix/lint.scm:93…> …)

ice-9/boot-9.scm:829:9: In procedure catch:
Wrong type (expecting array): ()
~~~

Does this ring any bells? Hopefully there isn't anything wrong the with
the attached emacs-mu4e-patch package definition.

Thanks,
Pierre
From 36baf49682d69e37b47e311a442adf33fc1d33c8 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Sat, 3 Aug 2019 13:24:50 +0100
Subject: [PATCH 1/2] gnu: Add emacs-mu4e-jump-to-list.

* gnu/packages/emacs-xyz.scm (emacs-mu4e-jump-to-list): New variable.
---
gnu/packages/emacs-xyz.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 600d810bea..1217bf7127 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -40,7 +40,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
-;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018, 2019 Brett Gilio <brettg@posteo.net>
;;; Copyright © 2019 Dimakakos Dimos <bendersteed@teknik.io>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
@@ -6993,6 +6993,34 @@ Additionally it can display the number of unread emails in the
mode-line.")
(license license:gpl3+)))
+(define-public emacs-mu4e-jump-to-list
+ (let ((commit "358bba003543b49ffa266e503e54aebd0ebe614b")
+ (revision "1"))
+ (package
+ (name "emacs-mu4e-jump-to-list")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/wavexx/mu4e-jump-to-list.el.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00y9nap61q1z2cdql4k9g7fgi2gdgd9iy5s5lzrd9a4agbx6r7sv"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("mu" ,mu)))
+ (home-page "https://gitlab.com/wavexx/mu4e-jump-to-list.el")
+ (synopsis "Select and view mailing lists in mu4e")
+ (description
+ "@code{mu4e-jump-to-list} allows you to select and view mailing lists
+automatically using existing List-ID headers in your mu database. Just press
+\"l\" in the headers view and any mailing list you've subscribed to will be
+automatically discovered and presented in recency order.")
+ (license license:gpl3+))))
+
(define-public emacs-pretty-mode
(package
(name "emacs-pretty-mode")
--
2.22.0
From e037d61848069a1ac6ba5a11e81285c57c120df2 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Sat, 3 Aug 2019 13:29:15 +0100
Subject: [PATCH 2/2] gnu: Add emacs-mu4e-patch.

* gnu/packages/emacs-xyz.scm (emacs-mu4e-patch): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1217bf7127..4a5bdff969 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7021,6 +7021,32 @@ automatically using existing List-ID headers in your mu database. Just press
automatically discovered and presented in recency order.")
(license license:gpl3+))))

+(define-public emacs-mu4e-patch
+ (let ((commit "522da46c1653b1cacc79cde91d6534da7ae9517d")
+ (revision "1"))
+ (package
+ (name "emacs-mu4e-patch")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/seanfarley/mu4e-patch")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10lzf3b70pk6rzdrgx0ww0gc94v0ydh9zj1gbsa20xw27ds7hmfn"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("mu" ,mu)))
+ (home-page "https://github.com/seanfarley/mu4e-patch")
+ (synopsis "Colorize patch-like emails in mu4e")
+ (description
+ "Extension for mu4e to colorize patch-like emails with diff-mode.
+This is based on Frank Terbeck's @code{gnus-article-treat-patch.el} but has
+been adapted to work with mu4e.")
+ (license license:gpl3+))))
+
(define-public emacs-pretty-mode
(package
(name "emacs-pretty-mode")
--
2.22.0
L
L
Ludovic Courtès wrote on 22 Aug 2019 17:57
(name . Pierre Langlois)(address . pierre.langlois@gmx.com)(address . 36906-done@debbugs.gnu.org)
878srlp503.fsf@gnu.org
Hello Pierre,

Pierre Langlois <pierre.langlois@gmx.com> skribis:

Toggle quote (3 lines)
> Here are a couple of new packages that extend mu4e, notably, mu4e-patch
> makes emails with patches look nice :-).

Neat, applied both!

Toggle quote (31 lines)
> As a side-note, I wasn't able to run `guix lint`:
>
> ~~~
> $ ./pre-inst-env guix lint emacs-mu4e-patch
> Backtrace:macs-mu4e-patch@0.1.0-1.522da46 [refresh]...
> 9 (apply-smob/1 #<catch-closure 1cab900>)
> In ice-9/boot-9.scm:
> 705:2 8 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
> In ice-9/eval.scm:
> 619:8 7 (_ #(#(#<directory (guile-user) 1d36140>)))
> In guix/ui.scm:
> 1692:12 6 (run-guix-command _ . _)
> In srfi/srfi-1.scm:
> 640:9 5 (for-each #<procedure 21938a0 at guix/scripts/lint.scm…> …)
> In guix/scripts/lint.scm:
> 57:4 4 (run-checkers _ _)
> In srfi/srfi-1.scm:
> 640:9 3 (for-each #<procedure 4003e60 at guix/scripts/lint.scm…> …)
> In guix/scripts/lint.scm:
> 64:17 2 (_ _)
> In guix/lint.scm:
> 1010:2 1 (check-for-updates #<package emacs-mu4e-patch@0.1.0-1.5…>)
> In ice-9/boot-9.scm:
> 829:9 0 (catch srfi-34 #<procedure 6c89570 at guix/lint.scm:93…> …)
>
> ice-9/boot-9.scm:829:9: In procedure catch:
> Wrong type (expecting array): ()
> ~~~
>
> Does this ring any bells?

Yes: you’re running guile-json@1 whereas Guix now requires guile-json@3.

Thanks,
Ludo’.
Closed
?