[PATCH] Make gzip timestamps writable for some packages.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brian Leung
  • Efraim Flashner
Owner
unassigned
Submitted by
Brian Leung
Severity
normal
B
B
Brian Leung wrote on 3 Aug 2019 22:40
(address . guix-patches@gnu.org)
CAAc=MEzSfpFg+LXCOKM1o9godQGce5uZPzx3KST4bWuY91889g@mail.gmail.com
See attached.
Attachment: file
From 8dfc2dd952edc1e19372d83bc1bedee67b0cddac Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Tue, 25 Jun 2019 20:48:54 +0200
Subject: [PATCH 1/2] gnu: khmer: Make gzip timestamps writable.

* gnu/packages/bioinformatics.scm (khmer): Make gzip timestamps writable.
---
gnu/packages/bioinformatics.scm | 11 +++++++++--
1 file changed, 9 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 89f1ac36ea..81da765be9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4206,8 +4206,15 @@ command, or queried for specific k-mers with @code{jellyfish query}.")
(modify-phases %standard-phases
(add-after 'unpack 'set-cc
(lambda _ (setenv "CC" "gcc") #t))
- ;; FIXME: This fails with "permission denied".
- (delete 'reset-gzip-timestamps))))
+
+ (add-before 'reset-gzip-timestamps 'make-files-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure .gz files are writable so that the
+ ;; 'reset-gzip-timestamps' phase can do its work.
+ (let ((out (assoc-ref outputs "out")))
+ (for-each make-file-writable
+ (find-files out "\\.gz$"))
+ #t))))))
(native-inputs
`(("python-cython" ,python-cython)
("python-pytest" ,python-pytest)
--
2.22.0
From 5f4bf9c5aa67096b8b1211959db61d9ca87c3fac Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Tue, 25 Jun 2019 20:50:54 +0200
Subject: [PATCH 2/2] gnu: python-scikit-learn: Make gzip timestamps writable.

* gnu/packages/machine-learning.scm (python-scikit-learn): Make gzip timestamps writable.
---
gnu/packages/machine-learning.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 2dc7dc81ef..dd5ee1e9ee 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -821,8 +821,14 @@ computing environments.")
(setenv "HOME" "/tmp")
(invoke "pytest" "sklearn" "-m" "not network")))
- ;; FIXME: This fails with permission denied
- (delete 'reset-gzip-timestamps))))
+ (add-before 'reset-gzip-timestamps 'make-files-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure .gz files are writable so that the
+ ;; 'reset-gzip-timestamps' phase can do its work.
+ (let ((out (assoc-ref outputs "out")))
+ (for-each make-file-writable
+ (find-files out "\\.gz$"))
+ #t))))))
(inputs
`(("openblas" ,openblas)))
(native-inputs
--
2.22.0
E
E
Efraim Flashner wrote on 5 Aug 2019 09:28
(name . Brian Leung)(address . bkleung89@gmail.com)(address . 36913-done@debbugs.gnu.org)
20190805072849.GC15819@E2140
Add a copyright line for you and patch pushed.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl1H2rEACgkQQarn3Mo9
g1FmphAAlYbBGSLp3j6Gbzu2AKvpZlZ15XQ0jy/Mn+1jLjGv97LHPGh9y5jkHprH
cxb4FtjbQmBVEZvlccxNfUOl3n3eVBxZf7WLmAsvjZXS3MmmkDl8mhAbWNWuwNWh
5PxYNwcsfmYdNFaksI6wiWlIAO3KLW+gZxgDoxSAiMp39N5aLA+gTwzt0WKb+0u3
Qgyx0oGsqBJ6CJxXMGhjPfEiosIqjkyWtufyG9r1JtR5pEvpPJTckICFC6NjBlJM
p0pjRj5bepujJi3sGl/jBuqwniAoBsXQ+tXV4+s+1K6o9VuGgSwDrHotZGaYF5rR
MhwTRLV626evG0OZwWbaGQrcJJS9GAU69nj4oX0a8ve/epIxNem5PjRz4hF4ITzc
E10n96qHS+crbEC10NDrLYfOGjM8ZCfJFelAMpLCEYRIn2/eTZE8k1iw7WCjPN+/
9Z5Ff3iBriX1bnMiT7P5P4hYXDZwNS/EzLzl/3WnnL008wGS4mlJ6UwRsYXOGmz/
8pld+L3oHuBhmPX/aZDIZwcNEtb/48DR/gM6M3FKm4pyLhPzFzRY9s2lCqDokMIo
mTAnnTSjCAdHzqKoc4VHkJrjr489uF3gmuGvV7P02TiWAen8YP20IUDI5NUpbt8B
HpJ3Mp99PVdl0CVmrHJKUTayMaeWHXggb6zXRQa7kKMd4Hpsqy4=
=0Jru
-----END PGP SIGNATURE-----


Closed
?