[PATCH] gnu: Add emacs-ebdb.

  • Done
  • quality assurance status badge
Details
3 participants
  • Amin Bandali
  • Nicolas Goaziou
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Amin Bandali
Severity
normal
A
A
Amin Bandali wrote on 6 Aug 2019 08:42
(address . guix-patches@gnu.org)
87sgqevlq4.fsf@fencepost.gnu.org
This adds EBDB, an EIEIO port (rewrite) of BBDB.

The package depends on cl-lib and seq. I don’t see any mention of
cl-lib in emacs-xyz.scm, but I do see an ‘emacs-seq’ there, and it’s
used in propagated-inputs of three packages. What’s the preferred way?
Is it fine to omit seq (and other Emacs Core packages that were also
added to GNU ELPA for users of older versions of Emacs), or would it be
best to explicitly add it in propagated-inputs?
From 18afb4972d831dffe45e4e2eb63072becd0db4c2 Mon Sep 17 00:00:00 2001
From: Amin Bandali <bandali@gnu.org>
Date: Mon, 5 Aug 2019 23:06:07 -0400
Subject: [PATCH] gnu: Add emacs-ebdb.

* gnu/packages/emacs-xyz.scm (emacs-ebdb): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1b6e02bcbc..ee7cd66f60 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autitici.org>
;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
+;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17186,3 +17187,26 @@ time.")
(description "@code{mastodon.el} is an Emacs client for Mastodon, the
federated microblogging social network.")
(license license:gpl3+)))
+
+(define-public emacs-ebdb
+ (let ((commit "2a87f5ed2a53e3a4e91e8c88ba5afc49f5e945df")
+ (revision "0"))
+ (package
+ (name "emacs-ebdb")
+ (version (git-version "0.6.10" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/girzel/ebdb.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fidy7z0c86dpqiss97sg5s92fd3fj4bdl8pqqdgg2m00jx4mrjz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/girzel/ebdb")
+ (synopsis "EIEIO port of BBDB, Emacs's contact-management package")
+ (description "EBDB is a contact management/addressbook package for
+Emacs. It's a re-write of the Insidious Big Brother Database (BBDB) using
+Emacs Lisp's (relatively new) EIEIO object oriented libraries.")
+ (license license:gpl3+))))
--
2.22.0
N
N
Nicolas Goaziou wrote on 6 Aug 2019 09:44
(name . Amin Bandali)(address . bandali@gnu.org)(address . 36943@debbugs.gnu.org)
87a7cmivpq.fsf@nicolasgoaziou.fr
Hello,

Amin Bandali <bandali@gnu.org> writes:

Toggle quote (9 lines)
> This adds EBDB, an EIEIO port (rewrite) of BBDB.
>
> The package depends on cl-lib and seq. I don’t see any mention of
> cl-lib in emacs-xyz.scm, but I do see an ‘emacs-seq’ there, and it’s
> used in propagated-inputs of three packages. What’s the preferred way?
> Is it fine to omit seq (and other Emacs Core packages that were also
> added to GNU ELPA for users of older versions of Emacs), or would it be
> best to explicitly add it in propagated-inputs?

The package should build without emacs-seq and cl-lib, since Guix ships
with Emacs 25+, so I don't think these packages should be propagated.

Regards,

--
Nicolas Goaziou
A
A
Amin Bandali wrote on 11 Aug 2019 18:04
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 36943@debbugs.gnu.org)
87tvan664p.fsf@fencepost.gnu.org
Hello,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (3 lines)
> Hello,
>

[...]

Toggle quote (6 lines)
>
> The package should build without emacs-seq and cl-lib, since Guix ships
> with Emacs 25+, so I don't think these packages should be propagated.
>
> Regards,

Thanks for the reply, makes sense. In that case this should be good to
go, I think. I’d appreciate it if you or someone applied the patch.

I have a few more emacs-xyz patches lined up that I’ll send along soon.

Best,

--
Amin Bandali
Free Software Activist | GNU Webmaster & Volunteer
GPG: BE62 7373 8E61 6D6D 1B3A 08E8 A21A 0202 4881 6103
R
R
Ricardo Wurmus wrote on 13 Aug 2019 12:19
(name . Amin Bandali)(address . bandali@gnu.org)
87blwtv038.fsf@elephly.net
Hi Amin,

I’ve pushed it with a comment about why this version was picked with
commit f9ccde2460.

Thanks!

--
Ricardo
Closed
?