[PATCH] packages: Apply target triplet in bag-transitive-host-inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • David Thompson
  • Ludovic Courtès
Owner
unassigned
Submitted by
David Thompson
Severity
normal
D
D
David Thompson wrote on 14 Aug 2019 14:57
(address . guix-patches@gnu.org)(name . David Thompson)(address . dthompson2@worcester.edu)
20190814125755.18360-1-dthompson2@worcester.edu
Fixes a bug where propagated inputs that should be cross-compiled are instead
compiled for the host system.

* guix/packages.scm (bag-transitive-host-inputs): Call transitive-inputs in
the context of the bag's target system triplet.
---
guix/packages.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/guix/packages.scm b/guix/packages.scm
index c94a651f27..143417b861 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -796,7 +796,8 @@ dependencies are known to build on SYSTEM."
(define (bag-transitive-host-inputs bag)
"Same as 'package-transitive-target-inputs', but applied to a bag."
- (transitive-inputs (bag-host-inputs bag)))
+ (parameterize ((%current-target-system (bag-target bag)))
+ (transitive-inputs (bag-host-inputs bag))))
(define (bag-transitive-target-inputs bag)
"Return the \"target inputs\" of BAG, recursively."
--
2.17.1
L
L
Ludovic Courtès wrote on 23 Aug 2019 23:31
(name . David Thompson)(address . dthompson2@worcester.edu)(address . 37026@debbugs.gnu.org)
87r25bzi03.fsf@gnu.org
Hello,

David Thompson <dthompson2@worcester.edu> skribis:

Toggle quote (21 lines)
> Fixes a bug where propagated inputs that should be cross-compiled are instead
> compiled for the host system.
>
> * guix/packages.scm (bag-transitive-host-inputs): Call transitive-inputs in
> the context of the bag's target system triplet.
> ---
> guix/packages.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/guix/packages.scm b/guix/packages.scm
> index c94a651f27..143417b861 100644
> --- a/guix/packages.scm
> +++ b/guix/packages.scm
> @@ -796,7 +796,8 @@ dependencies are known to build on SYSTEM."
>
> (define (bag-transitive-host-inputs bag)
> "Same as 'package-transitive-target-inputs', but applied to a bag."
> - (transitive-inputs (bag-host-inputs bag)))
> + (parameterize ((%current-target-system (bag-target bag)))
> + (transitive-inputs (bag-host-inputs bag))))

Good catch, please push!

Thanks,
Ludo’.
T
T
Thompson, David wrote on 26 Aug 2019 15:38
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37026-done@debbugs.gnu.org)
CAJ=RwfbSiu3Lb=msH4iKe_gSGVux56Yj+Uq+4x1gvS=1bF7QYA@mail.gmail.com
On Fri, Aug 23, 2019 at 5:31 PM Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (3 lines)
>
> Good catch, please push!

Thanks. Done!

- Dave
Closed
?